Skip to content

Class: ScanActivity

Scan events report the start, completion, and results of a scan job. The scan

event includes the number of items that were scanned and the number of

detections that were resolved.

URI: ocsf:ScanActivity

 classDiagram
    class ScanActivity
    click ScanActivity href "../ScanActivity/"
      ApplicationEvent <|-- ScanActivity
        click ApplicationEvent href "../ApplicationEvent/"

      ScanActivity : action

      ScanActivity : action_id





        ScanActivity --> "0..1 _recommended_" ActionIdEnum : action_id
        click ActionIdEnum href "../ActionIdEnum/"



      ScanActivity : activity_id





        ScanActivity --> "1" ScanActivityActivityIdEnum : activity_id
        click ScanActivityActivityIdEnum href "../ScanActivityActivityIdEnum/"



      ScanActivity : activity_name

      ScanActivity : actor





        ScanActivity --> "0..1" Actor : actor
        click Actor href "../Actor/"



      ScanActivity : api





        ScanActivity --> "0..1" Api : api
        click Api href "../Api/"



      ScanActivity : attacks





        ScanActivity --> "*" Attack : attacks
        click Attack href "../Attack/"



      ScanActivity : authorizations





        ScanActivity --> "*" Authorization : authorizations
        click Authorization href "../Authorization/"



      ScanActivity : category_name

      ScanActivity : category_uid





        ScanActivity --> "1" BaseEventCategoryUidEnum : category_uid
        click BaseEventCategoryUidEnum href "../BaseEventCategoryUidEnum/"



      ScanActivity : class_name

      ScanActivity : class_uid





        ScanActivity --> "1" BaseEventClassUidEnum : class_uid
        click BaseEventClassUidEnum href "../BaseEventClassUidEnum/"



      ScanActivity : cloud





        ScanActivity --> "1" Cloud : cloud
        click Cloud href "../Cloud/"



      ScanActivity : command_uid

      ScanActivity : confidence

      ScanActivity : confidence_id





        ScanActivity --> "0..1 _recommended_" ConfidenceIdEnum : confidence_id
        click ConfidenceIdEnum href "../ConfidenceIdEnum/"



      ScanActivity : confidence_score

      ScanActivity : count

      ScanActivity : device





        ScanActivity --> "0..1 _recommended_" Device : device
        click Device href "../Device/"



      ScanActivity : disposition

      ScanActivity : disposition_id





        ScanActivity --> "0..1 _recommended_" DispositionIdEnum : disposition_id
        click DispositionIdEnum href "../DispositionIdEnum/"



      ScanActivity : duration

      ScanActivity : end_time

      ScanActivity : enrichments





        ScanActivity --> "*" Enrichment : enrichments
        click Enrichment href "../Enrichment/"



      ScanActivity : firewall_rule





        ScanActivity --> "0..1" FirewallRule : firewall_rule
        click FirewallRule href "../FirewallRule/"



      ScanActivity : is_alert

      ScanActivity : malware





        ScanActivity --> "*" Malware : malware
        click Malware href "../Malware/"



      ScanActivity : malware_scan_info





        ScanActivity --> "0..1" MalwareScanInfo : malware_scan_info
        click MalwareScanInfo href "../MalwareScanInfo/"



      ScanActivity : message

      ScanActivity : metadata





        ScanActivity --> "1" Metadata : metadata
        click Metadata href "../Metadata/"



      ScanActivity : num_detections

      ScanActivity : num_files

      ScanActivity : num_folders

      ScanActivity : num_network_items

      ScanActivity : num_processes

      ScanActivity : num_registry_items

      ScanActivity : num_resolutions

      ScanActivity : num_skipped_items

      ScanActivity : num_trusted_items

      ScanActivity : observables





        ScanActivity --> "* _recommended_" Observable : observables
        click Observable href "../Observable/"



      ScanActivity : osint





        ScanActivity --> "1..*" Osint : osint
        click Osint href "../Osint/"



      ScanActivity : policy





        ScanActivity --> "0..1 _recommended_" Policy : policy
        click Policy href "../Policy/"



      ScanActivity : raw_data

      ScanActivity : raw_data_hash





        ScanActivity --> "0..1" Fingerprint : raw_data_hash
        click Fingerprint href "../Fingerprint/"



      ScanActivity : raw_data_size

      ScanActivity : risk_details

      ScanActivity : risk_level

      ScanActivity : risk_level_id





        ScanActivity --> "0..1" RiskLevelIdEnum : risk_level_id
        click RiskLevelIdEnum href "../RiskLevelIdEnum/"



      ScanActivity : risk_score

      ScanActivity : scan





        ScanActivity --> "1" Scan : scan
        click Scan href "../Scan/"



      ScanActivity : schedule_uid

      ScanActivity : severity

      ScanActivity : severity_id





        ScanActivity --> "1" SeverityIdEnum : severity_id
        click SeverityIdEnum href "../SeverityIdEnum/"



      ScanActivity : start_time

      ScanActivity : status

      ScanActivity : status_code

      ScanActivity : status_detail

      ScanActivity : status_id





        ScanActivity --> "0..1 _recommended_" StatusIdEnum : status_id
        click StatusIdEnum href "../StatusIdEnum/"



      ScanActivity : time

      ScanActivity : timezone_offset

      ScanActivity : total

      ScanActivity : type_name

      ScanActivity : type_uid

      ScanActivity : unmapped





        ScanActivity --> "0..1" Object : unmapped
        click Object href "../Object/"



Inheritance

Slots

Name Cardinality and Range Description Inheritance
activity_id 1
ScanActivityActivityIdEnum
The normalized identifier of the activity that triggered the event direct
command_uid 0..1 recommended
String
The command identifier that is associated with this scan event direct
duration 0..1 recommended
Integer
The duration of the scan direct
end_time 0..1 recommended
TimestampT
The end time of the scan job direct
num_detections 0..1 recommended
Integer
The number of detections direct
num_files 0..1 recommended
Integer
The number of files scanned direct
num_folders 0..1 recommended
Integer
The number of folders scanned direct
num_network_items 0..1 recommended
Integer
The number of network items scanned direct
num_processes 0..1 recommended
Integer
The number of processes scanned direct
num_registry_items 0..1 recommended
Integer
The number of registry items scanned direct
num_resolutions 0..1 recommended
Integer
The number of items that were resolved direct
num_skipped_items 0..1 recommended
Integer
The number of skipped items direct
num_trusted_items 0..1 recommended
Integer
The number of trusted items direct
policy 0..1 recommended
Policy
The policy associated with this Scan event; required if the scan was initiate... direct
scan 1
Scan
The Scan object describes characteristics of the scan job direct
schedule_uid 0..1 recommended
String
The unique identifier of the schedule associated with a scan job direct
start_time 0..1 recommended
TimestampT
The start time of the scan job direct
total 0..1 recommended
Integer
The total number of items that were scanned; zero if no items were scanned direct
activity_name 0..1
String
The event activity name, as defined by the activity_id BaseEvent
category_name 0..1
String
The event category name, as defined by category_uid value BaseEvent
category_uid 1
BaseEventCategoryUidEnum
The category unique identifier of the event BaseEvent
class_name 0..1
String
The event class name, as defined by class_uid value BaseEvent
class_uid 1
BaseEventClassUidEnum
The unique identifier of a class BaseEvent
count 0..1
Integer
The number of times that events in the same logical group occurred during the BaseEvent
enrichments *
Enrichment
The additional information from an external data source, which is associated BaseEvent
message 0..1 recommended
String
The description of the event/finding, as defined by the source BaseEvent
metadata 1
Metadata
The metadata associated with the event or a finding BaseEvent
observables * recommended
Observable
The observables associated with the event or a finding BaseEvent
raw_data 0..1
String
The raw event/finding data as received from the source BaseEvent
raw_data_hash 0..1
Fingerprint
The hash, which describes the content of the raw_data field BaseEvent
raw_data_size 0..1
Integer
The size of the raw data which was transformed into an OCSF event, in bytes BaseEvent
severity 0..1
String
The event/finding severity, normalized to the caption of the BaseEvent
severity_id 1
SeverityIdEnum

The normalized identifier of the event/finding severity

BaseEvent
status 0..1 recommended
String
The event status, normalized to the caption of the status_id value BaseEvent
status_code 0..1 recommended
String
The event status code, as reported by the event source BaseEvent
status_detail 0..1 recommended
String
The status detail contains additional information about the event/finding BaseEvent
status_id 0..1 recommended
StatusIdEnum
The normalized identifier of the event status BaseEvent
time 1
TimestampT
The normalized event occurrence time or the finding creation time BaseEvent
timezone_offset 0..1 recommended
Integer
The number of minutes that the reported event time is ahead or BaseEvent
type_name 0..1
String
The event/finding type name, as defined by the type_uid BaseEvent
type_uid 1
Integer
The event/finding type ID BaseEvent
unmapped 0..1
Object
The attributes that are not mapped to the event schema BaseEvent
api 0..1
Api
Describes details about a typical API (Application Programming Interface) cal... CloudProfile
cloud 1
Cloud
Describes details about the Cloud environment where the event or finding was CloudProfile
actor 0..1
Actor
The actor object describes details about the user/role/process that was the HostProfile
device 0..1 recommended
Device
An addressable device, computer system or host HostProfile
osint 1..*
Osint
The OSINT (Open Source Intelligence) object contains details related to an OsintProfile
action 0..1
String
The normalized caption of action_id SecurityControlProfile
action_id 0..1 recommended
ActionIdEnum
The action taken by a control or other policy-based system leading to an SecurityControlProfile
attacks *
Attack
An array of MITRE ATT&CK® objects describing identified tactics, techniques & SecurityControlProfile
authorizations *
Authorization
Provides details about an authorization, such as authorization outcome, and a... SecurityControlProfile
confidence 0..1
String
The confidence, normalized to the caption of the confidence_id value SecurityControlProfile
confidence_id 0..1 recommended
ConfidenceIdEnum
The normalized confidence refers to the accuracy of the rule that created the SecurityControlProfile
confidence_score 0..1
Integer
The confidence score as reported by the event source SecurityControlProfile
disposition 0..1
String
The disposition name, normalized to the caption of the disposition_id value SecurityControlProfile
disposition_id 0..1 recommended
DispositionIdEnum
Describes the outcome or action taken by a security control, such as access SecurityControlProfile
firewall_rule 0..1
FirewallRule
The firewall rule that pertains to the control that triggered the event, if SecurityControlProfile
is_alert 0..1 recommended
Boolean
Indicates that the event is considered to be an alertable signal SecurityControlProfile
malware *
Malware
A list of Malware objects, describing details about the identified malware SecurityControlProfile
malware_scan_info 0..1
MalwareScanInfo
Describes details about the scan job that identified malware on the target SecurityControlProfile
risk_details 0..1
String
Describes the risk associated with the finding SecurityControlProfile
risk_level 0..1
String
The risk level, normalized to the caption of the risk_level_id value SecurityControlProfile
risk_level_id 0..1
RiskLevelIdEnum
The normalized risk level id SecurityControlProfile
risk_score 0..1
Integer
The risk score as reported by the event source SecurityControlProfile

In Subsets

Aliases

  • Scan Activity

Identifier and Mapping Information

Annotations

property value
ocsf_event_uid 7

Schema Source

Mappings

Mapping Type Mapped Value
self ocsf:ScanActivity
native ocsf:ScanActivity

LinkML Source

Direct

name: ScanActivity
annotations:
  ocsf_event_uid:
    tag: ocsf_event_uid
    value: 7
description: 'Scan events report the start, completion, and results of a scan job.
  The scan

  event includes the number of items that were scanned and the number of

  detections that were resolved.'
in_subset:
- application_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Scan Activity
is_a: ApplicationEvent
slots:
- activity_id
- command_uid
- duration
- end_time
- num_detections
- num_files
- num_folders
- num_network_items
- num_processes
- num_registry_items
- num_resolutions
- num_skipped_items
- num_trusted_items
- policy
- scan
- schedule_uid
- start_time
- total
slot_usage:
  activity_id:
    name: activity_id
    range: ScanActivityActivityIdEnum
  command_uid:
    name: command_uid
    annotations:
      group:
        tag: group
        value: primary
    description: 'The command identifier that is associated with this scan event.  This
      ID

      uniquely identifies the proactive scan command, e.g., if remotely initiated.'
    recommended: true
  duration:
    name: duration
    description: The duration of the scan
    recommended: true
  end_time:
    name: end_time
    description: The end time of the scan job.
    recommended: true
  num_detections:
    name: num_detections
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_files:
    name: num_files
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_folders:
    name: num_folders
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_network_items:
    name: num_network_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_processes:
    name: num_processes
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_registry_items:
    name: num_registry_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_resolutions:
    name: num_resolutions
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_skipped_items:
    name: num_skipped_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_trusted_items:
    name: num_trusted_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  policy:
    name: policy
    annotations:
      group:
        tag: group
        value: primary
    description: 'The policy associated with this Scan event; required if the scan
      was initiated

      by a policy.'
    recommended: true
  scan:
    name: scan
    annotations:
      group:
        tag: group
        value: primary
    description: The Scan object describes characteristics of the scan job.
    required: true
  schedule_uid:
    name: schedule_uid
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  start_time:
    name: start_time
    description: The start time of the scan job.
    recommended: true
  total:
    name: total
    annotations:
      group:
        tag: group
        value: primary
    description: The total number of items that were scanned; zero if no items were
      scanned.
    recommended: true

Induced

name: ScanActivity
annotations:
  ocsf_event_uid:
    tag: ocsf_event_uid
    value: 7
description: 'Scan events report the start, completion, and results of a scan job.
  The scan

  event includes the number of items that were scanned and the number of

  detections that were resolved.'
in_subset:
- application_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Scan Activity
is_a: ApplicationEvent
slot_usage:
  activity_id:
    name: activity_id
    range: ScanActivityActivityIdEnum
  command_uid:
    name: command_uid
    annotations:
      group:
        tag: group
        value: primary
    description: 'The command identifier that is associated with this scan event.  This
      ID

      uniquely identifies the proactive scan command, e.g., if remotely initiated.'
    recommended: true
  duration:
    name: duration
    description: The duration of the scan
    recommended: true
  end_time:
    name: end_time
    description: The end time of the scan job.
    recommended: true
  num_detections:
    name: num_detections
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_files:
    name: num_files
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_folders:
    name: num_folders
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_network_items:
    name: num_network_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_processes:
    name: num_processes
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_registry_items:
    name: num_registry_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_resolutions:
    name: num_resolutions
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_skipped_items:
    name: num_skipped_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  num_trusted_items:
    name: num_trusted_items
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  policy:
    name: policy
    annotations:
      group:
        tag: group
        value: primary
    description: 'The policy associated with this Scan event; required if the scan
      was initiated

      by a policy.'
    recommended: true
  scan:
    name: scan
    annotations:
      group:
        tag: group
        value: primary
    description: The Scan object describes characteristics of the scan job.
    required: true
  schedule_uid:
    name: schedule_uid
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  start_time:
    name: start_time
    description: The start time of the scan job.
    recommended: true
  total:
    name: total
    annotations:
      group:
        tag: group
        value: primary
    description: The total number of items that were scanned; zero if no items were
      scanned.
    recommended: true
attributes:
  activity_id:
    name: activity_id
    annotations:
      group:
        tag: group
        value: classification
    description: The normalized identifier of the activity that triggered the event.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Activity ID
    rank: 1000
    alias: activity_id
    owner: ScanActivity
    domain_of:
    - BaseEvent
    - ApiActivity
    - ApplicationError
    - ApplicationLifecycle
    - DatastoreActivity
    - FileHosting
    - ScanActivity
    - WebResourceAccessActivity
    - WebResourcesActivity
    - DiscoveryEvent
    - DiscoveryResult
    - DataSecurityFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    - AccountChange
    - Authentication
    - AuthorizeSession
    - EntityManagement
    - GroupManagement
    - UserAccess
    - DhcpActivity
    - DnsActivity
    - EmailActivity
    - EmailFileActivity
    - EmailUrlActivity
    - FtpActivity
    - HttpActivity
    - NetworkActivity
    - NetworkFileActivity
    - NtpActivity
    - RdpActivity
    - SmbActivity
    - SshActivity
    - TunnelActivity
    - RemediationActivity
    - EventLogActvity
    - FileActivity
    - KernelActivity
    - KernelExtensionActivity
    - MemoryActivity
    - ModuleActivity
    - PeripheralActivity
    - ProcessActivity
    - ScheduledJobActivity
    - ScriptActivity
    - AirborneBroadcastActivity
    - DroneFlightsActivity
    - RegistryKeyActivity
    - RegistryValueActivity
    - WindowsResourceActivity
    - WindowsServiceActivity
    range: ScanActivityActivityIdEnum
    required: true
  command_uid:
    name: command_uid
    annotations:
      group:
        tag: group
        value: primary
    description: 'The command identifier that is associated with this scan event.  This
      ID

      uniquely identifies the proactive scan command, e.g., if remotely initiated.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Command UID
    rank: 1000
    alias: command_uid
    owner: ScanActivity
    domain_of:
    - ScanActivity
    - RemediationActivity
    range: string
    recommended: true
  duration:
    name: duration
    annotations:
      group:
        tag: group
        value: occurrence
    description: The duration of the scan
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Duration Milliseconds
    rank: 1000
    alias: duration
    owner: ScanActivity
    domain_of:
    - Span
    - Timespan
    - Trace
    - FirewallRule
    - BaseEvent
    - ScanActivity
    range: integer
    recommended: true
  end_time:
    name: end_time
    annotations:
      group:
        tag: group
        value: occurrence
    description: The end time of the scan job.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - End Time
    rank: 1000
    alias: end_time
    owner: ScanActivity
    domain_of:
    - Span
    - Timespan
    - Trace
    - NetworkTraffic
    - UnmannedSystemOperatingArea
    - MalwareScanInfo
    - BaseEvent
    - ScanActivity
    - Finding
    - IncidentFinding
    range: TimestampT
    recommended: true
  num_detections:
    name: num_detections
    annotations:
      group:
        tag: group
        value: primary
    description: The number of detections.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Detections
    rank: 1000
    alias: num_detections
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  num_files:
    name: num_files
    annotations:
      group:
        tag: group
        value: primary
    description: The number of files scanned.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Scanned Files
    rank: 1000
    alias: num_files
    owner: ScanActivity
    domain_of:
    - MalwareScanInfo
    - ScanActivity
    range: integer
    recommended: true
  num_folders:
    name: num_folders
    annotations:
      group:
        tag: group
        value: primary
    description: The number of folders scanned.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Scanned Folders
    rank: 1000
    alias: num_folders
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  num_network_items:
    name: num_network_items
    annotations:
      group:
        tag: group
        value: primary
    description: The number of network items scanned.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Scanned Network Items
    rank: 1000
    alias: num_network_items
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  num_processes:
    name: num_processes
    annotations:
      group:
        tag: group
        value: primary
    description: The number of processes scanned.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Scanned Processes
    rank: 1000
    alias: num_processes
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  num_registry_items:
    name: num_registry_items
    annotations:
      group:
        tag: group
        value: primary
    description: The number of registry items scanned.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Scanned Registry Items
    rank: 1000
    alias: num_registry_items
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  num_resolutions:
    name: num_resolutions
    annotations:
      group:
        tag: group
        value: primary
    description: The number of items that were resolved.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Resolutions
    rank: 1000
    alias: num_resolutions
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  num_skipped_items:
    name: num_skipped_items
    annotations:
      group:
        tag: group
        value: primary
    description: The number of skipped items.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Skipped
    rank: 1000
    alias: num_skipped_items
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  num_trusted_items:
    name: num_trusted_items
    annotations:
      group:
        tag: group
        value: primary
    description: The number of trusted items.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Trusted
    rank: 1000
    alias: num_trusted_items
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: integer
    recommended: true
  policy:
    name: policy
    annotations:
      group:
        tag: group
        value: primary
    description: 'The policy associated with this Scan event; required if the scan
      was initiated

      by a policy.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Policy
    rank: 1000
    alias: policy
    owner: ScanActivity
    domain_of:
    - PermissionAnalysisResult
    - AdditionalRestriction
    - Assessment
    - Authorization
    - DataClassification
    - DataSecurity
    - ManagedEntity
    - SecurityControlProfile
    - ScanActivity
    - AccountChange
    range: Policy
    recommended: true
  scan:
    name: scan
    annotations:
      group:
        tag: group
        value: primary
    description: The Scan object describes characteristics of the scan job.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Scan
    rank: 1000
    alias: scan
    owner: ScanActivity
    domain_of:
    - ScanActivity
    - RemediationActivity
    range: Scan
    required: true
  schedule_uid:
    name: schedule_uid
    annotations:
      group:
        tag: group
        value: primary
    description: The unique identifier of the schedule associated with a scan job.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Schedule UID
    rank: 1000
    alias: schedule_uid
    owner: ScanActivity
    domain_of:
    - ScanActivity
    range: string
    recommended: true
  start_time:
    name: start_time
    annotations:
      group:
        tag: group
        value: occurrence
    description: The start time of the scan job.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Start Time
    rank: 1000
    alias: start_time
    owner: ScanActivity
    domain_of:
    - Span
    - Timespan
    - Trace
    - NetworkTraffic
    - UnmannedSystemOperatingArea
    - MalwareScanInfo
    - BaseEvent
    - ScanActivity
    - Finding
    - IncidentFinding
    range: TimestampT
    recommended: true
  total:
    name: total
    annotations:
      group:
        tag: group
        value: primary
    description: The total number of items that were scanned; zero if no items were
      scanned.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Total
    rank: 1000
    alias: total
    owner: ScanActivity
    domain_of:
    - DataClassification
    - ScanActivity
    range: integer
    recommended: true
  activity_name:
    name: activity_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event activity name, as defined by the activity_id.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Activity
    rank: 1000
    alias: activity_name
    owner: ScanActivity
    domain_of:
    - BaseEvent
    - DataSecurityFinding
    - Finding
    - IncidentFinding
    range: string
  category_name:
    name: category_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event category name, as defined by category_uid value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Category
    rank: 1000
    alias: category_name
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: string
  category_uid:
    name: category_uid
    annotations:
      group:
        tag: group
        value: classification
    description: The category unique identifier of the event.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Category ID
    rank: 1000
    alias: category_uid
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: BaseEventCategoryUidEnum
    required: true
  class_name:
    name: class_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event class name, as defined by class_uid value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Class
    rank: 1000
    alias: class_name
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: string
  class_uid:
    name: class_uid
    annotations:
      group:
        tag: group
        value: classification
    description: 'The unique identifier of a class. A class describes the attributes
      available in

      an event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Class ID
    rank: 1000
    alias: class_uid
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: BaseEventClassUidEnum
    required: true
  count:
    name: count
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The number of times that events in the same logical group occurred
      during the

      event <strong>Start Time</strong> to <strong>End Time</strong> period.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Count
    rank: 1000
    alias: count
    owner: ScanActivity
    domain_of:
    - Observation
    - RelatedEvent
    - Session
    - DiscoveryDetails
    - UnmannedSystemOperatingArea
    - BaseEvent
    range: integer
  enrichments:
    name: enrichments
    annotations:
      group:
        tag: group
        value: context
    description: 'The additional information from an external data source, which is
      associated

      with the event or a finding. For example add location information for the IP

      address in the DNS answers:</p><code>[{"name": "answers.ip", "value":

      "92.24.47.250", "type": "location", "data": {"city": "Socotra", "continent":

      "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc":

      "Yemen"}}]</code>'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Enrichments
    rank: 1000
    alias: enrichments
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: Enrichment
    multivalued: true
  message:
    name: message
    annotations:
      group:
        tag: group
        value: primary
    description: The description of the event/finding, as defined by the source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Message
    rank: 1000
    alias: message
    owner: ScanActivity
    domain_of:
    - Response
    - Span
    - HttpResponse
    - LoadBalancer
    - BaseEvent
    - ApplicationError
    range: string
    recommended: true
  metadata:
    name: metadata
    annotations:
      group:
        tag: group
        value: context
    description: The metadata associated with the event or a finding.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Metadata
    rank: 1000
    alias: metadata
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: Metadata
    required: true
  observables:
    name: observables
    annotations:
      group:
        tag: group
        value: primary
    description: The observables associated with the event or a finding.
    notes:
    - 'OCSF Observables FAQ 

      https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md'
    from_schema: https://w3id.org/lmodel/ocsf
    see_also:
    - https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md
    aliases:
    - Observables
    rank: 1000
    alias: observables
    owner: ScanActivity
    domain_of:
    - RelatedEvent
    - BaseEvent
    range: Observable
    recommended: true
    multivalued: true
  raw_data:
    name: raw_data
    annotations:
      group:
        tag: group
        value: context
    description: The raw event/finding data as received from the source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data
    rank: 1000
    alias: raw_data
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: string
  raw_data_hash:
    name: raw_data_hash
    annotations:
      group:
        tag: group
        value: context
    description: The hash, which describes the content of the raw_data field.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data Hash
    rank: 1000
    alias: raw_data_hash
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: Fingerprint
  raw_data_size:
    name: raw_data_size
    annotations:
      group:
        tag: group
        value: context
    description: The size of the raw data which was transformed into an OCSF event,
      in bytes.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data Size
    rank: 1000
    alias: raw_data_size
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: integer
  severity:
    name: severity
    annotations:
      group:
        tag: group
        value: classification
    description: 'The event/finding severity, normalized to the caption of the

      <code>severity_id</code> value. In the case of ''Other'', it is defined by the

      source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Severity
    rank: 1000
    alias: severity
    owner: ScanActivity
    domain_of:
    - Osint
    - RelatedEvent
    - VendorAttributes
    - Vulnerability
    - Check
    - Cvss
    - KbArticle
    - Malware
    - BaseEvent
    range: string
  severity_id:
    name: severity_id
    annotations:
      group:
        tag: group
        value: classification
    description: '<p>The normalized identifier of the event/finding severity.</p>The
      normalized

      severity is a measurement the effort and expense required to manage and resolve

      an event or incident. Smaller numerical values represent lower impact events,

      and larger numerical values represent higher impact events.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Severity ID
    rank: 1000
    alias: severity_id
    owner: ScanActivity
    domain_of:
    - Osint
    - RelatedEvent
    - VendorAttributes
    - Check
    - Malware
    - BaseEvent
    range: SeverityIdEnum
    required: true
  status:
    name: status
    annotations:
      group:
        tag: group
        value: primary
    description: 'The event status, normalized to the caption of the status_id value.
      In the case

      of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status
    rank: 1000
    alias: status
    owner: ScanActivity
    domain_of:
    - RelatedEvent
    - Ticket
    - Whois
    - AdditionalRestriction
    - Check
    - Compliance
    - DataClassification
    - HttpResponse
    - BaseEvent
    - Finding
    - IncidentFinding
    - DroneFlightsActivity
    range: string
    recommended: true
  status_code:
    name: status_code
    annotations:
      group:
        tag: group
        value: primary
    description: 'The event status code, as reported by the event source.<br /><br
      />For example,

      in a Windows Failed Authentication event, this would be the value of ''Failure

      Code'', e.g. 0x18.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status Code
    rank: 1000
    alias: status_code
    owner: ScanActivity
    domain_of:
    - Span
    - Compliance
    - BaseEvent
    - EventLogActvity
    range: string
    recommended: true
  status_detail:
    name: status_detail
    annotations:
      group:
        tag: group
        value: primary
    description: 'The status detail contains additional information about the event/finding

      outcome.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status Detail
    rank: 1000
    alias: status_detail
    owner: ScanActivity
    domain_of:
    - Compliance
    - LoadBalancer
    - BaseEvent
    - Authentication
    - EventLogActvity
    range: string
    recommended: true
  status_id:
    name: status_id
    annotations:
      group:
        tag: group
        value: primary
    description: The normalized identifier of the event status.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status ID
    rank: 1000
    alias: status_id
    owner: ScanActivity
    domain_of:
    - Ticket
    - AdditionalRestriction
    - Check
    - Compliance
    - DataClassification
    - BaseEvent
    - Finding
    - IncidentFinding
    - RemediationActivity
    - DroneFlightsActivity
    range: StatusIdEnum
    recommended: true
  time:
    name: time
    annotations:
      group:
        tag: group
        value: occurrence
    description: The normalized event occurrence time or the finding creation time.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Event Time
    rank: 1000
    alias: time
    owner: ScanActivity
    domain_of:
    - TransformationInfo
    - BaseEvent
    range: TimestampT
    required: true
  timezone_offset:
    name: timezone_offset
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The number of minutes that the reported event <code>time</code>
      is ahead or

      behind UTC, in the range -1,080 to +1,080.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Timezone Offset
    rank: 1000
    alias: timezone_offset
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: integer
    recommended: true
  type_name:
    name: type_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event/finding type name, as defined by the type_uid.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type Name
    rank: 1000
    alias: type_name
    owner: ScanActivity
    domain_of:
    - RelatedEvent
    - BaseEvent
    range: string
  type_uid:
    name: type_uid
    annotations:
      group:
        tag: group
        value: classification
    description: 'The event/finding type ID. It identifies the event''s semantics
      and structure.

      The value is calculated by the logging system as: <code>class_uid * 100 +

      activity_id</code>.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type ID
    rank: 1000
    alias: type_uid
    owner: ScanActivity
    domain_of:
    - Observable
    - RelatedEvent
    - BaseEvent
    range: integer
    required: true
  unmapped:
    name: unmapped
    annotations:
      group:
        tag: group
        value: context
    description: 'The attributes that are not mapped to the event schema. The names
      and values of

      those attributes are specific to the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Unmapped Data
    rank: 1000
    alias: unmapped
    owner: ScanActivity
    domain_of:
    - BaseEvent
    range: Object
  api:
    name: api
    annotations:
      group:
        tag: group
        value: context
    description: Describes details about a typical API (Application Programming Interface)
      call.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - API Details
    rank: 1000
    alias: api
    owner: ScanActivity
    domain_of:
    - Evidences
    - CloudProfile
    - ApiActivity
    range: Api
  cloud:
    name: cloud
    annotations:
      group:
        tag: group
        value: primary
    description: 'Describes details about the Cloud environment where the event or
      finding was

      created.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Cloud
    rank: 1000
    alias: cloud
    owner: ScanActivity
    domain_of:
    - CloudProfile
    - CloudResourcesInventoryInfo
    range: Cloud
    required: true
  actor:
    name: actor
    description: 'The actor object describes details about the user/role/process that
      was the

      source of the activity. Note that this is not the threat actor of a campaign

      but may be part of a campaign.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Actor
    rank: 1000
    alias: actor
    owner: ScanActivity
    domain_of:
    - Evidences
    - HostProfile
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - ConfigState
    - DeviceConfigStateChange
    - InventoryInfo
    - OsintInventoryInfo
    - SoftwareInfo
    - UserInventory
    - DataSecurityFinding
    - IamEvent
    - NetworkFileActivity
    - SystemEvent
    - EventLogActvity
    - FileActivity
    - KernelExtensionActivity
    - ModuleActivity
    - ProcessActivity
    - ScheduledJobActivity
    - RegistryKeyActivity
    - RegistryValueActivity
    range: Actor
  device:
    name: device
    description: An addressable device, computer system or host.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Device
    rank: 1000
    alias: device
    owner: ScanActivity
    domain_of:
    - AuthFactor
    - Evidences
    - Logger
    - ManagedEntity
    - HostProfile
    - ConfigState
    - DeviceConfigStateChange
    - EvidenceInfo
    - InventoryInfo
    - PatchState
    - SoftwareInfo
    - DataSecurityFinding
    - Finding
    - RdpActivity
    - TunnelActivity
    - SystemEvent
    - EventLogActvity
    range: Device
    recommended: true
  osint:
    name: osint
    annotations:
      group:
        tag: group
        value: primary
    description: 'The OSINT (Open Source Intelligence) object contains details related
      to an

      indicator such as the indicator itself, related indicators, geolocation,

      registrar information, subdomains, analyst commentary, and other contextual

      information. This information can be used to further enrich a detection or

      finding by providing decisioning support to other analysts and engineers.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - OSINT
    rank: 1000
    alias: osint
    owner: ScanActivity
    domain_of:
    - OsintProfile
    - OsintInventoryInfo
    range: Osint
    required: true
    multivalued: true
  action:
    name: action
    description: The normalized caption of <code>action_id</code>.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Action
    rank: 1000
    alias: action
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    range: string
  action_id:
    name: action_id
    annotations:
      sibling:
        tag: sibling
        value: action
    description: 'The action taken by a control or other policy-based system leading
      to an

      outcome or disposition. An unknown action may still correspond to a known

      disposition. Refer to <code>disposition_id</code> for the outcome of the

      action.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Action ID
    rank: 1000
    alias: action_id
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    range: ActionIdEnum
    recommended: true
  attacks:
    name: attacks
    description: 'An array of MITRE ATT&CK® objects describing identified tactics,
      techniques &

      sub-techniques. The objects are compatible with MITRE ATLAS™ tactics,

      techniques & sub-techniques.'
    notes:
    - MITRE ATT&CK® — https://attack.mitre.org
    - MITRE ATLAS — https://atlas.mitre.org/matrices/ATLAS
    from_schema: https://w3id.org/lmodel/ocsf
    see_also:
    - https://attack.mitre.org
    - https://atlas.mitre.org/matrices/ATLAS
    aliases:
    - MITRE ATT&CK® and ATLAS™ Details
    rank: 1000
    alias: attacks
    owner: ScanActivity
    domain_of:
    - Osint
    - RelatedEvent
    - FindingInfo
    - SecurityControlProfile
    - IncidentFinding
    - SecurityFinding
    range: Attack
    multivalued: true
  authorizations:
    name: authorizations
    description: 'Provides details about an authorization, such as authorization outcome,
      and any

      associated policies related to the activity/event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Authorization Information
    rank: 1000
    alias: authorizations
    owner: ScanActivity
    domain_of:
    - Actor
    - SecurityControlProfile
    range: Authorization
    multivalued: true
  confidence:
    name: confidence
    annotations:
      group:
        tag: group
        value: context
    description: 'The confidence, normalized to the caption of the confidence_id value.
      In the

      case of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence
    rank: 1000
    alias: confidence
    owner: ScanActivity
    domain_of:
    - Osint
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: string
  confidence_id:
    name: confidence_id
    annotations:
      group:
        tag: group
        value: context
    description: 'The normalized confidence refers to the accuracy of the rule that
      created the

      finding. A rule with a low confidence means that the finding scope is wide and

      may create finding reports that may not be malicious in nature.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence ID
    rank: 1000
    alias: confidence_id
    owner: ScanActivity
    domain_of:
    - Osint
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: ConfidenceIdEnum
    recommended: true
  confidence_score:
    name: confidence_score
    annotations:
      group:
        tag: group
        value: context
    description: The confidence score as reported by the event source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence Score
    rank: 1000
    alias: confidence_score
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: integer
  disposition:
    name: disposition
    description: 'The disposition name, normalized to the caption of the disposition_id
      value. In

      the case of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Disposition
    rank: 1000
    alias: disposition
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    range: string
  disposition_id:
    name: disposition_id
    annotations:
      sibling:
        tag: sibling
        value: disposition
    description: 'Describes the outcome or action taken by a security control, such
      as access

      control checks, malware detections or various types of policy violations.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Disposition ID
    rank: 1000
    alias: disposition_id
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    range: DispositionIdEnum
    recommended: true
  firewall_rule:
    name: firewall_rule
    description: 'The firewall rule that pertains to the control that triggered the
      event, if

      applicable.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Firewall Rule
    rank: 1000
    alias: firewall_rule
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    range: FirewallRule
  is_alert:
    name: is_alert
    description: 'Indicates that the event is considered to be an alertable signal.
      Should be set

      to <code>true</code> if <code>disposition_id = Alert</code> among other

      dispositions, and/or <code>risk_level_id</code> or <code>severity_id</code>
      of

      the event is elevated. Not all control events will be alertable, for example
      if

      <code>disposition_id = Exonerated</code> or <code>disposition_id =

      Allowed</code>.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Alert
    rank: 1000
    alias: is_alert
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    range: boolean
    recommended: true
  malware:
    name: malware
    description: A list of Malware objects, describing details about the identified
      malware.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Malware
    rank: 1000
    alias: malware
    owner: ScanActivity
    domain_of:
    - Osint
    - SecurityControlProfile
    - DetectionFinding
    - SecurityFinding
    range: Malware
    multivalued: true
  malware_scan_info:
    name: malware_scan_info
    description: 'Describes details about the scan job that identified malware on
      the target

      system.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Malware Scan Info
    rank: 1000
    alias: malware_scan_info
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    - DetectionFinding
    range: MalwareScanInfo
  risk_details:
    name: risk_details
    annotations:
      group:
        tag: group
        value: context
    description: Describes the risk associated with the finding.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Details
    rank: 1000
    alias: risk_details
    owner: ScanActivity
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    range: string
  risk_level:
    name: risk_level
    annotations:
      group:
        tag: group
        value: context
    description: The risk level, normalized to the caption of the risk_level_id value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Level
    rank: 1000
    alias: risk_level
    owner: ScanActivity
    domain_of:
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: string
  risk_level_id:
    name: risk_level_id
    annotations:
      group:
        tag: group
        value: context
    description: The normalized risk level id.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Level ID
    rank: 1000
    alias: risk_level_id
    owner: ScanActivity
    domain_of:
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: RiskLevelIdEnum
  risk_score:
    name: risk_score
    annotations:
      group:
        tag: group
        value: context
    description: The risk score as reported by the event source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Score
    rank: 1000
    alias: risk_score
    owner: ScanActivity
    domain_of:
    - Osint
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: integer