Class: FileHosting
File Hosting Activity events report the actions taken by file management
applications, including file sharing servers like Sharepoint and services such
as Box, MS OneDrive, Google Drive, or network file share services.
URI: ocsf:FileHosting
classDiagram
class FileHosting
click FileHosting href "../FileHosting/"
ApplicationEvent <|-- FileHosting
click ApplicationEvent href "../ApplicationEvent/"
FileHosting : access_list
FileHosting : access_mask
FileHosting : access_result
FileHosting : action
FileHosting : action_id
FileHosting --> "0..1 _recommended_" ActionIdEnum : action_id
click ActionIdEnum href "../ActionIdEnum/"
FileHosting : activity_id
FileHosting --> "1" FileHostingActivityIdEnum : activity_id
click FileHostingActivityIdEnum href "../FileHostingActivityIdEnum/"
FileHosting : activity_name
FileHosting : actor
FileHosting --> "1" Actor : actor
click Actor href "../Actor/"
FileHosting : api
FileHosting --> "0..1" Api : api
click Api href "../Api/"
FileHosting : attacks
FileHosting --> "*" Attack : attacks
click Attack href "../Attack/"
FileHosting : authorizations
FileHosting --> "*" Authorization : authorizations
click Authorization href "../Authorization/"
FileHosting : category_name
FileHosting : category_uid
FileHosting --> "1" BaseEventCategoryUidEnum : category_uid
click BaseEventCategoryUidEnum href "../BaseEventCategoryUidEnum/"
FileHosting : class_name
FileHosting : class_uid
FileHosting --> "1" BaseEventClassUidEnum : class_uid
click BaseEventClassUidEnum href "../BaseEventClassUidEnum/"
FileHosting : cloud
FileHosting --> "1" Cloud : cloud
click Cloud href "../Cloud/"
FileHosting : confidence
FileHosting : confidence_id
FileHosting --> "0..1 _recommended_" ConfidenceIdEnum : confidence_id
click ConfidenceIdEnum href "../ConfidenceIdEnum/"
FileHosting : confidence_score
FileHosting : connection_info
FileHosting --> "0..1" NetworkConnectionInfo : connection_info
click NetworkConnectionInfo href "../NetworkConnectionInfo/"
FileHosting : count
FileHosting : device
FileHosting --> "0..1 _recommended_" Device : device
click Device href "../Device/"
FileHosting : disposition
FileHosting : disposition_id
FileHosting --> "0..1 _recommended_" DispositionIdEnum : disposition_id
click DispositionIdEnum href "../DispositionIdEnum/"
FileHosting : dst_endpoint
FileHosting --> "0..1 _recommended_" NetworkEndpoint : dst_endpoint
click NetworkEndpoint href "../NetworkEndpoint/"
FileHosting : duration
FileHosting : end_time
FileHosting : enrichments
FileHosting --> "*" Enrichment : enrichments
click Enrichment href "../Enrichment/"
FileHosting : expiration_time
FileHosting : file
FileHosting --> "1" File : file
click File href "../File/"
FileHosting : file_result
FileHosting --> "0..1" File : file_result
click File href "../File/"
FileHosting : firewall_rule
FileHosting --> "0..1" FirewallRule : firewall_rule
click FirewallRule href "../FirewallRule/"
FileHosting : http_request
FileHosting --> "0..1 _recommended_" HttpRequest : http_request
click HttpRequest href "../HttpRequest/"
FileHosting : http_response
FileHosting --> "0..1" HttpResponse : http_response
click HttpResponse href "../HttpResponse/"
FileHosting : is_alert
FileHosting : malware
FileHosting --> "*" Malware : malware
click Malware href "../Malware/"
FileHosting : malware_scan_info
FileHosting --> "0..1" MalwareScanInfo : malware_scan_info
click MalwareScanInfo href "../MalwareScanInfo/"
FileHosting : message
FileHosting : metadata
FileHosting --> "1" Metadata : metadata
click Metadata href "../Metadata/"
FileHosting : observables
FileHosting --> "* _recommended_" Observable : observables
click Observable href "../Observable/"
FileHosting : osint
FileHosting --> "1..*" Osint : osint
click Osint href "../Osint/"
FileHosting : policy
FileHosting --> "0..1" Policy : policy
click Policy href "../Policy/"
FileHosting : raw_data
FileHosting : raw_data_hash
FileHosting --> "0..1" Fingerprint : raw_data_hash
click Fingerprint href "../Fingerprint/"
FileHosting : raw_data_size
FileHosting : risk_details
FileHosting : risk_level
FileHosting : risk_level_id
FileHosting --> "0..1" RiskLevelIdEnum : risk_level_id
click RiskLevelIdEnum href "../RiskLevelIdEnum/"
FileHosting : risk_score
FileHosting : severity
FileHosting : severity_id
FileHosting --> "1" SeverityIdEnum : severity_id
click SeverityIdEnum href "../SeverityIdEnum/"
FileHosting : share
FileHosting : share_type
FileHosting : share_type_id
FileHosting --> "0..1" ShareTypeIdEnum : share_type_id
click ShareTypeIdEnum href "../ShareTypeIdEnum/"
FileHosting : src_endpoint
FileHosting --> "1" NetworkEndpoint : src_endpoint
click NetworkEndpoint href "../NetworkEndpoint/"
FileHosting : start_time
FileHosting : status
FileHosting : status_code
FileHosting : status_detail
FileHosting : status_id
FileHosting --> "0..1 _recommended_" StatusIdEnum : status_id
click StatusIdEnum href "../StatusIdEnum/"
FileHosting : time
FileHosting : timezone_offset
FileHosting : type_name
FileHosting : type_uid
FileHosting : unmapped
FileHosting --> "0..1" Object : unmapped
click Object href "../Object/"
Inheritance
- BaseEvent [ CloudProfile DatetimeProfile HostProfile OsintProfile SecurityControlProfile]
- ApplicationEvent
- FileHosting
- ApplicationEvent
Slots
| Name | Cardinality and Range | Description | Inheritance |
|---|---|---|---|
| access_list | * String |
The list of requested access rights | direct |
| access_mask | 0..1 Integer |
The sum of hexadecimal values of requested access rights | direct |
| access_result | 0..1 String |
The list of access check results | direct |
| activity_id | 1 FileHostingActivityIdEnum |
The normalized identifier of the activity that triggered the event | direct |
| actor | 1 Actor |
The actor that performed the activity on the target file | direct |
| connection_info | 0..1 NetworkConnectionInfo |
The network connection information | direct |
| dst_endpoint | 0..1 recommended NetworkEndpoint |
The endpoint that received the activity on the target file | direct |
| expiration_time | 0..1 TimestampT |
The share expiration time | direct |
| file | 1 File |
The file that is the target of the activity | direct |
| file_result | 0..1 File |
The resulting file object when the activity was allowed and successful | direct |
| http_request | 0..1 recommended HttpRequest |
Details about the underlying HTTP request | direct |
| http_response | 0..1 HttpResponse |
Details about the HTTP response, if available | direct |
| share | 0..1 String |
The share name | direct |
| share_type | 0..1 String |
The share type, normalized to the caption of the share_type_id value | direct |
| share_type_id | 0..1 ShareTypeIdEnum |
The normalized identifier of the share type | direct |
| src_endpoint | 1 NetworkEndpoint |
The endpoint that performed the activity on the target file | direct |
| activity_name | 0..1 String |
The event activity name, as defined by the activity_id | BaseEvent |
| category_name | 0..1 String |
The event category name, as defined by category_uid value | BaseEvent |
| category_uid | 1 BaseEventCategoryUidEnum |
The category unique identifier of the event | BaseEvent |
| class_name | 0..1 String |
The event class name, as defined by class_uid value | BaseEvent |
| class_uid | 1 BaseEventClassUidEnum |
The unique identifier of a class | BaseEvent |
| count | 0..1 Integer |
The number of times that events in the same logical group occurred during the | BaseEvent |
| duration | 0..1 Integer |
The event duration or aggregate time, the amount of time the event covers fro... | BaseEvent |
| end_time | 0..1 TimestampT |
The end time of a time period, or the time of the most recent event included ... | BaseEvent |
| enrichments | * Enrichment |
The additional information from an external data source, which is associated | BaseEvent |
| message | 0..1 recommended String |
The description of the event/finding, as defined by the source | BaseEvent |
| metadata | 1 Metadata |
The metadata associated with the event or a finding | BaseEvent |
| observables | * recommended Observable |
The observables associated with the event or a finding | BaseEvent |
| raw_data | 0..1 String |
The raw event/finding data as received from the source | BaseEvent |
| raw_data_hash | 0..1 Fingerprint |
The hash, which describes the content of the raw_data field | BaseEvent |
| raw_data_size | 0..1 Integer |
The size of the raw data which was transformed into an OCSF event, in bytes | BaseEvent |
| severity | 0..1 String |
The event/finding severity, normalized to the caption of the | BaseEvent |
| severity_id | 1 SeverityIdEnum |
The normalized identifier of the event/finding severity |
BaseEvent |
| start_time | 0..1 TimestampT |
The start time of a time period, or the time of the least recent event includ... | BaseEvent |
| status | 0..1 recommended String |
The event status, normalized to the caption of the status_id value | BaseEvent |
| status_code | 0..1 recommended String |
The event status code, as reported by the event source | BaseEvent |
| status_detail | 0..1 recommended String |
The status detail contains additional information about the event/finding | BaseEvent |
| status_id | 0..1 recommended StatusIdEnum |
The normalized identifier of the event status | BaseEvent |
| time | 1 TimestampT |
The normalized event occurrence time or the finding creation time | BaseEvent |
| timezone_offset | 0..1 recommended Integer |
The number of minutes that the reported event time is ahead or |
BaseEvent |
| type_name | 0..1 String |
The event/finding type name, as defined by the type_uid | BaseEvent |
| type_uid | 1 Integer |
The event/finding type ID | BaseEvent |
| unmapped | 0..1 Object |
The attributes that are not mapped to the event schema | BaseEvent |
| api | 0..1 Api |
Describes details about a typical API (Application Programming Interface) cal... | CloudProfile |
| cloud | 1 Cloud |
Describes details about the Cloud environment where the event or finding was | CloudProfile |
| device | 0..1 recommended Device |
An addressable device, computer system or host | HostProfile |
| osint | 1..* Osint |
The OSINT (Open Source Intelligence) object contains details related to an | OsintProfile |
| action | 0..1 String |
The normalized caption of action_id |
SecurityControlProfile |
| action_id | 0..1 recommended ActionIdEnum |
The action taken by a control or other policy-based system leading to an | SecurityControlProfile |
| attacks | * Attack |
An array of MITRE ATT&CK® objects describing identified tactics, techniques & | SecurityControlProfile |
| authorizations | * Authorization |
Provides details about an authorization, such as authorization outcome, and a... | SecurityControlProfile |
| confidence | 0..1 String |
The confidence, normalized to the caption of the confidence_id value | SecurityControlProfile |
| confidence_id | 0..1 recommended ConfidenceIdEnum |
The normalized confidence refers to the accuracy of the rule that created the | SecurityControlProfile |
| confidence_score | 0..1 Integer |
The confidence score as reported by the event source | SecurityControlProfile |
| disposition | 0..1 String |
The disposition name, normalized to the caption of the disposition_id value | SecurityControlProfile |
| disposition_id | 0..1 recommended DispositionIdEnum |
Describes the outcome or action taken by a security control, such as access | SecurityControlProfile |
| firewall_rule | 0..1 FirewallRule |
The firewall rule that pertains to the control that triggered the event, if | SecurityControlProfile |
| is_alert | 0..1 recommended Boolean |
Indicates that the event is considered to be an alertable signal | SecurityControlProfile |
| malware | * Malware |
A list of Malware objects, describing details about the identified malware | SecurityControlProfile |
| malware_scan_info | 0..1 MalwareScanInfo |
Describes details about the scan job that identified malware on the target | SecurityControlProfile |
| policy | 0..1 Policy |
The policy that pertains to the control that triggered the event, if | SecurityControlProfile |
| risk_details | 0..1 String |
Describes the risk associated with the finding | SecurityControlProfile |
| risk_level | 0..1 String |
The risk level, normalized to the caption of the risk_level_id value | SecurityControlProfile |
| risk_level_id | 0..1 RiskLevelIdEnum |
The normalized risk level id | SecurityControlProfile |
| risk_score | 0..1 Integer |
The risk score as reported by the event source | SecurityControlProfile |
In Subsets
Aliases
- File Hosting Activity
Identifier and Mapping Information
Annotations
| property | value |
|---|---|
| ocsf_event_uid | 6 |
Schema Source
- from schema: https://w3id.org/lmodel/ocsf
Mappings
| Mapping Type | Mapped Value |
|---|---|
| self | ocsf:FileHosting |
| native | ocsf:FileHosting |
LinkML Source
Direct
name: FileHosting
annotations:
ocsf_event_uid:
tag: ocsf_event_uid
value: 6
description: 'File Hosting Activity events report the actions taken by file management
applications, including file sharing servers like Sharepoint and services such
as Box, MS OneDrive, Google Drive, or network file share services.'
in_subset:
- application_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- File Hosting Activity
is_a: ApplicationEvent
slots:
- access_list
- access_mask
- access_result
- activity_id
- actor
- connection_info
- dst_endpoint
- expiration_time
- file
- file_result
- http_request
- http_response
- share
- share_type
- share_type_id
- src_endpoint
slot_usage:
access_list:
name: access_list
annotations:
group:
tag: group
value: context
access_mask:
name: access_mask
annotations:
group:
tag: group
value: context
description: The sum of hexadecimal values of requested access rights.
access_result:
name: access_result
annotations:
group:
tag: group
value: context
activity_id:
name: activity_id
range: FileHostingActivityIdEnum
actor:
name: actor
annotations:
group:
tag: group
value: primary
description: The actor that performed the activity on the target file.
required: true
connection_info:
name: connection_info
annotations:
group:
tag: group
value: context
dst_endpoint:
name: dst_endpoint
description: The endpoint that received the activity on the target file.
recommended: true
expiration_time:
name: expiration_time
annotations:
group:
tag: group
value: context
description: The share expiration time.
file:
name: file
annotations:
group:
tag: group
value: primary
description: The file that is the target of the activity.
required: true
file_result:
name: file_result
annotations:
group:
tag: group
value: context
description: The resulting file object when the activity was allowed and successful.
http_request:
name: http_request
annotations:
group:
tag: group
value: context
description: Details about the underlying HTTP request.
recommended: true
http_response:
name: http_response
annotations:
group:
tag: group
value: context
description: Details about the HTTP response, if available.
share:
name: share
annotations:
group:
tag: group
value: context
description: The share name.
share_type:
name: share_type
annotations:
group:
tag: group
value: context
share_type_id:
name: share_type_id
annotations:
group:
tag: group
value: context
src_endpoint:
name: src_endpoint
annotations:
group:
tag: group
value: primary
description: The endpoint that performed the activity on the target file.
required: true
Induced
name: FileHosting
annotations:
ocsf_event_uid:
tag: ocsf_event_uid
value: 6
description: 'File Hosting Activity events report the actions taken by file management
applications, including file sharing servers like Sharepoint and services such
as Box, MS OneDrive, Google Drive, or network file share services.'
in_subset:
- application_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- File Hosting Activity
is_a: ApplicationEvent
slot_usage:
access_list:
name: access_list
annotations:
group:
tag: group
value: context
access_mask:
name: access_mask
annotations:
group:
tag: group
value: context
description: The sum of hexadecimal values of requested access rights.
access_result:
name: access_result
annotations:
group:
tag: group
value: context
activity_id:
name: activity_id
range: FileHostingActivityIdEnum
actor:
name: actor
annotations:
group:
tag: group
value: primary
description: The actor that performed the activity on the target file.
required: true
connection_info:
name: connection_info
annotations:
group:
tag: group
value: context
dst_endpoint:
name: dst_endpoint
description: The endpoint that received the activity on the target file.
recommended: true
expiration_time:
name: expiration_time
annotations:
group:
tag: group
value: context
description: The share expiration time.
file:
name: file
annotations:
group:
tag: group
value: primary
description: The file that is the target of the activity.
required: true
file_result:
name: file_result
annotations:
group:
tag: group
value: context
description: The resulting file object when the activity was allowed and successful.
http_request:
name: http_request
annotations:
group:
tag: group
value: context
description: Details about the underlying HTTP request.
recommended: true
http_response:
name: http_response
annotations:
group:
tag: group
value: context
description: Details about the HTTP response, if available.
share:
name: share
annotations:
group:
tag: group
value: context
description: The share name.
share_type:
name: share_type
annotations:
group:
tag: group
value: context
share_type_id:
name: share_type_id
annotations:
group:
tag: group
value: context
src_endpoint:
name: src_endpoint
annotations:
group:
tag: group
value: primary
description: The endpoint that performed the activity on the target file.
required: true
attributes:
access_list:
name: access_list
annotations:
group:
tag: group
value: context
description: The list of requested access rights.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Access List
rank: 1000
alias: access_list
owner: FileHosting
domain_of:
- FileHosting
- EntityManagement
range: string
multivalued: true
access_mask:
name: access_mask
annotations:
group:
tag: group
value: context
description: The sum of hexadecimal values of requested access rights.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Access Mask
rank: 1000
alias: access_mask
owner: FileHosting
domain_of:
- FileHosting
- EntityManagement
- FileActivity
- RegistryKeyActivity
range: integer
access_result:
name: access_result
annotations:
group:
tag: group
value: context
description: The list of access check results.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Access Check Result
rank: 1000
alias: access_result
owner: FileHosting
domain_of:
- FileHosting
range: string
activity_id:
name: activity_id
annotations:
group:
tag: group
value: classification
description: The normalized identifier of the activity that triggered the event.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Activity ID
rank: 1000
alias: activity_id
owner: FileHosting
domain_of:
- BaseEvent
- ApiActivity
- ApplicationError
- ApplicationLifecycle
- DatastoreActivity
- FileHosting
- ScanActivity
- WebResourceAccessActivity
- WebResourcesActivity
- DiscoveryEvent
- DiscoveryResult
- DataSecurityFinding
- Finding
- IncidentFinding
- SecurityFinding
- AccountChange
- Authentication
- AuthorizeSession
- EntityManagement
- GroupManagement
- UserAccess
- DhcpActivity
- DnsActivity
- EmailActivity
- EmailFileActivity
- EmailUrlActivity
- FtpActivity
- HttpActivity
- NetworkActivity
- NetworkFileActivity
- NtpActivity
- RdpActivity
- SmbActivity
- SshActivity
- TunnelActivity
- RemediationActivity
- EventLogActvity
- FileActivity
- KernelActivity
- KernelExtensionActivity
- MemoryActivity
- ModuleActivity
- PeripheralActivity
- ProcessActivity
- ScheduledJobActivity
- ScriptActivity
- AirborneBroadcastActivity
- DroneFlightsActivity
- RegistryKeyActivity
- RegistryValueActivity
- WindowsResourceActivity
- WindowsServiceActivity
range: FileHostingActivityIdEnum
required: true
actor:
name: actor
annotations:
group:
tag: group
value: primary
description: The actor that performed the activity on the target file.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Actor
rank: 1000
alias: actor
owner: FileHosting
domain_of:
- Evidences
- HostProfile
- ApiActivity
- DatastoreActivity
- FileHosting
- ConfigState
- DeviceConfigStateChange
- InventoryInfo
- OsintInventoryInfo
- SoftwareInfo
- UserInventory
- DataSecurityFinding
- IamEvent
- NetworkFileActivity
- SystemEvent
- EventLogActvity
- FileActivity
- KernelExtensionActivity
- ModuleActivity
- ProcessActivity
- ScheduledJobActivity
- RegistryKeyActivity
- RegistryValueActivity
range: Actor
required: true
connection_info:
name: connection_info
annotations:
group:
tag: group
value: context
description: The network connection information.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Connection Info
rank: 1000
alias: connection_info
owner: FileHosting
domain_of:
- QueryEvidence
- Evidences
- FileHosting
- NetworkConnectionQuery
- NetworkEvent
- DnsActivity
- NetworkFileActivity
- RdpActivity
- TunnelActivity
- NetworkRemediationActivity
- UnmannedSystemsEvent
range: NetworkConnectionInfo
dst_endpoint:
name: dst_endpoint
description: The endpoint that received the activity on the target file.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Destination Endpoint
rank: 1000
alias: dst_endpoint
owner: FileHosting
domain_of:
- Evidences
- LoadBalancer
- ApiActivity
- DatastoreActivity
- FileHosting
- WebResourcesActivity
- DataSecurityFinding
- Authentication
- AuthorizeSession
- NetworkEvent
- DhcpActivity
- DnsActivity
- EmailActivity
- NetworkActivity
- NetworkFileActivity
- TunnelActivity
- EventLogActvity
- UnmannedSystemsEvent
- AirborneBroadcastActivity
range: NetworkEndpoint
recommended: true
expiration_time:
name: expiration_time
annotations:
group:
tag: group
value: context
description: The share expiration time.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Expiration Time
rank: 1000
alias: expiration_time
owner: FileHosting
domain_of:
- Osint
- Session
- Token
- AuthenticationToken
- Certificate
- HttpCookie
- FileHosting
- NetworkFileActivity
range: TimestampT
file:
name: file
annotations:
group:
tag: group
value: primary
description: The file that is the target of the activity.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- File
rank: 1000
alias: file
owner: FileHosting
domain_of:
- Osint
- QueryEvidence
- Script
- AffectedCode
- Databucket
- Evidences
- Job
- KernelDriver
- Module
- Process
- FileHosting
- FileQuery
- DataSecurityFinding
- EmailFileActivity
- FtpActivity
- HttpActivity
- NetworkFileActivity
- RdpActivity
- SmbActivity
- SshActivity
- FileRemediationActivity
- EventLogActvity
- FileActivity
range: File
required: true
file_result:
name: file_result
annotations:
group:
tag: group
value: context
description: The resulting file object when the activity was allowed and successful.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- File Result
rank: 1000
alias: file_result
owner: FileHosting
domain_of:
- FileHosting
- FileActivity
range: File
http_request:
name: http_request
annotations:
group:
tag: group
value: context
description: Details about the underlying HTTP request.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- HTTP Request
rank: 1000
alias: http_request
owner: FileHosting
domain_of:
- Evidences
- ApiActivity
- DatastoreActivity
- FileHosting
- WebResourceAccessActivity
- WebResourcesActivity
- IamEvent
- HttpActivity
range: HttpRequest
recommended: true
http_response:
name: http_response
annotations:
group:
tag: group
value: context
description: Details about the HTTP response, if available.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- HTTP Response
rank: 1000
alias: http_response
owner: FileHosting
domain_of:
- Evidences
- ApiActivity
- DatastoreActivity
- FileHosting
- WebResourceAccessActivity
- WebResourcesActivity
- IamEvent
- HttpActivity
range: HttpResponse
share:
name: share
annotations:
group:
tag: group
value: context
description: The share name.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Share
rank: 1000
alias: share
owner: FileHosting
domain_of:
- FileHosting
- SmbActivity
range: string
share_type:
name: share_type
annotations:
group:
tag: group
value: context
description: 'The share type, normalized to the caption of the share_type_id value.
In the
case of ''Other'', it is defined by the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Share Type
rank: 1000
alias: share_type
owner: FileHosting
domain_of:
- FileHosting
- SmbActivity
range: string
share_type_id:
name: share_type_id
annotations:
group:
tag: group
value: context
description: The normalized identifier of the share type.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Share Type ID
rank: 1000
alias: share_type_id
owner: FileHosting
domain_of:
- FileHosting
- SmbActivity
range: ShareTypeIdEnum
src_endpoint:
name: src_endpoint
annotations:
group:
tag: group
value: primary
description: The endpoint that performed the activity on the target file.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Source Endpoint
rank: 1000
alias: src_endpoint
owner: FileHosting
domain_of:
- Evidences
- ApiActivity
- DatastoreActivity
- FileHosting
- WebResourceAccessActivity
- WebResourcesActivity
- DataSecurityFinding
- IamEvent
- NetworkEvent
- DhcpActivity
- EmailActivity
- NetworkActivity
- NetworkFileActivity
- TunnelActivity
- EventLogActvity
- UnmannedSystemsEvent
- AirborneBroadcastActivity
- DroneFlightsActivity
range: NetworkEndpoint
required: true
activity_name:
name: activity_name
annotations:
group:
tag: group
value: classification
description: The event activity name, as defined by the activity_id.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Activity
rank: 1000
alias: activity_name
owner: FileHosting
domain_of:
- BaseEvent
- DataSecurityFinding
- Finding
- IncidentFinding
range: string
category_name:
name: category_name
annotations:
group:
tag: group
value: classification
description: The event category name, as defined by category_uid value.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Category
rank: 1000
alias: category_name
owner: FileHosting
domain_of:
- BaseEvent
range: string
category_uid:
name: category_uid
annotations:
group:
tag: group
value: classification
description: The category unique identifier of the event.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Category ID
rank: 1000
alias: category_uid
owner: FileHosting
domain_of:
- BaseEvent
range: BaseEventCategoryUidEnum
required: true
class_name:
name: class_name
annotations:
group:
tag: group
value: classification
description: The event class name, as defined by class_uid value.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Class
rank: 1000
alias: class_name
owner: FileHosting
domain_of:
- BaseEvent
range: string
class_uid:
name: class_uid
annotations:
group:
tag: group
value: classification
description: 'The unique identifier of a class. A class describes the attributes
available in
an event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Class ID
rank: 1000
alias: class_uid
owner: FileHosting
domain_of:
- BaseEvent
range: BaseEventClassUidEnum
required: true
count:
name: count
annotations:
group:
tag: group
value: occurrence
description: 'The number of times that events in the same logical group occurred
during the
event <strong>Start Time</strong> to <strong>End Time</strong> period.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Count
rank: 1000
alias: count
owner: FileHosting
domain_of:
- Observation
- RelatedEvent
- Session
- DiscoveryDetails
- UnmannedSystemOperatingArea
- BaseEvent
range: integer
duration:
name: duration
annotations:
group:
tag: group
value: occurrence
description: 'The event duration or aggregate time, the amount of time the event
covers from
<code>start_time</code> to <code>end_time</code> in milliseconds.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Duration Milliseconds
rank: 1000
alias: duration
owner: FileHosting
domain_of:
- Span
- Timespan
- Trace
- FirewallRule
- BaseEvent
- ScanActivity
range: integer
end_time:
name: end_time
annotations:
group:
tag: group
value: occurrence
description: 'The end time of a time period, or the time of the most recent event
included in
the aggregate event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- End Time
rank: 1000
alias: end_time
owner: FileHosting
domain_of:
- Span
- Timespan
- Trace
- NetworkTraffic
- UnmannedSystemOperatingArea
- MalwareScanInfo
- BaseEvent
- ScanActivity
- Finding
- IncidentFinding
range: TimestampT
enrichments:
name: enrichments
annotations:
group:
tag: group
value: context
description: 'The additional information from an external data source, which is
associated
with the event or a finding. For example add location information for the IP
address in the DNS answers:</p><code>[{"name": "answers.ip", "value":
"92.24.47.250", "type": "location", "data": {"city": "Socotra", "continent":
"Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc":
"Yemen"}}]</code>'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Enrichments
rank: 1000
alias: enrichments
owner: FileHosting
domain_of:
- BaseEvent
range: Enrichment
multivalued: true
message:
name: message
annotations:
group:
tag: group
value: primary
description: The description of the event/finding, as defined by the source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Message
rank: 1000
alias: message
owner: FileHosting
domain_of:
- Response
- Span
- HttpResponse
- LoadBalancer
- BaseEvent
- ApplicationError
range: string
recommended: true
metadata:
name: metadata
annotations:
group:
tag: group
value: context
description: The metadata associated with the event or a finding.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Metadata
rank: 1000
alias: metadata
owner: FileHosting
domain_of:
- BaseEvent
range: Metadata
required: true
observables:
name: observables
annotations:
group:
tag: group
value: primary
description: The observables associated with the event or a finding.
notes:
- 'OCSF Observables FAQ —
https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md'
from_schema: https://w3id.org/lmodel/ocsf
see_also:
- https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md
aliases:
- Observables
rank: 1000
alias: observables
owner: FileHosting
domain_of:
- RelatedEvent
- BaseEvent
range: Observable
recommended: true
multivalued: true
raw_data:
name: raw_data
annotations:
group:
tag: group
value: context
description: The raw event/finding data as received from the source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Raw Data
rank: 1000
alias: raw_data
owner: FileHosting
domain_of:
- BaseEvent
range: string
raw_data_hash:
name: raw_data_hash
annotations:
group:
tag: group
value: context
description: The hash, which describes the content of the raw_data field.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Raw Data Hash
rank: 1000
alias: raw_data_hash
owner: FileHosting
domain_of:
- BaseEvent
range: Fingerprint
raw_data_size:
name: raw_data_size
annotations:
group:
tag: group
value: context
description: The size of the raw data which was transformed into an OCSF event,
in bytes.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Raw Data Size
rank: 1000
alias: raw_data_size
owner: FileHosting
domain_of:
- BaseEvent
range: integer
severity:
name: severity
annotations:
group:
tag: group
value: classification
description: 'The event/finding severity, normalized to the caption of the
<code>severity_id</code> value. In the case of ''Other'', it is defined by the
source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Severity
rank: 1000
alias: severity
owner: FileHosting
domain_of:
- Osint
- RelatedEvent
- VendorAttributes
- Vulnerability
- Check
- Cvss
- KbArticle
- Malware
- BaseEvent
range: string
severity_id:
name: severity_id
annotations:
group:
tag: group
value: classification
description: '<p>The normalized identifier of the event/finding severity.</p>The
normalized
severity is a measurement the effort and expense required to manage and resolve
an event or incident. Smaller numerical values represent lower impact events,
and larger numerical values represent higher impact events.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Severity ID
rank: 1000
alias: severity_id
owner: FileHosting
domain_of:
- Osint
- RelatedEvent
- VendorAttributes
- Check
- Malware
- BaseEvent
range: SeverityIdEnum
required: true
start_time:
name: start_time
annotations:
group:
tag: group
value: occurrence
description: 'The start time of a time period, or the time of the least recent
event included
in the aggregate event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Start Time
rank: 1000
alias: start_time
owner: FileHosting
domain_of:
- Span
- Timespan
- Trace
- NetworkTraffic
- UnmannedSystemOperatingArea
- MalwareScanInfo
- BaseEvent
- ScanActivity
- Finding
- IncidentFinding
range: TimestampT
status:
name: status
annotations:
group:
tag: group
value: primary
description: 'The event status, normalized to the caption of the status_id value.
In the case
of ''Other'', it is defined by the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status
rank: 1000
alias: status
owner: FileHosting
domain_of:
- RelatedEvent
- Ticket
- Whois
- AdditionalRestriction
- Check
- Compliance
- DataClassification
- HttpResponse
- BaseEvent
- Finding
- IncidentFinding
- DroneFlightsActivity
range: string
recommended: true
status_code:
name: status_code
annotations:
group:
tag: group
value: primary
description: 'The event status code, as reported by the event source.<br /><br
/>For example,
in a Windows Failed Authentication event, this would be the value of ''Failure
Code'', e.g. 0x18.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status Code
rank: 1000
alias: status_code
owner: FileHosting
domain_of:
- Span
- Compliance
- BaseEvent
- EventLogActvity
range: string
recommended: true
status_detail:
name: status_detail
annotations:
group:
tag: group
value: primary
description: 'The status detail contains additional information about the event/finding
outcome.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status Detail
rank: 1000
alias: status_detail
owner: FileHosting
domain_of:
- Compliance
- LoadBalancer
- BaseEvent
- Authentication
- EventLogActvity
range: string
recommended: true
status_id:
name: status_id
annotations:
group:
tag: group
value: primary
description: The normalized identifier of the event status.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status ID
rank: 1000
alias: status_id
owner: FileHosting
domain_of:
- Ticket
- AdditionalRestriction
- Check
- Compliance
- DataClassification
- BaseEvent
- Finding
- IncidentFinding
- RemediationActivity
- DroneFlightsActivity
range: StatusIdEnum
recommended: true
time:
name: time
annotations:
group:
tag: group
value: occurrence
description: The normalized event occurrence time or the finding creation time.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Event Time
rank: 1000
alias: time
owner: FileHosting
domain_of:
- TransformationInfo
- BaseEvent
range: TimestampT
required: true
timezone_offset:
name: timezone_offset
annotations:
group:
tag: group
value: occurrence
description: 'The number of minutes that the reported event <code>time</code>
is ahead or
behind UTC, in the range -1,080 to +1,080.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Timezone Offset
rank: 1000
alias: timezone_offset
owner: FileHosting
domain_of:
- BaseEvent
range: integer
recommended: true
type_name:
name: type_name
annotations:
group:
tag: group
value: classification
description: The event/finding type name, as defined by the type_uid.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Type Name
rank: 1000
alias: type_name
owner: FileHosting
domain_of:
- RelatedEvent
- BaseEvent
range: string
type_uid:
name: type_uid
annotations:
group:
tag: group
value: classification
description: 'The event/finding type ID. It identifies the event''s semantics
and structure.
The value is calculated by the logging system as: <code>class_uid * 100 +
activity_id</code>.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Type ID
rank: 1000
alias: type_uid
owner: FileHosting
domain_of:
- Observable
- RelatedEvent
- BaseEvent
range: integer
required: true
unmapped:
name: unmapped
annotations:
group:
tag: group
value: context
description: 'The attributes that are not mapped to the event schema. The names
and values of
those attributes are specific to the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Unmapped Data
rank: 1000
alias: unmapped
owner: FileHosting
domain_of:
- BaseEvent
range: Object
api:
name: api
annotations:
group:
tag: group
value: context
description: Describes details about a typical API (Application Programming Interface)
call.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- API Details
rank: 1000
alias: api
owner: FileHosting
domain_of:
- Evidences
- CloudProfile
- ApiActivity
range: Api
cloud:
name: cloud
annotations:
group:
tag: group
value: primary
description: 'Describes details about the Cloud environment where the event or
finding was
created.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Cloud
rank: 1000
alias: cloud
owner: FileHosting
domain_of:
- CloudProfile
- CloudResourcesInventoryInfo
range: Cloud
required: true
device:
name: device
description: An addressable device, computer system or host.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Device
rank: 1000
alias: device
owner: FileHosting
domain_of:
- AuthFactor
- Evidences
- Logger
- ManagedEntity
- HostProfile
- ConfigState
- DeviceConfigStateChange
- EvidenceInfo
- InventoryInfo
- PatchState
- SoftwareInfo
- DataSecurityFinding
- Finding
- RdpActivity
- TunnelActivity
- SystemEvent
- EventLogActvity
range: Device
recommended: true
osint:
name: osint
annotations:
group:
tag: group
value: primary
description: 'The OSINT (Open Source Intelligence) object contains details related
to an
indicator such as the indicator itself, related indicators, geolocation,
registrar information, subdomains, analyst commentary, and other contextual
information. This information can be used to further enrich a detection or
finding by providing decisioning support to other analysts and engineers.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- OSINT
rank: 1000
alias: osint
owner: FileHosting
domain_of:
- OsintProfile
- OsintInventoryInfo
range: Osint
required: true
multivalued: true
action:
name: action
description: The normalized caption of <code>action_id</code>.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Action
rank: 1000
alias: action
owner: FileHosting
domain_of:
- SecurityControlProfile
range: string
action_id:
name: action_id
annotations:
sibling:
tag: sibling
value: action
description: 'The action taken by a control or other policy-based system leading
to an
outcome or disposition. An unknown action may still correspond to a known
disposition. Refer to <code>disposition_id</code> for the outcome of the
action.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Action ID
rank: 1000
alias: action_id
owner: FileHosting
domain_of:
- SecurityControlProfile
range: ActionIdEnum
recommended: true
attacks:
name: attacks
description: 'An array of MITRE ATT&CK® objects describing identified tactics,
techniques &
sub-techniques. The objects are compatible with MITRE ATLAS™ tactics,
techniques & sub-techniques.'
notes:
- MITRE ATT&CK® — https://attack.mitre.org
- MITRE ATLAS — https://atlas.mitre.org/matrices/ATLAS
from_schema: https://w3id.org/lmodel/ocsf
see_also:
- https://attack.mitre.org
- https://atlas.mitre.org/matrices/ATLAS
aliases:
- MITRE ATT&CK® and ATLAS™ Details
rank: 1000
alias: attacks
owner: FileHosting
domain_of:
- Osint
- RelatedEvent
- FindingInfo
- SecurityControlProfile
- IncidentFinding
- SecurityFinding
range: Attack
multivalued: true
authorizations:
name: authorizations
description: 'Provides details about an authorization, such as authorization outcome,
and any
associated policies related to the activity/event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Authorization Information
rank: 1000
alias: authorizations
owner: FileHosting
domain_of:
- Actor
- SecurityControlProfile
range: Authorization
multivalued: true
confidence:
name: confidence
annotations:
group:
tag: group
value: context
description: 'The confidence, normalized to the caption of the confidence_id value.
In the
case of ''Other'', it is defined by the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Confidence
rank: 1000
alias: confidence
owner: FileHosting
domain_of:
- Osint
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- Finding
- IncidentFinding
- SecurityFinding
range: string
confidence_id:
name: confidence_id
annotations:
group:
tag: group
value: context
description: 'The normalized confidence refers to the accuracy of the rule that
created the
finding. A rule with a low confidence means that the finding scope is wide and
may create finding reports that may not be malicious in nature.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Confidence ID
rank: 1000
alias: confidence_id
owner: FileHosting
domain_of:
- Osint
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- Finding
- IncidentFinding
- SecurityFinding
range: ConfidenceIdEnum
recommended: true
confidence_score:
name: confidence_score
annotations:
group:
tag: group
value: context
description: The confidence score as reported by the event source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Confidence Score
rank: 1000
alias: confidence_score
owner: FileHosting
domain_of:
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- Finding
- IncidentFinding
- SecurityFinding
range: integer
disposition:
name: disposition
description: 'The disposition name, normalized to the caption of the disposition_id
value. In
the case of ''Other'', it is defined by the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Disposition
rank: 1000
alias: disposition
owner: FileHosting
domain_of:
- SecurityControlProfile
range: string
disposition_id:
name: disposition_id
annotations:
sibling:
tag: sibling
value: disposition
description: 'Describes the outcome or action taken by a security control, such
as access
control checks, malware detections or various types of policy violations.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Disposition ID
rank: 1000
alias: disposition_id
owner: FileHosting
domain_of:
- SecurityControlProfile
range: DispositionIdEnum
recommended: true
firewall_rule:
name: firewall_rule
description: 'The firewall rule that pertains to the control that triggered the
event, if
applicable.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Firewall Rule
rank: 1000
alias: firewall_rule
owner: FileHosting
domain_of:
- SecurityControlProfile
range: FirewallRule
is_alert:
name: is_alert
description: 'Indicates that the event is considered to be an alertable signal.
Should be set
to <code>true</code> if <code>disposition_id = Alert</code> among other
dispositions, and/or <code>risk_level_id</code> or <code>severity_id</code>
of
the event is elevated. Not all control events will be alertable, for example
if
<code>disposition_id = Exonerated</code> or <code>disposition_id =
Allowed</code>.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Alert
rank: 1000
alias: is_alert
owner: FileHosting
domain_of:
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
range: boolean
recommended: true
malware:
name: malware
description: A list of Malware objects, describing details about the identified
malware.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Malware
rank: 1000
alias: malware
owner: FileHosting
domain_of:
- Osint
- SecurityControlProfile
- DetectionFinding
- SecurityFinding
range: Malware
multivalued: true
malware_scan_info:
name: malware_scan_info
description: 'Describes details about the scan job that identified malware on
the target
system.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Malware Scan Info
rank: 1000
alias: malware_scan_info
owner: FileHosting
domain_of:
- SecurityControlProfile
- DetectionFinding
range: MalwareScanInfo
policy:
name: policy
description: 'The policy that pertains to the control that triggered the event,
if
applicable. For example the name of an anti-malware policy or an access control
policy.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Policy
rank: 1000
alias: policy
owner: FileHosting
domain_of:
- PermissionAnalysisResult
- AdditionalRestriction
- Assessment
- Authorization
- DataClassification
- DataSecurity
- ManagedEntity
- SecurityControlProfile
- ScanActivity
- AccountChange
range: Policy
risk_details:
name: risk_details
annotations:
group:
tag: group
value: context
description: Describes the risk associated with the finding.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Details
rank: 1000
alias: risk_details
owner: FileHosting
domain_of:
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
range: string
risk_level:
name: risk_level
annotations:
group:
tag: group
value: context
description: The risk level, normalized to the caption of the risk_level_id value.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Level
rank: 1000
alias: risk_level
owner: FileHosting
domain_of:
- ApplicationObject
- User
- Device
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- SecurityFinding
range: string
risk_level_id:
name: risk_level_id
annotations:
group:
tag: group
value: context
description: The normalized risk level id.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Level ID
rank: 1000
alias: risk_level_id
owner: FileHosting
domain_of:
- ApplicationObject
- User
- Device
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- SecurityFinding
range: RiskLevelIdEnum
risk_score:
name: risk_score
annotations:
group:
tag: group
value: context
description: The risk score as reported by the event source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Score
rank: 1000
alias: risk_score
owner: FileHosting
domain_of:
- Osint
- ApplicationObject
- User
- Device
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- SecurityFinding
range: integer