Class: DroneFlightsActivity
Drone Flights Activity events report the activity of Unmanned Aerial Systems
(UAS), their Operators, and mission-planning and authorization metadata as
reported by the UAS platforms themselves, by Counter-UAS (CUAS) systems, or
other remote monitoring or sensing infrastructure. Based on the Remote ID
defined in Standard Specification for Remote ID and Tracking (ASTM Designation:
F3411-22a) <a target='_blank'
href='https://cdn.standards.iteh.ai/samples/112830/71297057ac42432880a203654f213709/ASTM-F3411-22a.pdf'>ASTM
F3411-22a
URI: ocsf:DroneFlightsActivity
classDiagram
class DroneFlightsActivity
click DroneFlightsActivity href "../DroneFlightsActivity/"
UnmannedSystemsEvent <|-- DroneFlightsActivity
click UnmannedSystemsEvent href "../UnmannedSystemsEvent/"
DroneFlightsActivity : action
DroneFlightsActivity : action_id
DroneFlightsActivity --> "0..1 _recommended_" ActionIdEnum : action_id
click ActionIdEnum href "../ActionIdEnum/"
DroneFlightsActivity : activity_id
DroneFlightsActivity --> "1" DroneFlightsActivityActivityIdEnum : activity_id
click DroneFlightsActivityActivityIdEnum href "../DroneFlightsActivityActivityIdEnum/"
DroneFlightsActivity : activity_name
DroneFlightsActivity : actor
DroneFlightsActivity --> "0..1" Actor : actor
click Actor href "../Actor/"
DroneFlightsActivity : api
DroneFlightsActivity --> "0..1" Api : api
click Api href "../Api/"
DroneFlightsActivity : attacks
DroneFlightsActivity --> "*" Attack : attacks
click Attack href "../Attack/"
DroneFlightsActivity : auth_protocol
DroneFlightsActivity : auth_protocol_id
DroneFlightsActivity --> "0..1" DroneFlightsActivityAuthProtocolIdEnum : auth_protocol_id
click DroneFlightsActivityAuthProtocolIdEnum href "../DroneFlightsActivityAuthProtocolIdEnum/"
DroneFlightsActivity : authorizations
DroneFlightsActivity --> "*" Authorization : authorizations
click Authorization href "../Authorization/"
DroneFlightsActivity : category_name
DroneFlightsActivity : category_uid
DroneFlightsActivity --> "1" BaseEventCategoryUidEnum : category_uid
click BaseEventCategoryUidEnum href "../BaseEventCategoryUidEnum/"
DroneFlightsActivity : class_name
DroneFlightsActivity : class_uid
DroneFlightsActivity --> "1" BaseEventClassUidEnum : class_uid
click BaseEventClassUidEnum href "../BaseEventClassUidEnum/"
DroneFlightsActivity : classification
DroneFlightsActivity : cloud
DroneFlightsActivity --> "1" Cloud : cloud
click Cloud href "../Cloud/"
DroneFlightsActivity : comment
DroneFlightsActivity : confidence
DroneFlightsActivity : confidence_id
DroneFlightsActivity --> "0..1 _recommended_" ConfidenceIdEnum : confidence_id
click ConfidenceIdEnum href "../ConfidenceIdEnum/"
DroneFlightsActivity : confidence_score
DroneFlightsActivity : connection_info
DroneFlightsActivity --> "0..1 _recommended_" NetworkConnectionInfo : connection_info
click NetworkConnectionInfo href "../NetworkConnectionInfo/"
DroneFlightsActivity : count
DroneFlightsActivity : device
DroneFlightsActivity --> "0..1 _recommended_" Device : device
click Device href "../Device/"
DroneFlightsActivity : disposition
DroneFlightsActivity : disposition_id
DroneFlightsActivity --> "0..1 _recommended_" DispositionIdEnum : disposition_id
click DispositionIdEnum href "../DispositionIdEnum/"
DroneFlightsActivity : dst_endpoint
DroneFlightsActivity --> "1" NetworkEndpoint : dst_endpoint
click NetworkEndpoint href "../NetworkEndpoint/"
DroneFlightsActivity : duration
DroneFlightsActivity : end_time
DroneFlightsActivity : enrichments
DroneFlightsActivity --> "*" Enrichment : enrichments
click Enrichment href "../Enrichment/"
DroneFlightsActivity : firewall_rule
DroneFlightsActivity --> "0..1" FirewallRule : firewall_rule
click FirewallRule href "../FirewallRule/"
DroneFlightsActivity : is_alert
DroneFlightsActivity : malware
DroneFlightsActivity --> "*" Malware : malware
click Malware href "../Malware/"
DroneFlightsActivity : malware_scan_info
DroneFlightsActivity --> "0..1" MalwareScanInfo : malware_scan_info
click MalwareScanInfo href "../MalwareScanInfo/"
DroneFlightsActivity : message
DroneFlightsActivity : metadata
DroneFlightsActivity --> "1" Metadata : metadata
click Metadata href "../Metadata/"
DroneFlightsActivity : observables
DroneFlightsActivity --> "* _recommended_" Observable : observables
click Observable href "../Observable/"
DroneFlightsActivity : osint
DroneFlightsActivity --> "1..*" Osint : osint
click Osint href "../Osint/"
DroneFlightsActivity : policy
DroneFlightsActivity --> "0..1" Policy : policy
click Policy href "../Policy/"
DroneFlightsActivity : protocol_name
DroneFlightsActivity : proxy_endpoint
DroneFlightsActivity --> "0..1 _recommended_" NetworkProxy : proxy_endpoint
click NetworkProxy href "../NetworkProxy/"
DroneFlightsActivity : raw_data
DroneFlightsActivity : raw_data_hash
DroneFlightsActivity --> "0..1" Fingerprint : raw_data_hash
click Fingerprint href "../Fingerprint/"
DroneFlightsActivity : raw_data_size
DroneFlightsActivity : risk_details
DroneFlightsActivity : risk_level
DroneFlightsActivity : risk_level_id
DroneFlightsActivity --> "0..1" RiskLevelIdEnum : risk_level_id
click RiskLevelIdEnum href "../RiskLevelIdEnum/"
DroneFlightsActivity : risk_score
DroneFlightsActivity : severity
DroneFlightsActivity : severity_id
DroneFlightsActivity --> "1" SeverityIdEnum : severity_id
click SeverityIdEnum href "../SeverityIdEnum/"
DroneFlightsActivity : src_endpoint
DroneFlightsActivity --> "0..1 _recommended_" NetworkEndpoint : src_endpoint
click NetworkEndpoint href "../NetworkEndpoint/"
DroneFlightsActivity : start_time
DroneFlightsActivity : status
DroneFlightsActivity : status_code
DroneFlightsActivity : status_detail
DroneFlightsActivity : status_id
DroneFlightsActivity --> "0..1 _recommended_" DroneFlightsActivityStatusIdEnum : status_id
click DroneFlightsActivityStatusIdEnum href "../DroneFlightsActivityStatusIdEnum/"
DroneFlightsActivity : time
DroneFlightsActivity : timezone_offset
DroneFlightsActivity : tls
DroneFlightsActivity --> "0..1" Tls : tls
click Tls href "../Tls/"
DroneFlightsActivity : traffic
DroneFlightsActivity --> "0..1 _recommended_" NetworkTraffic : traffic
click NetworkTraffic href "../NetworkTraffic/"
DroneFlightsActivity : type_name
DroneFlightsActivity : type_uid
DroneFlightsActivity : unmanned_aerial_system
DroneFlightsActivity --> "1" UnmannedAerialSystem : unmanned_aerial_system
click UnmannedAerialSystem href "../UnmannedAerialSystem/"
DroneFlightsActivity : unmanned_system_operating_area
DroneFlightsActivity --> "0..1 _recommended_" UnmannedSystemOperatingArea : unmanned_system_operating_area
click UnmannedSystemOperatingArea href "../UnmannedSystemOperatingArea/"
DroneFlightsActivity : unmanned_system_operator
DroneFlightsActivity --> "1" User : unmanned_system_operator
click User href "../User/"
DroneFlightsActivity : unmapped
DroneFlightsActivity --> "0..1" Object : unmapped
click Object href "../Object/"
Inheritance
- BaseEvent [ CloudProfile DatetimeProfile HostProfile OsintProfile SecurityControlProfile]
- UnmannedSystemsEvent
- DroneFlightsActivity
- UnmannedSystemsEvent
Slots
| Name | Cardinality and Range | Description | Inheritance |
|---|---|---|---|
| activity_id | 1 DroneFlightsActivityActivityIdEnum |
The normalized identifier of the activity that triggered the event | direct |
| auth_protocol | 0..1 String |
The authentication type as defined by the caption of | direct |
| auth_protocol_id | 0..1 DroneFlightsActivityAuthProtocolIdEnum |
The normalized identifier of the authentication type used to authorize a flig... | direct |
| classification | 0..1 String |
UA Classification - Allows a region to classify UAS in a regional specific | direct |
| comment | 0..1 String |
This optional, free-text field enables the operator to describe the purpose o... | direct |
| protocol_name | 0..1 String |
The networking protocol associated with the Remote ID device or beacon | direct |
| src_endpoint | 0..1 recommended NetworkEndpoint |
The source network endpoint of the Unmanned Aerial System (UAS), Counter | direct |
| status | 0..1 recommended String |
The normalized Operational status for the Unmanned Aerial System (UAS) | direct |
| status_id | 0..1 recommended DroneFlightsActivityStatusIdEnum |
The normalized Operational status identifier for the Unmanned Aerial System | direct |
| traffic | 0..1 recommended NetworkTraffic |
Traffic refers to the amount of data transmitted from a Unmanned Aerial Syste... | direct |
| unmanned_aerial_system | 1 UnmannedAerialSystem |
The Unmanned Aerial System object describes the characteristics, Position | direct |
| unmanned_system_operating_area | 0..1 recommended UnmannedSystemOperatingArea |
The UAS Operating Area object describes details about a precise area of | direct |
| unmanned_system_operator | 1 User |
The human or machine operator of an Unmanned System | direct |
| connection_info | 0..1 recommended NetworkConnectionInfo |
The network connection information | UnmannedSystemsEvent |
| dst_endpoint | 1 NetworkEndpoint |
The destination network endpoint of the Unmanned Aerial System (UAS), Counter | UnmannedSystemsEvent |
| proxy_endpoint | 0..1 recommended NetworkProxy |
The proxy (server) in a network connection | UnmannedSystemsEvent |
| tls | 0..1 Tls |
The Transport Layer Security (TLS) attributes | UnmannedSystemsEvent |
| activity_name | 0..1 String |
The event activity name, as defined by the activity_id | BaseEvent |
| category_name | 0..1 String |
The event category name, as defined by category_uid value | BaseEvent |
| category_uid | 1 BaseEventCategoryUidEnum |
The category unique identifier of the event | BaseEvent |
| class_name | 0..1 String |
The event class name, as defined by class_uid value | BaseEvent |
| class_uid | 1 BaseEventClassUidEnum |
The unique identifier of a class | BaseEvent |
| count | 0..1 Integer |
The number of times that events in the same logical group occurred during the | BaseEvent |
| duration | 0..1 Integer |
The event duration or aggregate time, the amount of time the event covers fro... | BaseEvent |
| end_time | 0..1 TimestampT |
The end time of a time period, or the time of the most recent event included ... | BaseEvent |
| enrichments | * Enrichment |
The additional information from an external data source, which is associated | BaseEvent |
| message | 0..1 recommended String |
The description of the event/finding, as defined by the source | BaseEvent |
| metadata | 1 Metadata |
The metadata associated with the event or a finding | BaseEvent |
| observables | * recommended Observable |
The observables associated with the event or a finding | BaseEvent |
| raw_data | 0..1 String |
The raw event/finding data as received from the source | BaseEvent |
| raw_data_hash | 0..1 Fingerprint |
The hash, which describes the content of the raw_data field | BaseEvent |
| raw_data_size | 0..1 Integer |
The size of the raw data which was transformed into an OCSF event, in bytes | BaseEvent |
| severity | 0..1 String |
The event/finding severity, normalized to the caption of the | BaseEvent |
| severity_id | 1 SeverityIdEnum |
The normalized identifier of the event/finding severity |
BaseEvent |
| start_time | 0..1 TimestampT |
The start time of a time period, or the time of the least recent event includ... | BaseEvent |
| status_code | 0..1 recommended String |
The event status code, as reported by the event source | BaseEvent |
| status_detail | 0..1 recommended String |
The status detail contains additional information about the event/finding | BaseEvent |
| time | 1 TimestampT |
The normalized event occurrence time or the finding creation time | BaseEvent |
| timezone_offset | 0..1 recommended Integer |
The number of minutes that the reported event time is ahead or |
BaseEvent |
| type_name | 0..1 String |
The event/finding type name, as defined by the type_uid | BaseEvent |
| type_uid | 1 Integer |
The event/finding type ID | BaseEvent |
| unmapped | 0..1 Object |
The attributes that are not mapped to the event schema | BaseEvent |
| api | 0..1 Api |
Describes details about a typical API (Application Programming Interface) cal... | CloudProfile |
| cloud | 1 Cloud |
Describes details about the Cloud environment where the event or finding was | CloudProfile |
| actor | 0..1 Actor |
The actor object describes details about the user/role/process that was the | HostProfile |
| device | 0..1 recommended Device |
An addressable device, computer system or host | HostProfile |
| osint | 1..* Osint |
The OSINT (Open Source Intelligence) object contains details related to an | OsintProfile |
| action | 0..1 String |
The normalized caption of action_id |
SecurityControlProfile |
| action_id | 0..1 recommended ActionIdEnum |
The action taken by a control or other policy-based system leading to an | SecurityControlProfile |
| attacks | * Attack |
An array of MITRE ATT&CK® objects describing identified tactics, techniques & | SecurityControlProfile |
| authorizations | * Authorization |
Provides details about an authorization, such as authorization outcome, and a... | SecurityControlProfile |
| confidence | 0..1 String |
The confidence, normalized to the caption of the confidence_id value | SecurityControlProfile |
| confidence_id | 0..1 recommended ConfidenceIdEnum |
The normalized confidence refers to the accuracy of the rule that created the | SecurityControlProfile |
| confidence_score | 0..1 Integer |
The confidence score as reported by the event source | SecurityControlProfile |
| disposition | 0..1 String |
The disposition name, normalized to the caption of the disposition_id value | SecurityControlProfile |
| disposition_id | 0..1 recommended DispositionIdEnum |
Describes the outcome or action taken by a security control, such as access | SecurityControlProfile |
| firewall_rule | 0..1 FirewallRule |
The firewall rule that pertains to the control that triggered the event, if | SecurityControlProfile |
| is_alert | 0..1 recommended Boolean |
Indicates that the event is considered to be an alertable signal | SecurityControlProfile |
| malware | * Malware |
A list of Malware objects, describing details about the identified malware | SecurityControlProfile |
| malware_scan_info | 0..1 MalwareScanInfo |
Describes details about the scan job that identified malware on the target | SecurityControlProfile |
| policy | 0..1 Policy |
The policy that pertains to the control that triggered the event, if | SecurityControlProfile |
| risk_details | 0..1 String |
Describes the risk associated with the finding | SecurityControlProfile |
| risk_level | 0..1 String |
The risk level, normalized to the caption of the risk_level_id value | SecurityControlProfile |
| risk_level_id | 0..1 RiskLevelIdEnum |
The normalized risk level id | SecurityControlProfile |
| risk_score | 0..1 Integer |
The risk score as reported by the event source | SecurityControlProfile |
Rules
| Rule Applied | Preconditions | Postconditions | Elseconditions |
|---|---|---|---|
| any_of | [{'slot_conditions': {'src_endpoint': {'required': True}}}, {'slot_conditions': {'unmanned_aerial_system': {'required': True}}}, {'slot_conditions': {'unmanned_system_operator': {'required': True}}}, {'slot_conditions': {'unmanned_system_operating_area': {'required': True}}}] |
In Subsets
Aliases
- Drone Flights Activity
Identifier and Mapping Information
Annotations
| property | value |
|---|---|
| ocsf_constraints | {"at_least_one": ["src_endpoint", "unmanned_aerial_system", |
| "unmanned_system_operator", "unmanned_system_operating_area"]} | |
| ocsf_event_uid | 1 |
Schema Source
- from schema: https://w3id.org/lmodel/ocsf
Mappings
| Mapping Type | Mapped Value |
|---|---|
| self | ocsf:DroneFlightsActivity |
| native | ocsf:DroneFlightsActivity |
LinkML Source
Direct
name: DroneFlightsActivity
annotations:
ocsf_constraints:
tag: ocsf_constraints
value: '{"at_least_one": ["src_endpoint", "unmanned_aerial_system",
"unmanned_system_operator", "unmanned_system_operating_area"]}'
ocsf_event_uid:
tag: ocsf_event_uid
value: 1
description: 'Drone Flights Activity events report the activity of Unmanned Aerial
Systems
(UAS), their Operators, and mission-planning and authorization metadata as
reported by the UAS platforms themselves, by Counter-UAS (CUAS) systems, or
other remote monitoring or sensing infrastructure. Based on the Remote ID
defined in Standard Specification for Remote ID and Tracking (ASTM Designation:
F3411-22a) <a target=''_blank''
href=''https://cdn.standards.iteh.ai/samples/112830/71297057ac42432880a203654f213709/ASTM-F3411-22a.pdf''>ASTM
F3411-22a</a>'
in_subset:
- unmanned_systems_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Drone Flights Activity
is_a: UnmannedSystemsEvent
slots:
- activity_id
- auth_protocol
- auth_protocol_id
- classification
- comment
- protocol_name
- src_endpoint
- status
- status_id
- traffic
- unmanned_aerial_system
- unmanned_system_operating_area
- unmanned_system_operator
slot_usage:
activity_id:
name: activity_id
annotations:
group:
tag: group
value: primary
range: DroneFlightsActivityActivityIdEnum
required: true
auth_protocol:
name: auth_protocol
annotations:
group:
tag: group
value: context
description: 'The authentication type as defined by the caption of
<code>auth_protocol_id</code>. In the case of ''Other'', it is defined by the
event source.'
auth_protocol_id:
name: auth_protocol_id
annotations:
group:
tag: group
value: context
description: 'The normalized identifier of the authentication type used to authorize
a flight
plan or mission.'
range: DroneFlightsActivityAuthProtocolIdEnum
classification:
name: classification
annotations:
group:
tag: group
value: context
description: 'UA Classification - Allows a region to classify UAS in a regional
specific
manner. The format may differ from region to region.'
comment:
name: comment
annotations:
group:
tag: group
value: context
description: 'This optional, free-text field enables the operator to describe
the purpose of
a flight, if so desired.'
protocol_name:
name: protocol_name
annotations:
group:
tag: group
value: context
description: 'The networking protocol associated with the Remote ID device or
beacon. E.g.
<code>BLE</code>, <code>LTE</code>, <code>802.11</code>.'
src_endpoint:
name: src_endpoint
annotations:
group:
tag: group
value: context
status:
name: status
annotations:
group:
tag: group
value: context
description: 'The normalized Operational status for the Unmanned Aerial System
(UAS)
normalized to the caption of the <code>status_id</code> value. In the case of
''Other'', it is defined by the source.'
status_id:
name: status_id
annotations:
group:
tag: group
value: primary
description: 'The normalized Operational status identifier for the Unmanned Aerial
System
(UAS).'
range: DroneFlightsActivityStatusIdEnum
recommended: true
traffic:
name: traffic
annotations:
group:
tag: group
value: context
description: 'Traffic refers to the amount of data transmitted from a Unmanned
Aerial System
(UAS) or Counter Unmanned Aerial System (UAS) (CUAS) system at a given point
of
time. Ex: <code>bytes_in</code> and <code>bytes_out</code>.'
unmanned_aerial_system:
name: unmanned_aerial_system
annotations:
group:
tag: group
value: primary
required: true
unmanned_system_operating_area:
name: unmanned_system_operating_area
annotations:
group:
tag: group
value: primary
recommended: true
unmanned_system_operator:
name: unmanned_system_operator
annotations:
group:
tag: group
value: primary
required: true
rules:
- postconditions:
any_of:
- slot_conditions:
src_endpoint:
name: src_endpoint
required: true
- slot_conditions:
unmanned_aerial_system:
name: unmanned_aerial_system
required: true
- slot_conditions:
unmanned_system_operator:
name: unmanned_system_operator
required: true
- slot_conditions:
unmanned_system_operating_area:
name: unmanned_system_operating_area
required: true
description: 'OCSF at_least_one: at least one of [''src_endpoint'', ''unmanned_aerial_system'',
''unmanned_system_operator'', ''unmanned_system_operating_area''] must be set.'
Induced
name: DroneFlightsActivity
annotations:
ocsf_constraints:
tag: ocsf_constraints
value: '{"at_least_one": ["src_endpoint", "unmanned_aerial_system",
"unmanned_system_operator", "unmanned_system_operating_area"]}'
ocsf_event_uid:
tag: ocsf_event_uid
value: 1
description: 'Drone Flights Activity events report the activity of Unmanned Aerial
Systems
(UAS), their Operators, and mission-planning and authorization metadata as
reported by the UAS platforms themselves, by Counter-UAS (CUAS) systems, or
other remote monitoring or sensing infrastructure. Based on the Remote ID
defined in Standard Specification for Remote ID and Tracking (ASTM Designation:
F3411-22a) <a target=''_blank''
href=''https://cdn.standards.iteh.ai/samples/112830/71297057ac42432880a203654f213709/ASTM-F3411-22a.pdf''>ASTM
F3411-22a</a>'
in_subset:
- unmanned_systems_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Drone Flights Activity
is_a: UnmannedSystemsEvent
slot_usage:
activity_id:
name: activity_id
annotations:
group:
tag: group
value: primary
range: DroneFlightsActivityActivityIdEnum
required: true
auth_protocol:
name: auth_protocol
annotations:
group:
tag: group
value: context
description: 'The authentication type as defined by the caption of
<code>auth_protocol_id</code>. In the case of ''Other'', it is defined by the
event source.'
auth_protocol_id:
name: auth_protocol_id
annotations:
group:
tag: group
value: context
description: 'The normalized identifier of the authentication type used to authorize
a flight
plan or mission.'
range: DroneFlightsActivityAuthProtocolIdEnum
classification:
name: classification
annotations:
group:
tag: group
value: context
description: 'UA Classification - Allows a region to classify UAS in a regional
specific
manner. The format may differ from region to region.'
comment:
name: comment
annotations:
group:
tag: group
value: context
description: 'This optional, free-text field enables the operator to describe
the purpose of
a flight, if so desired.'
protocol_name:
name: protocol_name
annotations:
group:
tag: group
value: context
description: 'The networking protocol associated with the Remote ID device or
beacon. E.g.
<code>BLE</code>, <code>LTE</code>, <code>802.11</code>.'
src_endpoint:
name: src_endpoint
annotations:
group:
tag: group
value: context
status:
name: status
annotations:
group:
tag: group
value: context
description: 'The normalized Operational status for the Unmanned Aerial System
(UAS)
normalized to the caption of the <code>status_id</code> value. In the case of
''Other'', it is defined by the source.'
status_id:
name: status_id
annotations:
group:
tag: group
value: primary
description: 'The normalized Operational status identifier for the Unmanned Aerial
System
(UAS).'
range: DroneFlightsActivityStatusIdEnum
recommended: true
traffic:
name: traffic
annotations:
group:
tag: group
value: context
description: 'Traffic refers to the amount of data transmitted from a Unmanned
Aerial System
(UAS) or Counter Unmanned Aerial System (UAS) (CUAS) system at a given point
of
time. Ex: <code>bytes_in</code> and <code>bytes_out</code>.'
unmanned_aerial_system:
name: unmanned_aerial_system
annotations:
group:
tag: group
value: primary
required: true
unmanned_system_operating_area:
name: unmanned_system_operating_area
annotations:
group:
tag: group
value: primary
recommended: true
unmanned_system_operator:
name: unmanned_system_operator
annotations:
group:
tag: group
value: primary
required: true
attributes:
activity_id:
name: activity_id
annotations:
group:
tag: group
value: primary
description: The normalized identifier of the activity that triggered the event.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Activity ID
rank: 1000
alias: activity_id
owner: DroneFlightsActivity
domain_of:
- BaseEvent
- ApiActivity
- ApplicationError
- ApplicationLifecycle
- DatastoreActivity
- FileHosting
- ScanActivity
- WebResourceAccessActivity
- WebResourcesActivity
- DiscoveryEvent
- DiscoveryResult
- DataSecurityFinding
- Finding
- IncidentFinding
- SecurityFinding
- AccountChange
- Authentication
- AuthorizeSession
- EntityManagement
- GroupManagement
- UserAccess
- DhcpActivity
- DnsActivity
- EmailActivity
- EmailFileActivity
- EmailUrlActivity
- FtpActivity
- HttpActivity
- NetworkActivity
- NetworkFileActivity
- NtpActivity
- RdpActivity
- SmbActivity
- SshActivity
- TunnelActivity
- RemediationActivity
- EventLogActvity
- FileActivity
- KernelActivity
- KernelExtensionActivity
- MemoryActivity
- ModuleActivity
- PeripheralActivity
- ProcessActivity
- ScheduledJobActivity
- ScriptActivity
- AirborneBroadcastActivity
- DroneFlightsActivity
- RegistryKeyActivity
- RegistryValueActivity
- WindowsResourceActivity
- WindowsServiceActivity
range: DroneFlightsActivityActivityIdEnum
required: true
auth_protocol:
name: auth_protocol
annotations:
group:
tag: group
value: context
description: 'The authentication type as defined by the caption of
<code>auth_protocol_id</code>. In the case of ''Other'', it is defined by the
event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Auth Protocol
rank: 1000
alias: auth_protocol
owner: DroneFlightsActivity
domain_of:
- Scim
- Sso
- Authentication
- DroneFlightsActivity
range: string
auth_protocol_id:
name: auth_protocol_id
annotations:
group:
tag: group
value: context
description: 'The normalized identifier of the authentication type used to authorize
a flight
plan or mission.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Auth Protocol ID
rank: 1000
alias: auth_protocol_id
owner: DroneFlightsActivity
domain_of:
- Scim
- Sso
- Authentication
- DroneFlightsActivity
range: DroneFlightsActivityAuthProtocolIdEnum
classification:
name: classification
annotations:
group:
tag: group
value: context
description: 'UA Classification - Allows a region to classify UAS in a regional
specific
manner. The format may differ from region to region.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Classification
rank: 1000
alias: classification
owner: DroneFlightsActivity
domain_of:
- Advisory
- KbArticle
- LoadBalancer
- DroneFlightsActivity
range: string
comment:
name: comment
annotations:
group:
tag: group
value: context
description: 'This optional, free-text field enables the operator to describe
the purpose of
a flight, if so desired.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Comment
rank: 1000
alias: comment
owner: DroneFlightsActivity
domain_of:
- Osint
- Finding
- IncidentFinding
- EntityManagement
- DroneFlightsActivity
range: string
protocol_name:
name: protocol_name
annotations:
group:
tag: group
value: context
description: 'The networking protocol associated with the Remote ID device or
beacon. E.g.
<code>BLE</code>, <code>LTE</code>, <code>802.11</code>.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Protocol Name
rank: 1000
alias: protocol_name
owner: DroneFlightsActivity
domain_of:
- PortInfo
- Scim
- Sso
- Idp
- NetworkConnectionInfo
- EmailActivity
- TunnelActivity
- AirborneBroadcastActivity
- DroneFlightsActivity
range: string
src_endpoint:
name: src_endpoint
annotations:
group:
tag: group
value: context
description: 'The source network endpoint of the Unmanned Aerial System (UAS),
Counter
Unmanned Aerial System (CUAS) platform, or other unmanned systems monitoring
and/or sensing infrastructure.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Source Endpoint
rank: 1000
alias: src_endpoint
owner: DroneFlightsActivity
domain_of:
- Evidences
- ApiActivity
- DatastoreActivity
- FileHosting
- WebResourceAccessActivity
- WebResourcesActivity
- DataSecurityFinding
- IamEvent
- NetworkEvent
- DhcpActivity
- EmailActivity
- NetworkActivity
- NetworkFileActivity
- TunnelActivity
- EventLogActvity
- UnmannedSystemsEvent
- AirborneBroadcastActivity
- DroneFlightsActivity
range: NetworkEndpoint
recommended: true
status:
name: status
annotations:
group:
tag: group
value: context
description: 'The normalized Operational status for the Unmanned Aerial System
(UAS)
normalized to the caption of the <code>status_id</code> value. In the case of
''Other'', it is defined by the source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status
rank: 1000
alias: status
owner: DroneFlightsActivity
domain_of:
- RelatedEvent
- Ticket
- Whois
- AdditionalRestriction
- Check
- Compliance
- DataClassification
- HttpResponse
- BaseEvent
- Finding
- IncidentFinding
- DroneFlightsActivity
range: string
recommended: true
status_id:
name: status_id
annotations:
group:
tag: group
value: primary
description: 'The normalized Operational status identifier for the Unmanned Aerial
System
(UAS).'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status ID
rank: 1000
alias: status_id
owner: DroneFlightsActivity
domain_of:
- Ticket
- AdditionalRestriction
- Check
- Compliance
- DataClassification
- BaseEvent
- Finding
- IncidentFinding
- RemediationActivity
- DroneFlightsActivity
range: DroneFlightsActivityStatusIdEnum
recommended: true
traffic:
name: traffic
annotations:
group:
tag: group
value: context
description: 'Traffic refers to the amount of data transmitted from a Unmanned
Aerial System
(UAS) or Counter Unmanned Aerial System (UAS) (CUAS) system at a given point
of
time. Ex: <code>bytes_in</code> and <code>bytes_out</code>.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Traffic
rank: 1000
alias: traffic
owner: DroneFlightsActivity
domain_of:
- NetworkEvent
- DnsActivity
- TunnelActivity
- UnmannedSystemsEvent
- AirborneBroadcastActivity
- DroneFlightsActivity
range: NetworkTraffic
recommended: true
unmanned_aerial_system:
name: unmanned_aerial_system
annotations:
group:
tag: group
value: primary
description: 'The Unmanned Aerial System object describes the characteristics,
Position
Location Information (PLI), and other metadata of Unmanned Aerial Systems (UAS)
and other unmanned and drone systems used in Remote ID. Remote ID is defined
in
the Standard Specification for Remote ID and Tracking (ASTM Designation:
F3411-22a) <a target=''_blank''
href=''https://cdn.standards.iteh.ai/samples/112830/71297057ac42432880a203654f213709/ASTM-F3411-22a.pdf''>ASTM
F3411-22a</a>.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Unmanned Aerial System
rank: 1000
alias: unmanned_aerial_system
owner: DroneFlightsActivity
domain_of:
- AirborneBroadcastActivity
- DroneFlightsActivity
range: UnmannedAerialSystem
required: true
unmanned_system_operating_area:
name: unmanned_system_operating_area
annotations:
group:
tag: group
value: primary
description: 'The UAS Operating Area object describes details about a precise
area of
operations for a UAS flight or mission.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- UAS Operating Area
rank: 1000
alias: unmanned_system_operating_area
owner: DroneFlightsActivity
domain_of:
- AirborneBroadcastActivity
- DroneFlightsActivity
range: UnmannedSystemOperatingArea
recommended: true
unmanned_system_operator:
name: unmanned_system_operator
annotations:
group:
tag: group
value: primary
description: The human or machine operator of an Unmanned System.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Unmanned Systems Operator
rank: 1000
alias: unmanned_system_operator
owner: DroneFlightsActivity
domain_of:
- AirborneBroadcastActivity
- DroneFlightsActivity
range: User
required: true
connection_info:
name: connection_info
annotations:
group:
tag: group
value: context
description: The network connection information.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Connection Info
rank: 1000
alias: connection_info
owner: DroneFlightsActivity
domain_of:
- QueryEvidence
- Evidences
- FileHosting
- NetworkConnectionQuery
- NetworkEvent
- DnsActivity
- NetworkFileActivity
- RdpActivity
- TunnelActivity
- NetworkRemediationActivity
- UnmannedSystemsEvent
range: NetworkConnectionInfo
recommended: true
dst_endpoint:
name: dst_endpoint
annotations:
group:
tag: group
value: context
description: 'The destination network endpoint of the Unmanned Aerial System (UAS),
Counter
Unmanned Aerial System (CUAS) platform, or other unmanned systems monitoring
and/or sensing infrastructure.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Destination Endpoint
rank: 1000
alias: dst_endpoint
owner: DroneFlightsActivity
domain_of:
- Evidences
- LoadBalancer
- ApiActivity
- DatastoreActivity
- FileHosting
- WebResourcesActivity
- DataSecurityFinding
- Authentication
- AuthorizeSession
- NetworkEvent
- DhcpActivity
- DnsActivity
- EmailActivity
- NetworkActivity
- NetworkFileActivity
- TunnelActivity
- EventLogActvity
- UnmannedSystemsEvent
- AirborneBroadcastActivity
range: NetworkEndpoint
required: true
proxy_endpoint:
name: proxy_endpoint
annotations:
group:
tag: group
value: context
description: The proxy (server) in a network connection.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Proxy Endpoint
rank: 1000
alias: proxy_endpoint
owner: DroneFlightsActivity
domain_of:
- NetworkEndpoint
- NetworkProxyProfile
- UnmannedSystemsEvent
range: NetworkProxy
recommended: true
tls:
name: tls
annotations:
group:
tag: group
value: context
description: The Transport Layer Security (TLS) attributes.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- TLS
rank: 1000
alias: tls
owner: DroneFlightsActivity
domain_of:
- Evidences
- WebResourceAccessActivity
- WebResourcesActivity
- NetworkEvent
- UnmannedSystemsEvent
range: Tls
activity_name:
name: activity_name
annotations:
group:
tag: group
value: classification
description: The event activity name, as defined by the activity_id.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Activity
rank: 1000
alias: activity_name
owner: DroneFlightsActivity
domain_of:
- BaseEvent
- DataSecurityFinding
- Finding
- IncidentFinding
range: string
category_name:
name: category_name
annotations:
group:
tag: group
value: classification
description: The event category name, as defined by category_uid value.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Category
rank: 1000
alias: category_name
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: string
category_uid:
name: category_uid
annotations:
group:
tag: group
value: classification
description: The category unique identifier of the event.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Category ID
rank: 1000
alias: category_uid
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: BaseEventCategoryUidEnum
required: true
class_name:
name: class_name
annotations:
group:
tag: group
value: classification
description: The event class name, as defined by class_uid value.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Class
rank: 1000
alias: class_name
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: string
class_uid:
name: class_uid
annotations:
group:
tag: group
value: classification
description: 'The unique identifier of a class. A class describes the attributes
available in
an event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Class ID
rank: 1000
alias: class_uid
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: BaseEventClassUidEnum
required: true
count:
name: count
annotations:
group:
tag: group
value: occurrence
description: 'The number of times that events in the same logical group occurred
during the
event <strong>Start Time</strong> to <strong>End Time</strong> period.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Count
rank: 1000
alias: count
owner: DroneFlightsActivity
domain_of:
- Observation
- RelatedEvent
- Session
- DiscoveryDetails
- UnmannedSystemOperatingArea
- BaseEvent
range: integer
duration:
name: duration
annotations:
group:
tag: group
value: occurrence
description: 'The event duration or aggregate time, the amount of time the event
covers from
<code>start_time</code> to <code>end_time</code> in milliseconds.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Duration Milliseconds
rank: 1000
alias: duration
owner: DroneFlightsActivity
domain_of:
- Span
- Timespan
- Trace
- FirewallRule
- BaseEvent
- ScanActivity
range: integer
end_time:
name: end_time
annotations:
group:
tag: group
value: occurrence
description: 'The end time of a time period, or the time of the most recent event
included in
the aggregate event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- End Time
rank: 1000
alias: end_time
owner: DroneFlightsActivity
domain_of:
- Span
- Timespan
- Trace
- NetworkTraffic
- UnmannedSystemOperatingArea
- MalwareScanInfo
- BaseEvent
- ScanActivity
- Finding
- IncidentFinding
range: TimestampT
enrichments:
name: enrichments
annotations:
group:
tag: group
value: context
description: 'The additional information from an external data source, which is
associated
with the event or a finding. For example add location information for the IP
address in the DNS answers:</p><code>[{"name": "answers.ip", "value":
"92.24.47.250", "type": "location", "data": {"city": "Socotra", "continent":
"Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc":
"Yemen"}}]</code>'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Enrichments
rank: 1000
alias: enrichments
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: Enrichment
multivalued: true
message:
name: message
annotations:
group:
tag: group
value: primary
description: The description of the event/finding, as defined by the source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Message
rank: 1000
alias: message
owner: DroneFlightsActivity
domain_of:
- Response
- Span
- HttpResponse
- LoadBalancer
- BaseEvent
- ApplicationError
range: string
recommended: true
metadata:
name: metadata
annotations:
group:
tag: group
value: context
description: The metadata associated with the event or a finding.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Metadata
rank: 1000
alias: metadata
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: Metadata
required: true
observables:
name: observables
annotations:
group:
tag: group
value: primary
description: The observables associated with the event or a finding.
notes:
- 'OCSF Observables FAQ —
https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md'
from_schema: https://w3id.org/lmodel/ocsf
see_also:
- https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md
aliases:
- Observables
rank: 1000
alias: observables
owner: DroneFlightsActivity
domain_of:
- RelatedEvent
- BaseEvent
range: Observable
recommended: true
multivalued: true
raw_data:
name: raw_data
annotations:
group:
tag: group
value: context
description: The raw event/finding data as received from the source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Raw Data
rank: 1000
alias: raw_data
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: string
raw_data_hash:
name: raw_data_hash
annotations:
group:
tag: group
value: context
description: The hash, which describes the content of the raw_data field.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Raw Data Hash
rank: 1000
alias: raw_data_hash
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: Fingerprint
raw_data_size:
name: raw_data_size
annotations:
group:
tag: group
value: context
description: The size of the raw data which was transformed into an OCSF event,
in bytes.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Raw Data Size
rank: 1000
alias: raw_data_size
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: integer
severity:
name: severity
annotations:
group:
tag: group
value: classification
description: 'The event/finding severity, normalized to the caption of the
<code>severity_id</code> value. In the case of ''Other'', it is defined by the
source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Severity
rank: 1000
alias: severity
owner: DroneFlightsActivity
domain_of:
- Osint
- RelatedEvent
- VendorAttributes
- Vulnerability
- Check
- Cvss
- KbArticle
- Malware
- BaseEvent
range: string
severity_id:
name: severity_id
annotations:
group:
tag: group
value: classification
description: '<p>The normalized identifier of the event/finding severity.</p>The
normalized
severity is a measurement the effort and expense required to manage and resolve
an event or incident. Smaller numerical values represent lower impact events,
and larger numerical values represent higher impact events.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Severity ID
rank: 1000
alias: severity_id
owner: DroneFlightsActivity
domain_of:
- Osint
- RelatedEvent
- VendorAttributes
- Check
- Malware
- BaseEvent
range: SeverityIdEnum
required: true
start_time:
name: start_time
annotations:
group:
tag: group
value: occurrence
description: 'The start time of a time period, or the time of the least recent
event included
in the aggregate event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Start Time
rank: 1000
alias: start_time
owner: DroneFlightsActivity
domain_of:
- Span
- Timespan
- Trace
- NetworkTraffic
- UnmannedSystemOperatingArea
- MalwareScanInfo
- BaseEvent
- ScanActivity
- Finding
- IncidentFinding
range: TimestampT
status_code:
name: status_code
annotations:
group:
tag: group
value: primary
description: 'The event status code, as reported by the event source.<br /><br
/>For example,
in a Windows Failed Authentication event, this would be the value of ''Failure
Code'', e.g. 0x18.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status Code
rank: 1000
alias: status_code
owner: DroneFlightsActivity
domain_of:
- Span
- Compliance
- BaseEvent
- EventLogActvity
range: string
recommended: true
status_detail:
name: status_detail
annotations:
group:
tag: group
value: primary
description: 'The status detail contains additional information about the event/finding
outcome.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Status Detail
rank: 1000
alias: status_detail
owner: DroneFlightsActivity
domain_of:
- Compliance
- LoadBalancer
- BaseEvent
- Authentication
- EventLogActvity
range: string
recommended: true
time:
name: time
annotations:
group:
tag: group
value: occurrence
description: The normalized event occurrence time or the finding creation time.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Event Time
rank: 1000
alias: time
owner: DroneFlightsActivity
domain_of:
- TransformationInfo
- BaseEvent
range: TimestampT
required: true
timezone_offset:
name: timezone_offset
annotations:
group:
tag: group
value: occurrence
description: 'The number of minutes that the reported event <code>time</code>
is ahead or
behind UTC, in the range -1,080 to +1,080.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Timezone Offset
rank: 1000
alias: timezone_offset
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: integer
recommended: true
type_name:
name: type_name
annotations:
group:
tag: group
value: classification
description: The event/finding type name, as defined by the type_uid.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Type Name
rank: 1000
alias: type_name
owner: DroneFlightsActivity
domain_of:
- RelatedEvent
- BaseEvent
range: string
type_uid:
name: type_uid
annotations:
group:
tag: group
value: classification
description: 'The event/finding type ID. It identifies the event''s semantics
and structure.
The value is calculated by the logging system as: <code>class_uid * 100 +
activity_id</code>.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Type ID
rank: 1000
alias: type_uid
owner: DroneFlightsActivity
domain_of:
- Observable
- RelatedEvent
- BaseEvent
range: integer
required: true
unmapped:
name: unmapped
annotations:
group:
tag: group
value: context
description: 'The attributes that are not mapped to the event schema. The names
and values of
those attributes are specific to the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Unmapped Data
rank: 1000
alias: unmapped
owner: DroneFlightsActivity
domain_of:
- BaseEvent
range: Object
api:
name: api
annotations:
group:
tag: group
value: context
description: Describes details about a typical API (Application Programming Interface)
call.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- API Details
rank: 1000
alias: api
owner: DroneFlightsActivity
domain_of:
- Evidences
- CloudProfile
- ApiActivity
range: Api
cloud:
name: cloud
annotations:
group:
tag: group
value: primary
description: 'Describes details about the Cloud environment where the event or
finding was
created.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Cloud
rank: 1000
alias: cloud
owner: DroneFlightsActivity
domain_of:
- CloudProfile
- CloudResourcesInventoryInfo
range: Cloud
required: true
actor:
name: actor
description: 'The actor object describes details about the user/role/process that
was the
source of the activity. Note that this is not the threat actor of a campaign
but may be part of a campaign.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Actor
rank: 1000
alias: actor
owner: DroneFlightsActivity
domain_of:
- Evidences
- HostProfile
- ApiActivity
- DatastoreActivity
- FileHosting
- ConfigState
- DeviceConfigStateChange
- InventoryInfo
- OsintInventoryInfo
- SoftwareInfo
- UserInventory
- DataSecurityFinding
- IamEvent
- NetworkFileActivity
- SystemEvent
- EventLogActvity
- FileActivity
- KernelExtensionActivity
- ModuleActivity
- ProcessActivity
- ScheduledJobActivity
- RegistryKeyActivity
- RegistryValueActivity
range: Actor
device:
name: device
description: An addressable device, computer system or host.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Device
rank: 1000
alias: device
owner: DroneFlightsActivity
domain_of:
- AuthFactor
- Evidences
- Logger
- ManagedEntity
- HostProfile
- ConfigState
- DeviceConfigStateChange
- EvidenceInfo
- InventoryInfo
- PatchState
- SoftwareInfo
- DataSecurityFinding
- Finding
- RdpActivity
- TunnelActivity
- SystemEvent
- EventLogActvity
range: Device
recommended: true
osint:
name: osint
annotations:
group:
tag: group
value: primary
description: 'The OSINT (Open Source Intelligence) object contains details related
to an
indicator such as the indicator itself, related indicators, geolocation,
registrar information, subdomains, analyst commentary, and other contextual
information. This information can be used to further enrich a detection or
finding by providing decisioning support to other analysts and engineers.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- OSINT
rank: 1000
alias: osint
owner: DroneFlightsActivity
domain_of:
- OsintProfile
- OsintInventoryInfo
range: Osint
required: true
multivalued: true
action:
name: action
description: The normalized caption of <code>action_id</code>.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Action
rank: 1000
alias: action
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
range: string
action_id:
name: action_id
annotations:
sibling:
tag: sibling
value: action
description: 'The action taken by a control or other policy-based system leading
to an
outcome or disposition. An unknown action may still correspond to a known
disposition. Refer to <code>disposition_id</code> for the outcome of the
action.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Action ID
rank: 1000
alias: action_id
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
range: ActionIdEnum
recommended: true
attacks:
name: attacks
description: 'An array of MITRE ATT&CK® objects describing identified tactics,
techniques &
sub-techniques. The objects are compatible with MITRE ATLAS™ tactics,
techniques & sub-techniques.'
notes:
- MITRE ATT&CK® — https://attack.mitre.org
- MITRE ATLAS — https://atlas.mitre.org/matrices/ATLAS
from_schema: https://w3id.org/lmodel/ocsf
see_also:
- https://attack.mitre.org
- https://atlas.mitre.org/matrices/ATLAS
aliases:
- MITRE ATT&CK® and ATLAS™ Details
rank: 1000
alias: attacks
owner: DroneFlightsActivity
domain_of:
- Osint
- RelatedEvent
- FindingInfo
- SecurityControlProfile
- IncidentFinding
- SecurityFinding
range: Attack
multivalued: true
authorizations:
name: authorizations
description: 'Provides details about an authorization, such as authorization outcome,
and any
associated policies related to the activity/event.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Authorization Information
rank: 1000
alias: authorizations
owner: DroneFlightsActivity
domain_of:
- Actor
- SecurityControlProfile
range: Authorization
multivalued: true
confidence:
name: confidence
annotations:
group:
tag: group
value: context
description: 'The confidence, normalized to the caption of the confidence_id value.
In the
case of ''Other'', it is defined by the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Confidence
rank: 1000
alias: confidence
owner: DroneFlightsActivity
domain_of:
- Osint
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- Finding
- IncidentFinding
- SecurityFinding
range: string
confidence_id:
name: confidence_id
annotations:
group:
tag: group
value: context
description: 'The normalized confidence refers to the accuracy of the rule that
created the
finding. A rule with a low confidence means that the finding scope is wide and
may create finding reports that may not be malicious in nature.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Confidence ID
rank: 1000
alias: confidence_id
owner: DroneFlightsActivity
domain_of:
- Osint
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- Finding
- IncidentFinding
- SecurityFinding
range: ConfidenceIdEnum
recommended: true
confidence_score:
name: confidence_score
annotations:
group:
tag: group
value: context
description: The confidence score as reported by the event source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Confidence Score
rank: 1000
alias: confidence_score
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- Finding
- IncidentFinding
- SecurityFinding
range: integer
disposition:
name: disposition
description: 'The disposition name, normalized to the caption of the disposition_id
value. In
the case of ''Other'', it is defined by the event source.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Disposition
rank: 1000
alias: disposition
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
range: string
disposition_id:
name: disposition_id
annotations:
sibling:
tag: sibling
value: disposition
description: 'Describes the outcome or action taken by a security control, such
as access
control checks, malware detections or various types of policy violations.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Disposition ID
rank: 1000
alias: disposition_id
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
range: DispositionIdEnum
recommended: true
firewall_rule:
name: firewall_rule
description: 'The firewall rule that pertains to the control that triggered the
event, if
applicable.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Firewall Rule
rank: 1000
alias: firewall_rule
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
range: FirewallRule
is_alert:
name: is_alert
description: 'Indicates that the event is considered to be an alertable signal.
Should be set
to <code>true</code> if <code>disposition_id = Alert</code> among other
dispositions, and/or <code>risk_level_id</code> or <code>severity_id</code>
of
the event is elevated. Not all control events will be alertable, for example
if
<code>disposition_id = Exonerated</code> or <code>disposition_id =
Allowed</code>.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Alert
rank: 1000
alias: is_alert
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
range: boolean
recommended: true
malware:
name: malware
description: A list of Malware objects, describing details about the identified
malware.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Malware
rank: 1000
alias: malware
owner: DroneFlightsActivity
domain_of:
- Osint
- SecurityControlProfile
- DetectionFinding
- SecurityFinding
range: Malware
multivalued: true
malware_scan_info:
name: malware_scan_info
description: 'Describes details about the scan job that identified malware on
the target
system.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Malware Scan Info
rank: 1000
alias: malware_scan_info
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
- DetectionFinding
range: MalwareScanInfo
policy:
name: policy
description: 'The policy that pertains to the control that triggered the event,
if
applicable. For example the name of an anti-malware policy or an access control
policy.'
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Policy
rank: 1000
alias: policy
owner: DroneFlightsActivity
domain_of:
- PermissionAnalysisResult
- AdditionalRestriction
- Assessment
- Authorization
- DataClassification
- DataSecurity
- ManagedEntity
- SecurityControlProfile
- ScanActivity
- AccountChange
range: Policy
risk_details:
name: risk_details
annotations:
group:
tag: group
value: context
description: Describes the risk associated with the finding.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Details
rank: 1000
alias: risk_details
owner: DroneFlightsActivity
domain_of:
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
range: string
risk_level:
name: risk_level
annotations:
group:
tag: group
value: context
description: The risk level, normalized to the caption of the risk_level_id value.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Level
rank: 1000
alias: risk_level
owner: DroneFlightsActivity
domain_of:
- ApplicationObject
- User
- Device
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- SecurityFinding
range: string
risk_level_id:
name: risk_level_id
annotations:
group:
tag: group
value: context
description: The normalized risk level id.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Level ID
rank: 1000
alias: risk_level_id
owner: DroneFlightsActivity
domain_of:
- ApplicationObject
- User
- Device
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- SecurityFinding
range: RiskLevelIdEnum
risk_score:
name: risk_score
annotations:
group:
tag: group
value: context
description: The risk score as reported by the event source.
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Risk Score
rank: 1000
alias: risk_score
owner: DroneFlightsActivity
domain_of:
- Osint
- ApplicationObject
- User
- Device
- SecurityControlProfile
- DataSecurityFinding
- DetectionFinding
- SecurityFinding
range: integer
rules:
- postconditions:
any_of:
- slot_conditions:
src_endpoint:
name: src_endpoint
required: true
- slot_conditions:
unmanned_aerial_system:
name: unmanned_aerial_system
required: true
- slot_conditions:
unmanned_system_operator:
name: unmanned_system_operator
required: true
- slot_conditions:
unmanned_system_operating_area:
name: unmanned_system_operating_area
required: true
description: 'OCSF at_least_one: at least one of [''src_endpoint'', ''unmanned_aerial_system'',
''unmanned_system_operator'', ''unmanned_system_operating_area''] must be set.'