Skip to content

Class: DatastoreActivity

Datastore events describe general activities (Read, Update, Query, Delete,

etc.) which affect datastores or data within those datastores, e.g. (AWS RDS,

AWS S3).

URI: ocsf:DatastoreActivity

 classDiagram
    class DatastoreActivity
    click DatastoreActivity href "../DatastoreActivity/"
      AiOperationProfile <|-- DatastoreActivity
        click AiOperationProfile href "../AiOperationProfile/"
      ApplicationEvent <|-- DatastoreActivity
        click ApplicationEvent href "../ApplicationEvent/"

      DatastoreActivity : action

      DatastoreActivity : action_id





        DatastoreActivity --> "0..1 _recommended_" ActionIdEnum : action_id
        click ActionIdEnum href "../ActionIdEnum/"



      DatastoreActivity : activity_id





        DatastoreActivity --> "1" DatastoreActivityActivityIdEnum : activity_id
        click DatastoreActivityActivityIdEnum href "../DatastoreActivityActivityIdEnum/"



      DatastoreActivity : activity_name

      DatastoreActivity : actor





        DatastoreActivity --> "1" Actor : actor
        click Actor href "../Actor/"



      DatastoreActivity : ai_model





        DatastoreActivity --> "0..1 _recommended_" AiModel : ai_model
        click AiModel href "../AiModel/"



      DatastoreActivity : api





        DatastoreActivity --> "0..1" Api : api
        click Api href "../Api/"



      DatastoreActivity : attacks





        DatastoreActivity --> "*" Attack : attacks
        click Attack href "../Attack/"



      DatastoreActivity : authorizations





        DatastoreActivity --> "*" Authorization : authorizations
        click Authorization href "../Authorization/"



      DatastoreActivity : category_name

      DatastoreActivity : category_uid





        DatastoreActivity --> "1" BaseEventCategoryUidEnum : category_uid
        click BaseEventCategoryUidEnum href "../BaseEventCategoryUidEnum/"



      DatastoreActivity : class_name

      DatastoreActivity : class_uid





        DatastoreActivity --> "1" BaseEventClassUidEnum : class_uid
        click BaseEventClassUidEnum href "../BaseEventClassUidEnum/"



      DatastoreActivity : cloud





        DatastoreActivity --> "1" Cloud : cloud
        click Cloud href "../Cloud/"



      DatastoreActivity : confidence

      DatastoreActivity : confidence_id





        DatastoreActivity --> "0..1 _recommended_" ConfidenceIdEnum : confidence_id
        click ConfidenceIdEnum href "../ConfidenceIdEnum/"



      DatastoreActivity : confidence_score

      DatastoreActivity : count

      DatastoreActivity : database





        DatastoreActivity --> "0..1 _recommended_" Database : database
        click Database href "../Database/"



      DatastoreActivity : databucket





        DatastoreActivity --> "0..1 _recommended_" Databucket : databucket
        click Databucket href "../Databucket/"



      DatastoreActivity : device





        DatastoreActivity --> "0..1 _recommended_" Device : device
        click Device href "../Device/"



      DatastoreActivity : disposition

      DatastoreActivity : disposition_id





        DatastoreActivity --> "0..1 _recommended_" DispositionIdEnum : disposition_id
        click DispositionIdEnum href "../DispositionIdEnum/"



      DatastoreActivity : dst_endpoint





        DatastoreActivity --> "0..1 _recommended_" NetworkEndpoint : dst_endpoint
        click NetworkEndpoint href "../NetworkEndpoint/"



      DatastoreActivity : duration

      DatastoreActivity : end_time

      DatastoreActivity : enrichments





        DatastoreActivity --> "*" Enrichment : enrichments
        click Enrichment href "../Enrichment/"



      DatastoreActivity : firewall_rule





        DatastoreActivity --> "0..1" FirewallRule : firewall_rule
        click FirewallRule href "../FirewallRule/"



      DatastoreActivity : http_request





        DatastoreActivity --> "0..1 _recommended_" HttpRequest : http_request
        click HttpRequest href "../HttpRequest/"



      DatastoreActivity : http_response





        DatastoreActivity --> "0..1 _recommended_" HttpResponse : http_response
        click HttpResponse href "../HttpResponse/"



      DatastoreActivity : is_alert

      DatastoreActivity : malware





        DatastoreActivity --> "*" Malware : malware
        click Malware href "../Malware/"



      DatastoreActivity : malware_scan_info





        DatastoreActivity --> "0..1" MalwareScanInfo : malware_scan_info
        click MalwareScanInfo href "../MalwareScanInfo/"



      DatastoreActivity : message

      DatastoreActivity : message_context





        DatastoreActivity --> "0..1" MessageContext : message_context
        click MessageContext href "../MessageContext/"



      DatastoreActivity : metadata





        DatastoreActivity --> "1" Metadata : metadata
        click Metadata href "../Metadata/"



      DatastoreActivity : observables





        DatastoreActivity --> "* _recommended_" Observable : observables
        click Observable href "../Observable/"



      DatastoreActivity : osint





        DatastoreActivity --> "1..*" Osint : osint
        click Osint href "../Osint/"



      DatastoreActivity : policy





        DatastoreActivity --> "0..1" Policy : policy
        click Policy href "../Policy/"



      DatastoreActivity : query_info





        DatastoreActivity --> "0..1 _recommended_" QueryInfo : query_info
        click QueryInfo href "../QueryInfo/"



      DatastoreActivity : raw_data

      DatastoreActivity : raw_data_hash





        DatastoreActivity --> "0..1" Fingerprint : raw_data_hash
        click Fingerprint href "../Fingerprint/"



      DatastoreActivity : raw_data_size

      DatastoreActivity : risk_details

      DatastoreActivity : risk_level

      DatastoreActivity : risk_level_id





        DatastoreActivity --> "0..1" RiskLevelIdEnum : risk_level_id
        click RiskLevelIdEnum href "../RiskLevelIdEnum/"



      DatastoreActivity : risk_score

      DatastoreActivity : severity

      DatastoreActivity : severity_id





        DatastoreActivity --> "1" SeverityIdEnum : severity_id
        click SeverityIdEnum href "../SeverityIdEnum/"



      DatastoreActivity : src_endpoint





        DatastoreActivity --> "1" NetworkEndpoint : src_endpoint
        click NetworkEndpoint href "../NetworkEndpoint/"



      DatastoreActivity : start_time

      DatastoreActivity : status

      DatastoreActivity : status_code

      DatastoreActivity : status_detail

      DatastoreActivity : status_id





        DatastoreActivity --> "0..1 _recommended_" StatusIdEnum : status_id
        click StatusIdEnum href "../StatusIdEnum/"



      DatastoreActivity : table





        DatastoreActivity --> "0..1 _recommended_" Table : table
        click Table href "../Table/"



      DatastoreActivity : time

      DatastoreActivity : timezone_offset

      DatastoreActivity : type

      DatastoreActivity : type_id





        DatastoreActivity --> "0..1 _recommended_" DatastoreActivityTypeIdEnum : type_id
        click DatastoreActivityTypeIdEnum href "../DatastoreActivityTypeIdEnum/"



      DatastoreActivity : type_name

      DatastoreActivity : type_uid

      DatastoreActivity : unmapped





        DatastoreActivity --> "0..1" Object : unmapped
        click Object href "../Object/"



Inheritance

Slots

Name Cardinality and Range Description Inheritance
activity_id 1
DatastoreActivityActivityIdEnum
The normalized identifier of the activity that triggered the event direct
actor 1
Actor
The actor object describes details about the user/role/process that was the direct
database 0..1 recommended
Database
The database object is used for databases which are typically datastore direct
databucket 0..1 recommended
Databucket
The data bucket object is a basic container that holds data, typically direct
dst_endpoint 0..1 recommended
NetworkEndpoint
Details about the endpoint hosting the datastore application or service direct
http_request 0..1 recommended
HttpRequest
Details about the underlying http request direct
http_response 0..1 recommended
HttpResponse
Details about the underlying http response direct
query_info 0..1 recommended
QueryInfo
The query info object holds information related to data access within a direct
src_endpoint 1
NetworkEndpoint
Details about the source of the activity direct
table 0..1 recommended
Table
The table object represents a table within a structured relational database o... direct
type 0..1
String
The datastore resource type (e direct
type_id 0..1 recommended
DatastoreActivityTypeIdEnum
The normalized datastore resource type identifier direct
ai_model 0..1 recommended
AiModel
The AI Model object describes the characteristics of an AI/ML model AiOperationProfile
message_context 0..1
MessageContext
Communication context for AI system interactions including protocols, roles, AiOperationProfile
activity_name 0..1
String
The event activity name, as defined by the activity_id BaseEvent
category_name 0..1
String
The event category name, as defined by category_uid value BaseEvent
category_uid 1
BaseEventCategoryUidEnum
The category unique identifier of the event BaseEvent
class_name 0..1
String
The event class name, as defined by class_uid value BaseEvent
class_uid 1
BaseEventClassUidEnum
The unique identifier of a class BaseEvent
count 0..1
Integer
The number of times that events in the same logical group occurred during the BaseEvent
duration 0..1
Integer
The event duration or aggregate time, the amount of time the event covers fro... BaseEvent
end_time 0..1
TimestampT
The end time of a time period, or the time of the most recent event included ... BaseEvent
enrichments *
Enrichment
The additional information from an external data source, which is associated BaseEvent
message 0..1 recommended
String
The description of the event/finding, as defined by the source BaseEvent
metadata 1
Metadata
The metadata associated with the event or a finding BaseEvent
observables * recommended
Observable
The observables associated with the event or a finding BaseEvent
raw_data 0..1
String
The raw event/finding data as received from the source BaseEvent
raw_data_hash 0..1
Fingerprint
The hash, which describes the content of the raw_data field BaseEvent
raw_data_size 0..1
Integer
The size of the raw data which was transformed into an OCSF event, in bytes BaseEvent
severity 0..1
String
The event/finding severity, normalized to the caption of the BaseEvent
severity_id 1
SeverityIdEnum

The normalized identifier of the event/finding severity

BaseEvent
start_time 0..1
TimestampT
The start time of a time period, or the time of the least recent event includ... BaseEvent
status 0..1 recommended
String
The event status, normalized to the caption of the status_id value BaseEvent
status_code 0..1 recommended
String
The event status code, as reported by the event source BaseEvent
status_detail 0..1 recommended
String
The status detail contains additional information about the event/finding BaseEvent
status_id 0..1 recommended
StatusIdEnum
The normalized identifier of the event status BaseEvent
time 1
TimestampT
The normalized event occurrence time or the finding creation time BaseEvent
timezone_offset 0..1 recommended
Integer
The number of minutes that the reported event time is ahead or BaseEvent
type_name 0..1
String
The event/finding type name, as defined by the type_uid BaseEvent
type_uid 1
Integer
The event/finding type ID BaseEvent
unmapped 0..1
Object
The attributes that are not mapped to the event schema BaseEvent
api 0..1
Api
Describes details about a typical API (Application Programming Interface) cal... CloudProfile
cloud 1
Cloud
Describes details about the Cloud environment where the event or finding was CloudProfile
device 0..1 recommended
Device
An addressable device, computer system or host HostProfile
osint 1..*
Osint
The OSINT (Open Source Intelligence) object contains details related to an OsintProfile
action 0..1
String
The normalized caption of action_id SecurityControlProfile
action_id 0..1 recommended
ActionIdEnum
The action taken by a control or other policy-based system leading to an SecurityControlProfile
attacks *
Attack
An array of MITRE ATT&CK® objects describing identified tactics, techniques & SecurityControlProfile
authorizations *
Authorization
Provides details about an authorization, such as authorization outcome, and a... SecurityControlProfile
confidence 0..1
String
The confidence, normalized to the caption of the confidence_id value SecurityControlProfile
confidence_id 0..1 recommended
ConfidenceIdEnum
The normalized confidence refers to the accuracy of the rule that created the SecurityControlProfile
confidence_score 0..1
Integer
The confidence score as reported by the event source SecurityControlProfile
disposition 0..1
String
The disposition name, normalized to the caption of the disposition_id value SecurityControlProfile
disposition_id 0..1 recommended
DispositionIdEnum
Describes the outcome or action taken by a security control, such as access SecurityControlProfile
firewall_rule 0..1
FirewallRule
The firewall rule that pertains to the control that triggered the event, if SecurityControlProfile
is_alert 0..1 recommended
Boolean
Indicates that the event is considered to be an alertable signal SecurityControlProfile
malware *
Malware
A list of Malware objects, describing details about the identified malware SecurityControlProfile
malware_scan_info 0..1
MalwareScanInfo
Describes details about the scan job that identified malware on the target SecurityControlProfile
policy 0..1
Policy
The policy that pertains to the control that triggered the event, if SecurityControlProfile
risk_details 0..1
String
Describes the risk associated with the finding SecurityControlProfile
risk_level 0..1
String
The risk level, normalized to the caption of the risk_level_id value SecurityControlProfile
risk_level_id 0..1
RiskLevelIdEnum
The normalized risk level id SecurityControlProfile
risk_score 0..1
Integer
The risk score as reported by the event source SecurityControlProfile

Rules

Rule Applied Preconditions Postconditions Elseconditions
any_of [{'slot_conditions': {'database': {'required': True}}}, {'slot_conditions': {'databucket': {'required': True}}}, {'slot_conditions': {'table': {'required': True}}}]

In Subsets

Aliases

  • Datastore Activity

Identifier and Mapping Information

Annotations

property value
ocsf_constraints {"at_least_one": ["database", "databucket", "table"]}
ocsf_event_uid 5

Schema Source

Mappings

Mapping Type Mapped Value
self ocsf:DatastoreActivity
native ocsf:DatastoreActivity

LinkML Source

Direct

name: DatastoreActivity
annotations:
  ocsf_constraints:
    tag: ocsf_constraints
    value: '{"at_least_one": ["database", "databucket", "table"]}'
  ocsf_event_uid:
    tag: ocsf_event_uid
    value: 5
description: 'Datastore events describe general activities (Read, Update, Query, Delete,

  etc.) which affect datastores or data within those datastores, e.g. (AWS RDS,

  AWS S3).'
in_subset:
- application_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Datastore Activity
is_a: ApplicationEvent
mixins:
- AiOperationProfile
slots:
- activity_id
- actor
- database
- databucket
- dst_endpoint
- http_request
- http_response
- query_info
- src_endpoint
- table
- type
- type_id
slot_usage:
  activity_id:
    name: activity_id
    range: DatastoreActivityActivityIdEnum
  actor:
    name: actor
    annotations:
      group:
        tag: group
        value: primary
    required: true
  database:
    name: database
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  databucket:
    name: databucket
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  dst_endpoint:
    name: dst_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the endpoint hosting the datastore application or service.
    recommended: true
  http_request:
    name: http_request
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the underlying http request.
    recommended: true
  http_response:
    name: http_response
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the underlying http response.
    recommended: true
  query_info:
    name: query_info
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  src_endpoint:
    name: src_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the source of the activity.
    required: true
  table:
    name: table
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  type:
    name: type
    description: The datastore resource type (e.g. database, datastore, or table).
  type_id:
    name: type_id
    description: The normalized datastore resource type identifier.
    range: DatastoreActivityTypeIdEnum
    recommended: true
rules:
- postconditions:
    any_of:
    - slot_conditions:
        database:
          name: database
          required: true
    - slot_conditions:
        databucket:
          name: databucket
          required: true
    - slot_conditions:
        table:
          name: table
          required: true
  description: 'OCSF at_least_one: at least one of [''database'', ''databucket'',
    ''table''] must be

    set.'

Induced

name: DatastoreActivity
annotations:
  ocsf_constraints:
    tag: ocsf_constraints
    value: '{"at_least_one": ["database", "databucket", "table"]}'
  ocsf_event_uid:
    tag: ocsf_event_uid
    value: 5
description: 'Datastore events describe general activities (Read, Update, Query, Delete,

  etc.) which affect datastores or data within those datastores, e.g. (AWS RDS,

  AWS S3).'
in_subset:
- application_subset
from_schema: https://w3id.org/lmodel/ocsf
aliases:
- Datastore Activity
is_a: ApplicationEvent
mixins:
- AiOperationProfile
slot_usage:
  activity_id:
    name: activity_id
    range: DatastoreActivityActivityIdEnum
  actor:
    name: actor
    annotations:
      group:
        tag: group
        value: primary
    required: true
  database:
    name: database
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  databucket:
    name: databucket
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  dst_endpoint:
    name: dst_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the endpoint hosting the datastore application or service.
    recommended: true
  http_request:
    name: http_request
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the underlying http request.
    recommended: true
  http_response:
    name: http_response
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the underlying http response.
    recommended: true
  query_info:
    name: query_info
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  src_endpoint:
    name: src_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the source of the activity.
    required: true
  table:
    name: table
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  type:
    name: type
    description: The datastore resource type (e.g. database, datastore, or table).
  type_id:
    name: type_id
    description: The normalized datastore resource type identifier.
    range: DatastoreActivityTypeIdEnum
    recommended: true
attributes:
  activity_id:
    name: activity_id
    annotations:
      group:
        tag: group
        value: classification
    description: The normalized identifier of the activity that triggered the event.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Activity ID
    rank: 1000
    alias: activity_id
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    - ApiActivity
    - ApplicationError
    - ApplicationLifecycle
    - DatastoreActivity
    - FileHosting
    - ScanActivity
    - WebResourceAccessActivity
    - WebResourcesActivity
    - DiscoveryEvent
    - DiscoveryResult
    - DataSecurityFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    - AccountChange
    - Authentication
    - AuthorizeSession
    - EntityManagement
    - GroupManagement
    - UserAccess
    - DhcpActivity
    - DnsActivity
    - EmailActivity
    - EmailFileActivity
    - EmailUrlActivity
    - FtpActivity
    - HttpActivity
    - NetworkActivity
    - NetworkFileActivity
    - NtpActivity
    - RdpActivity
    - SmbActivity
    - SshActivity
    - TunnelActivity
    - RemediationActivity
    - EventLogActvity
    - FileActivity
    - KernelActivity
    - KernelExtensionActivity
    - MemoryActivity
    - ModuleActivity
    - PeripheralActivity
    - ProcessActivity
    - ScheduledJobActivity
    - ScriptActivity
    - AirborneBroadcastActivity
    - DroneFlightsActivity
    - RegistryKeyActivity
    - RegistryValueActivity
    - WindowsResourceActivity
    - WindowsServiceActivity
    range: DatastoreActivityActivityIdEnum
    required: true
  actor:
    name: actor
    annotations:
      group:
        tag: group
        value: primary
    description: 'The actor object describes details about the user/role/process that
      was the

      source of the activity. Note that this is not the threat actor of a campaign

      but may be part of a campaign.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Actor
    rank: 1000
    alias: actor
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - HostProfile
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - ConfigState
    - DeviceConfigStateChange
    - InventoryInfo
    - OsintInventoryInfo
    - SoftwareInfo
    - UserInventory
    - DataSecurityFinding
    - IamEvent
    - NetworkFileActivity
    - SystemEvent
    - EventLogActvity
    - FileActivity
    - KernelExtensionActivity
    - ModuleActivity
    - ProcessActivity
    - ScheduledJobActivity
    - RegistryKeyActivity
    - RegistryValueActivity
    range: Actor
    required: true
  database:
    name: database
    annotations:
      group:
        tag: group
        value: primary
    description: 'The database object is used for databases which are typically datastore

      services that contain an organized collection of structured and unstructured

      data or a types of data.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Database
    rank: 1000
    alias: database
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - DatastoreActivity
    - CloudResourcesInventoryInfo
    - DataSecurityFinding
    range: Database
    recommended: true
  databucket:
    name: databucket
    annotations:
      group:
        tag: group
        value: primary
    description: 'The data bucket object is a basic container that holds data, typically

      organized through the use of data partitions.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Databucket
    rank: 1000
    alias: databucket
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - DatastoreActivity
    - CloudResourcesInventoryInfo
    - DataSecurityFinding
    range: Databucket
    recommended: true
  dst_endpoint:
    name: dst_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the endpoint hosting the datastore application or service.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Destination Endpoint
    rank: 1000
    alias: dst_endpoint
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - LoadBalancer
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourcesActivity
    - DataSecurityFinding
    - Authentication
    - AuthorizeSession
    - NetworkEvent
    - DhcpActivity
    - DnsActivity
    - EmailActivity
    - NetworkActivity
    - NetworkFileActivity
    - TunnelActivity
    - EventLogActvity
    - UnmannedSystemsEvent
    - AirborneBroadcastActivity
    range: NetworkEndpoint
    recommended: true
  http_request:
    name: http_request
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the underlying http request.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - HTTP Request
    rank: 1000
    alias: http_request
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourceAccessActivity
    - WebResourcesActivity
    - IamEvent
    - HttpActivity
    range: HttpRequest
    recommended: true
  http_response:
    name: http_response
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the underlying http response.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - HTTP Response
    rank: 1000
    alias: http_response
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourceAccessActivity
    - WebResourcesActivity
    - IamEvent
    - HttpActivity
    range: HttpResponse
    recommended: true
  query_info:
    name: query_info
    annotations:
      group:
        tag: group
        value: primary
    description: 'The query info object holds information related to data access within
      a

      datastore. To access, manipulate, delete, or retrieve data from a datastore,
      a

      database query must be written using a specific syntax.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Query Info
    rank: 1000
    alias: query_info
    owner: DatastoreActivity
    domain_of:
    - DatastoreActivity
    - DiscoveryResult
    range: QueryInfo
    recommended: true
  src_endpoint:
    name: src_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the source of the activity.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Source Endpoint
    rank: 1000
    alias: src_endpoint
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourceAccessActivity
    - WebResourcesActivity
    - DataSecurityFinding
    - IamEvent
    - NetworkEvent
    - DhcpActivity
    - EmailActivity
    - NetworkActivity
    - NetworkFileActivity
    - TunnelActivity
    - EventLogActvity
    - UnmannedSystemsEvent
    - AirborneBroadcastActivity
    - DroneFlightsActivity
    range: NetworkEndpoint
    required: true
  table:
    name: table
    annotations:
      group:
        tag: group
        value: primary
    description: 'The table object represents a table within a structured relational
      database or

      datastore, which contains columns and rows of data that are able to be create,

      updated, deleted and queried.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Table
    rank: 1000
    alias: table
    owner: DatastoreActivity
    domain_of:
    - DatastoreActivity
    - CloudResourcesInventoryInfo
    - DataSecurityFinding
    range: Table
    recommended: true
  type:
    name: type
    description: The datastore resource type (e.g. database, datastore, or table).
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type
    rank: 1000
    alias: type
    owner: DatastoreActivity
    domain_of:
    - AnalysisTarget
    - Observable
    - Os
    - Osint
    - Package
    - PrivilegeInfo
    - ProgrammaticCredential
    - RelatedEvent
    - San
    - Sbom
    - Script
    - SoftwareComponent
    - StartupItem
    - ThreatActor
    - Ticket
    - Timespan
    - TlsExtension
    - Token
    - Dns
    - Resource
    - Account
    - Agent
    - Analytic
    - ApplicationObject
    - AuthenticationToken
    - ClassifierDetails
    - Cve
    - Database
    - Databucket
    - DiscoveryDetails
    - DnsAnswer
    - DomainContact
    - EncryptionDetails
    - Endpoint
    - Enrichment
    - File
    - Graph
    - Group
    - Ja4Fingerprint
    - Kernel
    - ManagedEntity
    - Metadata
    - Module
    - NetworkEndpoint
    - NetworkInterface
    - Node
    - PeripheralDevice
    - Policy
    - Rule
    - Scan
    - Trait
    - UnmannedAerialSystem
    - UnmannedSystemOperatingArea
    - User
    - WebResource
    - Device
    - DatastoreActivity
    - FtpActivity
    - RegValue
    - WinResource
    range: string
  type_id:
    name: type_id
    annotations:
      sibling:
        tag: sibling
        value: type
    description: The normalized datastore resource type identifier.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type ID
    rank: 1000
    alias: type_id
    owner: DatastoreActivity
    domain_of:
    - Observable
    - Os
    - Osint
    - Package
    - PrivilegeInfo
    - Sbom
    - Script
    - SoftwareComponent
    - StartupItem
    - ThreatActor
    - Ticket
    - Timespan
    - TlsExtension
    - Token
    - Account
    - Agent
    - Analytic
    - AuthenticationToken
    - Database
    - Databucket
    - DomainContact
    - Endpoint
    - File
    - Ja4Fingerprint
    - Kernel
    - ManagedEntity
    - NetworkEndpoint
    - NetworkInterface
    - PeripheralDevice
    - Scan
    - UnmannedAerialSystem
    - UnmannedSystemOperatingArea
    - User
    - Device
    - DatastoreActivity
    - RegValue
    - WinResource
    range: DatastoreActivityTypeIdEnum
    recommended: true
  ai_model:
    name: ai_model
    annotations:
      group:
        tag: group
        value: context
    description: 'The AI Model object describes the characteristics of an AI/ML model.
      Examples

      include language models like GPT-4, embedding models like

      text-embedding-ada-002, and computer vision models like CLIP.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - AI Model
    rank: 1000
    alias: ai_model
    owner: DatastoreActivity
    domain_of:
    - AiOperationProfile
    range: AiModel
    recommended: true
  message_context:
    name: message_context
    annotations:
      group:
        tag: group
        value: context
    description: 'Communication context for AI system interactions including protocols,
      roles,

      clients, and session information for MCP and other AI communication systems.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Message Context
    rank: 1000
    alias: message_context
    owner: DatastoreActivity
    domain_of:
    - AiOperationProfile
    range: MessageContext
  activity_name:
    name: activity_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event activity name, as defined by the activity_id.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Activity
    rank: 1000
    alias: activity_name
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    - DataSecurityFinding
    - Finding
    - IncidentFinding
    range: string
  category_name:
    name: category_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event category name, as defined by category_uid value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Category
    rank: 1000
    alias: category_name
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: string
  category_uid:
    name: category_uid
    annotations:
      group:
        tag: group
        value: classification
    description: The category unique identifier of the event.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Category ID
    rank: 1000
    alias: category_uid
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: BaseEventCategoryUidEnum
    required: true
  class_name:
    name: class_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event class name, as defined by class_uid value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Class
    rank: 1000
    alias: class_name
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: string
  class_uid:
    name: class_uid
    annotations:
      group:
        tag: group
        value: classification
    description: 'The unique identifier of a class. A class describes the attributes
      available in

      an event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Class ID
    rank: 1000
    alias: class_uid
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: BaseEventClassUidEnum
    required: true
  count:
    name: count
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The number of times that events in the same logical group occurred
      during the

      event <strong>Start Time</strong> to <strong>End Time</strong> period.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Count
    rank: 1000
    alias: count
    owner: DatastoreActivity
    domain_of:
    - Observation
    - RelatedEvent
    - Session
    - DiscoveryDetails
    - UnmannedSystemOperatingArea
    - BaseEvent
    range: integer
  duration:
    name: duration
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The event duration or aggregate time, the amount of time the event
      covers from

      <code>start_time</code> to <code>end_time</code> in milliseconds.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Duration Milliseconds
    rank: 1000
    alias: duration
    owner: DatastoreActivity
    domain_of:
    - Span
    - Timespan
    - Trace
    - FirewallRule
    - BaseEvent
    - ScanActivity
    range: integer
  end_time:
    name: end_time
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The end time of a time period, or the time of the most recent event
      included in

      the aggregate event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - End Time
    rank: 1000
    alias: end_time
    owner: DatastoreActivity
    domain_of:
    - Span
    - Timespan
    - Trace
    - NetworkTraffic
    - UnmannedSystemOperatingArea
    - MalwareScanInfo
    - BaseEvent
    - ScanActivity
    - Finding
    - IncidentFinding
    range: TimestampT
  enrichments:
    name: enrichments
    annotations:
      group:
        tag: group
        value: context
    description: 'The additional information from an external data source, which is
      associated

      with the event or a finding. For example add location information for the IP

      address in the DNS answers:</p><code>[{"name": "answers.ip", "value":

      "92.24.47.250", "type": "location", "data": {"city": "Socotra", "continent":

      "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc":

      "Yemen"}}]</code>'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Enrichments
    rank: 1000
    alias: enrichments
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: Enrichment
    multivalued: true
  message:
    name: message
    annotations:
      group:
        tag: group
        value: primary
    description: The description of the event/finding, as defined by the source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Message
    rank: 1000
    alias: message
    owner: DatastoreActivity
    domain_of:
    - Response
    - Span
    - HttpResponse
    - LoadBalancer
    - BaseEvent
    - ApplicationError
    range: string
    recommended: true
  metadata:
    name: metadata
    annotations:
      group:
        tag: group
        value: context
    description: The metadata associated with the event or a finding.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Metadata
    rank: 1000
    alias: metadata
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: Metadata
    required: true
  observables:
    name: observables
    annotations:
      group:
        tag: group
        value: primary
    description: The observables associated with the event or a finding.
    notes:
    - 'OCSF Observables FAQ 

      https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md'
    from_schema: https://w3id.org/lmodel/ocsf
    see_also:
    - https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md
    aliases:
    - Observables
    rank: 1000
    alias: observables
    owner: DatastoreActivity
    domain_of:
    - RelatedEvent
    - BaseEvent
    range: Observable
    recommended: true
    multivalued: true
  raw_data:
    name: raw_data
    annotations:
      group:
        tag: group
        value: context
    description: The raw event/finding data as received from the source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data
    rank: 1000
    alias: raw_data
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: string
  raw_data_hash:
    name: raw_data_hash
    annotations:
      group:
        tag: group
        value: context
    description: The hash, which describes the content of the raw_data field.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data Hash
    rank: 1000
    alias: raw_data_hash
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: Fingerprint
  raw_data_size:
    name: raw_data_size
    annotations:
      group:
        tag: group
        value: context
    description: The size of the raw data which was transformed into an OCSF event,
      in bytes.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data Size
    rank: 1000
    alias: raw_data_size
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: integer
  severity:
    name: severity
    annotations:
      group:
        tag: group
        value: classification
    description: 'The event/finding severity, normalized to the caption of the

      <code>severity_id</code> value. In the case of ''Other'', it is defined by the

      source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Severity
    rank: 1000
    alias: severity
    owner: DatastoreActivity
    domain_of:
    - Osint
    - RelatedEvent
    - VendorAttributes
    - Vulnerability
    - Check
    - Cvss
    - KbArticle
    - Malware
    - BaseEvent
    range: string
  severity_id:
    name: severity_id
    annotations:
      group:
        tag: group
        value: classification
    description: '<p>The normalized identifier of the event/finding severity.</p>The
      normalized

      severity is a measurement the effort and expense required to manage and resolve

      an event or incident. Smaller numerical values represent lower impact events,

      and larger numerical values represent higher impact events.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Severity ID
    rank: 1000
    alias: severity_id
    owner: DatastoreActivity
    domain_of:
    - Osint
    - RelatedEvent
    - VendorAttributes
    - Check
    - Malware
    - BaseEvent
    range: SeverityIdEnum
    required: true
  start_time:
    name: start_time
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The start time of a time period, or the time of the least recent
      event included

      in the aggregate event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Start Time
    rank: 1000
    alias: start_time
    owner: DatastoreActivity
    domain_of:
    - Span
    - Timespan
    - Trace
    - NetworkTraffic
    - UnmannedSystemOperatingArea
    - MalwareScanInfo
    - BaseEvent
    - ScanActivity
    - Finding
    - IncidentFinding
    range: TimestampT
  status:
    name: status
    annotations:
      group:
        tag: group
        value: primary
    description: 'The event status, normalized to the caption of the status_id value.
      In the case

      of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status
    rank: 1000
    alias: status
    owner: DatastoreActivity
    domain_of:
    - RelatedEvent
    - Ticket
    - Whois
    - AdditionalRestriction
    - Check
    - Compliance
    - DataClassification
    - HttpResponse
    - BaseEvent
    - Finding
    - IncidentFinding
    - DroneFlightsActivity
    range: string
    recommended: true
  status_code:
    name: status_code
    annotations:
      group:
        tag: group
        value: primary
    description: 'The event status code, as reported by the event source.<br /><br
      />For example,

      in a Windows Failed Authentication event, this would be the value of ''Failure

      Code'', e.g. 0x18.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status Code
    rank: 1000
    alias: status_code
    owner: DatastoreActivity
    domain_of:
    - Span
    - Compliance
    - BaseEvent
    - EventLogActvity
    range: string
    recommended: true
  status_detail:
    name: status_detail
    annotations:
      group:
        tag: group
        value: primary
    description: 'The status detail contains additional information about the event/finding

      outcome.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status Detail
    rank: 1000
    alias: status_detail
    owner: DatastoreActivity
    domain_of:
    - Compliance
    - LoadBalancer
    - BaseEvent
    - Authentication
    - EventLogActvity
    range: string
    recommended: true
  status_id:
    name: status_id
    annotations:
      group:
        tag: group
        value: primary
    description: The normalized identifier of the event status.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status ID
    rank: 1000
    alias: status_id
    owner: DatastoreActivity
    domain_of:
    - Ticket
    - AdditionalRestriction
    - Check
    - Compliance
    - DataClassification
    - BaseEvent
    - Finding
    - IncidentFinding
    - RemediationActivity
    - DroneFlightsActivity
    range: StatusIdEnum
    recommended: true
  time:
    name: time
    annotations:
      group:
        tag: group
        value: occurrence
    description: The normalized event occurrence time or the finding creation time.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Event Time
    rank: 1000
    alias: time
    owner: DatastoreActivity
    domain_of:
    - TransformationInfo
    - BaseEvent
    range: TimestampT
    required: true
  timezone_offset:
    name: timezone_offset
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The number of minutes that the reported event <code>time</code>
      is ahead or

      behind UTC, in the range -1,080 to +1,080.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Timezone Offset
    rank: 1000
    alias: timezone_offset
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: integer
    recommended: true
  type_name:
    name: type_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event/finding type name, as defined by the type_uid.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type Name
    rank: 1000
    alias: type_name
    owner: DatastoreActivity
    domain_of:
    - RelatedEvent
    - BaseEvent
    range: string
  type_uid:
    name: type_uid
    annotations:
      group:
        tag: group
        value: classification
    description: 'The event/finding type ID. It identifies the event''s semantics
      and structure.

      The value is calculated by the logging system as: <code>class_uid * 100 +

      activity_id</code>.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type ID
    rank: 1000
    alias: type_uid
    owner: DatastoreActivity
    domain_of:
    - Observable
    - RelatedEvent
    - BaseEvent
    range: integer
    required: true
  unmapped:
    name: unmapped
    annotations:
      group:
        tag: group
        value: context
    description: 'The attributes that are not mapped to the event schema. The names
      and values of

      those attributes are specific to the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Unmapped Data
    rank: 1000
    alias: unmapped
    owner: DatastoreActivity
    domain_of:
    - BaseEvent
    range: Object
  api:
    name: api
    annotations:
      group:
        tag: group
        value: context
    description: Describes details about a typical API (Application Programming Interface)
      call.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - API Details
    rank: 1000
    alias: api
    owner: DatastoreActivity
    domain_of:
    - Evidences
    - CloudProfile
    - ApiActivity
    range: Api
  cloud:
    name: cloud
    annotations:
      group:
        tag: group
        value: primary
    description: 'Describes details about the Cloud environment where the event or
      finding was

      created.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Cloud
    rank: 1000
    alias: cloud
    owner: DatastoreActivity
    domain_of:
    - CloudProfile
    - CloudResourcesInventoryInfo
    range: Cloud
    required: true
  device:
    name: device
    description: An addressable device, computer system or host.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Device
    rank: 1000
    alias: device
    owner: DatastoreActivity
    domain_of:
    - AuthFactor
    - Evidences
    - Logger
    - ManagedEntity
    - HostProfile
    - ConfigState
    - DeviceConfigStateChange
    - EvidenceInfo
    - InventoryInfo
    - PatchState
    - SoftwareInfo
    - DataSecurityFinding
    - Finding
    - RdpActivity
    - TunnelActivity
    - SystemEvent
    - EventLogActvity
    range: Device
    recommended: true
  osint:
    name: osint
    annotations:
      group:
        tag: group
        value: primary
    description: 'The OSINT (Open Source Intelligence) object contains details related
      to an

      indicator such as the indicator itself, related indicators, geolocation,

      registrar information, subdomains, analyst commentary, and other contextual

      information. This information can be used to further enrich a detection or

      finding by providing decisioning support to other analysts and engineers.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - OSINT
    rank: 1000
    alias: osint
    owner: DatastoreActivity
    domain_of:
    - OsintProfile
    - OsintInventoryInfo
    range: Osint
    required: true
    multivalued: true
  action:
    name: action
    description: The normalized caption of <code>action_id</code>.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Action
    rank: 1000
    alias: action
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    range: string
  action_id:
    name: action_id
    annotations:
      sibling:
        tag: sibling
        value: action
    description: 'The action taken by a control or other policy-based system leading
      to an

      outcome or disposition. An unknown action may still correspond to a known

      disposition. Refer to <code>disposition_id</code> for the outcome of the

      action.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Action ID
    rank: 1000
    alias: action_id
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    range: ActionIdEnum
    recommended: true
  attacks:
    name: attacks
    description: 'An array of MITRE ATT&CK® objects describing identified tactics,
      techniques &

      sub-techniques. The objects are compatible with MITRE ATLAS™ tactics,

      techniques & sub-techniques.'
    notes:
    - MITRE ATT&CK® — https://attack.mitre.org
    - MITRE ATLAS — https://atlas.mitre.org/matrices/ATLAS
    from_schema: https://w3id.org/lmodel/ocsf
    see_also:
    - https://attack.mitre.org
    - https://atlas.mitre.org/matrices/ATLAS
    aliases:
    - MITRE ATT&CK® and ATLAS™ Details
    rank: 1000
    alias: attacks
    owner: DatastoreActivity
    domain_of:
    - Osint
    - RelatedEvent
    - FindingInfo
    - SecurityControlProfile
    - IncidentFinding
    - SecurityFinding
    range: Attack
    multivalued: true
  authorizations:
    name: authorizations
    description: 'Provides details about an authorization, such as authorization outcome,
      and any

      associated policies related to the activity/event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Authorization Information
    rank: 1000
    alias: authorizations
    owner: DatastoreActivity
    domain_of:
    - Actor
    - SecurityControlProfile
    range: Authorization
    multivalued: true
  confidence:
    name: confidence
    annotations:
      group:
        tag: group
        value: context
    description: 'The confidence, normalized to the caption of the confidence_id value.
      In the

      case of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence
    rank: 1000
    alias: confidence
    owner: DatastoreActivity
    domain_of:
    - Osint
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: string
  confidence_id:
    name: confidence_id
    annotations:
      group:
        tag: group
        value: context
    description: 'The normalized confidence refers to the accuracy of the rule that
      created the

      finding. A rule with a low confidence means that the finding scope is wide and

      may create finding reports that may not be malicious in nature.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence ID
    rank: 1000
    alias: confidence_id
    owner: DatastoreActivity
    domain_of:
    - Osint
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: ConfidenceIdEnum
    recommended: true
  confidence_score:
    name: confidence_score
    annotations:
      group:
        tag: group
        value: context
    description: The confidence score as reported by the event source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence Score
    rank: 1000
    alias: confidence_score
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: integer
  disposition:
    name: disposition
    description: 'The disposition name, normalized to the caption of the disposition_id
      value. In

      the case of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Disposition
    rank: 1000
    alias: disposition
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    range: string
  disposition_id:
    name: disposition_id
    annotations:
      sibling:
        tag: sibling
        value: disposition
    description: 'Describes the outcome or action taken by a security control, such
      as access

      control checks, malware detections or various types of policy violations.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Disposition ID
    rank: 1000
    alias: disposition_id
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    range: DispositionIdEnum
    recommended: true
  firewall_rule:
    name: firewall_rule
    description: 'The firewall rule that pertains to the control that triggered the
      event, if

      applicable.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Firewall Rule
    rank: 1000
    alias: firewall_rule
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    range: FirewallRule
  is_alert:
    name: is_alert
    description: 'Indicates that the event is considered to be an alertable signal.
      Should be set

      to <code>true</code> if <code>disposition_id = Alert</code> among other

      dispositions, and/or <code>risk_level_id</code> or <code>severity_id</code>
      of

      the event is elevated. Not all control events will be alertable, for example
      if

      <code>disposition_id = Exonerated</code> or <code>disposition_id =

      Allowed</code>.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Alert
    rank: 1000
    alias: is_alert
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    range: boolean
    recommended: true
  malware:
    name: malware
    description: A list of Malware objects, describing details about the identified
      malware.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Malware
    rank: 1000
    alias: malware
    owner: DatastoreActivity
    domain_of:
    - Osint
    - SecurityControlProfile
    - DetectionFinding
    - SecurityFinding
    range: Malware
    multivalued: true
  malware_scan_info:
    name: malware_scan_info
    description: 'Describes details about the scan job that identified malware on
      the target

      system.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Malware Scan Info
    rank: 1000
    alias: malware_scan_info
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    - DetectionFinding
    range: MalwareScanInfo
  policy:
    name: policy
    description: 'The policy that pertains to the control that triggered the event,
      if

      applicable. For example the name of an anti-malware policy or an access control

      policy.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Policy
    rank: 1000
    alias: policy
    owner: DatastoreActivity
    domain_of:
    - PermissionAnalysisResult
    - AdditionalRestriction
    - Assessment
    - Authorization
    - DataClassification
    - DataSecurity
    - ManagedEntity
    - SecurityControlProfile
    - ScanActivity
    - AccountChange
    range: Policy
  risk_details:
    name: risk_details
    annotations:
      group:
        tag: group
        value: context
    description: Describes the risk associated with the finding.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Details
    rank: 1000
    alias: risk_details
    owner: DatastoreActivity
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    range: string
  risk_level:
    name: risk_level
    annotations:
      group:
        tag: group
        value: context
    description: The risk level, normalized to the caption of the risk_level_id value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Level
    rank: 1000
    alias: risk_level
    owner: DatastoreActivity
    domain_of:
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: string
  risk_level_id:
    name: risk_level_id
    annotations:
      group:
        tag: group
        value: context
    description: The normalized risk level id.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Level ID
    rank: 1000
    alias: risk_level_id
    owner: DatastoreActivity
    domain_of:
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: RiskLevelIdEnum
  risk_score:
    name: risk_score
    annotations:
      group:
        tag: group
        value: context
    description: The risk score as reported by the event source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Score
    rank: 1000
    alias: risk_score
    owner: DatastoreActivity
    domain_of:
    - Osint
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: integer
rules:
- postconditions:
    any_of:
    - slot_conditions:
        database:
          name: database
          required: true
    - slot_conditions:
        databucket:
          name: databucket
          required: true
    - slot_conditions:
        table:
          name: table
          required: true
  description: 'OCSF at_least_one: at least one of [''database'', ''databucket'',
    ''table''] must be

    set.'