Skip to content

Class: Authentication

Authentication events report authentication session activities, including user

attempts to log on or log off, regardless of success, as well as other key

stages within the authentication process. These events are typically generated

by authentication services, such as Kerberos, OIDC, or SAML, and may include

information about the user, the authentication method used, and the status of

the authentication attempt.

URI: ocsf:Authentication

 classDiagram
    class Authentication
    click Authentication href "../Authentication/"
      IamEvent <|-- Authentication
        click IamEvent href "../IamEvent/"

      Authentication : account_switch_type

      Authentication : account_switch_type_id





        Authentication --> "0..1 _recommended_" AccountSwitchTypeIdEnum : account_switch_type_id
        click AccountSwitchTypeIdEnum href "../AccountSwitchTypeIdEnum/"



      Authentication : action

      Authentication : action_id





        Authentication --> "0..1 _recommended_" ActionIdEnum : action_id
        click ActionIdEnum href "../ActionIdEnum/"



      Authentication : activity_id





        Authentication --> "1" AuthenticationActivityIdEnum : activity_id
        click AuthenticationActivityIdEnum href "../AuthenticationActivityIdEnum/"



      Authentication : activity_name

      Authentication : actor





        Authentication --> "0..1 _recommended_" Actor : actor
        click Actor href "../Actor/"



      Authentication : api





        Authentication --> "0..1" Api : api
        click Api href "../Api/"



      Authentication : attacks





        Authentication --> "*" Attack : attacks
        click Attack href "../Attack/"



      Authentication : auth_factors





        Authentication --> "*" AuthFactor : auth_factors
        click AuthFactor href "../AuthFactor/"



      Authentication : auth_protocol

      Authentication : auth_protocol_id





        Authentication --> "0..1 _recommended_" AuthProtocolIdEnum : auth_protocol_id
        click AuthProtocolIdEnum href "../AuthProtocolIdEnum/"



      Authentication : authentication_token





        Authentication --> "0..1" AuthenticationToken : authentication_token
        click AuthenticationToken href "../AuthenticationToken/"



      Authentication : authorizations





        Authentication --> "*" Authorization : authorizations
        click Authorization href "../Authorization/"



      Authentication : category_name

      Authentication : category_uid





        Authentication --> "1" BaseEventCategoryUidEnum : category_uid
        click BaseEventCategoryUidEnum href "../BaseEventCategoryUidEnum/"



      Authentication : certificate





        Authentication --> "0..1 _recommended_" Certificate : certificate
        click Certificate href "../Certificate/"



      Authentication : class_name

      Authentication : class_uid





        Authentication --> "1" BaseEventClassUidEnum : class_uid
        click BaseEventClassUidEnum href "../BaseEventClassUidEnum/"



      Authentication : cloud





        Authentication --> "1" Cloud : cloud
        click Cloud href "../Cloud/"



      Authentication : confidence

      Authentication : confidence_id





        Authentication --> "0..1 _recommended_" ConfidenceIdEnum : confidence_id
        click ConfidenceIdEnum href "../ConfidenceIdEnum/"



      Authentication : confidence_score

      Authentication : count

      Authentication : device





        Authentication --> "0..1 _recommended_" Device : device
        click Device href "../Device/"



      Authentication : disposition

      Authentication : disposition_id





        Authentication --> "0..1 _recommended_" DispositionIdEnum : disposition_id
        click DispositionIdEnum href "../DispositionIdEnum/"



      Authentication : dst_endpoint





        Authentication --> "0..1 _recommended_" NetworkEndpoint : dst_endpoint
        click NetworkEndpoint href "../NetworkEndpoint/"



      Authentication : duration

      Authentication : end_time

      Authentication : enrichments





        Authentication --> "*" Enrichment : enrichments
        click Enrichment href "../Enrichment/"



      Authentication : firewall_rule





        Authentication --> "0..1" FirewallRule : firewall_rule
        click FirewallRule href "../FirewallRule/"



      Authentication : http_request





        Authentication --> "0..1" HttpRequest : http_request
        click HttpRequest href "../HttpRequest/"



      Authentication : http_response





        Authentication --> "0..1" HttpResponse : http_response
        click HttpResponse href "../HttpResponse/"



      Authentication : is_alert

      Authentication : is_cleartext

      Authentication : is_mfa

      Authentication : is_new_logon

      Authentication : is_remote

      Authentication : logon_process





        Authentication --> "0..1" Process : logon_process
        click Process href "../Process/"



      Authentication : logon_type

      Authentication : logon_type_id





        Authentication --> "0..1 _recommended_" LogonTypeIdEnum : logon_type_id
        click LogonTypeIdEnum href "../LogonTypeIdEnum/"



      Authentication : malware





        Authentication --> "*" Malware : malware
        click Malware href "../Malware/"



      Authentication : malware_scan_info





        Authentication --> "0..1" MalwareScanInfo : malware_scan_info
        click MalwareScanInfo href "../MalwareScanInfo/"



      Authentication : message

      Authentication : metadata





        Authentication --> "1" Metadata : metadata
        click Metadata href "../Metadata/"



      Authentication : observables





        Authentication --> "* _recommended_" Observable : observables
        click Observable href "../Observable/"



      Authentication : osint





        Authentication --> "1..*" Osint : osint
        click Osint href "../Osint/"



      Authentication : policy





        Authentication --> "0..1" Policy : policy
        click Policy href "../Policy/"



      Authentication : raw_data

      Authentication : raw_data_hash





        Authentication --> "0..1" Fingerprint : raw_data_hash
        click Fingerprint href "../Fingerprint/"



      Authentication : raw_data_size

      Authentication : risk_details

      Authentication : risk_level

      Authentication : risk_level_id





        Authentication --> "0..1" RiskLevelIdEnum : risk_level_id
        click RiskLevelIdEnum href "../RiskLevelIdEnum/"



      Authentication : risk_score

      Authentication : service





        Authentication --> "0..1 _recommended_" Service : service
        click Service href "../Service/"



      Authentication : session





        Authentication --> "0..1 _recommended_" Session : session
        click Session href "../Session/"



      Authentication : severity

      Authentication : severity_id





        Authentication --> "1" SeverityIdEnum : severity_id
        click SeverityIdEnum href "../SeverityIdEnum/"



      Authentication : src_endpoint





        Authentication --> "0..1 _recommended_" NetworkEndpoint : src_endpoint
        click NetworkEndpoint href "../NetworkEndpoint/"



      Authentication : start_time

      Authentication : status

      Authentication : status_code

      Authentication : status_detail

      Authentication : status_id





        Authentication --> "0..1 _recommended_" StatusIdEnum : status_id
        click StatusIdEnum href "../StatusIdEnum/"



      Authentication : time

      Authentication : timezone_offset

      Authentication : type_name

      Authentication : type_uid

      Authentication : unmapped





        Authentication --> "0..1" Object : unmapped
        click Object href "../Object/"



      Authentication : user





        Authentication --> "1" User : user
        click User href "../User/"



Inheritance

Slots

Name Cardinality and Range Description Inheritance
account_switch_type 0..1 recommended
String
The account switch method, normalized to the caption of the direct
account_switch_type_id 0..1 recommended
AccountSwitchTypeIdEnum
The normalized identifier of the account switch method direct
activity_id 1
AuthenticationActivityIdEnum
The normalized identifier of the activity that triggered the event direct
auth_factors *
AuthFactor
Describes a category of methods used for identity verification in an direct
auth_protocol 0..1 recommended
String
The authentication protocol as defined by the caption of direct
auth_protocol_id 0..1 recommended
AuthProtocolIdEnum
The normalized identifier of the authentication protocol used to create the direct
authentication_token 0..1
AuthenticationToken
The authentication token, ticket, or assertion, e direct
certificate 0..1 recommended
Certificate
The certificate associated with the authentication or pre-authentication direct
dst_endpoint 0..1 recommended
NetworkEndpoint
The endpoint to which the authentication was targeted direct
is_cleartext 0..1
Boolean
Indicates whether the credentials were passed in clear text direct
is_mfa 0..1 recommended
Boolean
Indicates whether Multi Factor Authentication was used during authentication direct
is_new_logon 0..1
Boolean
Indicates logon is from a device not seen before or a first time account logo... direct
is_remote 0..1 recommended
Boolean
The attempted authentication is over a remote connection direct
logon_process 0..1
Process
The trusted process that validated the authentication credentials direct
logon_type 0..1 recommended
String
The logon type, normalized to the caption of the logon_type_id value direct
logon_type_id 0..1 recommended
LogonTypeIdEnum
The normalized logon type identifier direct
service 0..1 recommended
Service
The service or gateway to which the user or process is being authenticated direct
session 0..1 recommended
Session
The authenticated user or service session direct
status_detail 0..1 recommended
String
The details about the authentication request direct
user 1
User
The subject (user/role or account) to authenticate direct
actor 0..1 recommended
Actor
The actor object describes details about the user/role/process that was the HostProfile, IamEvent
http_request 0..1
HttpRequest
Details about the underlying HTTP request IamEvent
http_response 0..1
HttpResponse
Details about the underlying HTTP response IamEvent
src_endpoint 0..1 recommended
NetworkEndpoint
Details about the source of the IAM activity IamEvent
activity_name 0..1
String
The event activity name, as defined by the activity_id BaseEvent
category_name 0..1
String
The event category name, as defined by category_uid value BaseEvent
category_uid 1
BaseEventCategoryUidEnum
The category unique identifier of the event BaseEvent
class_name 0..1
String
The event class name, as defined by class_uid value BaseEvent
class_uid 1
BaseEventClassUidEnum
The unique identifier of a class BaseEvent
count 0..1
Integer
The number of times that events in the same logical group occurred during the BaseEvent
duration 0..1
Integer
The event duration or aggregate time, the amount of time the event covers fro... BaseEvent
end_time 0..1
TimestampT
The end time of a time period, or the time of the most recent event included ... BaseEvent
enrichments *
Enrichment
The additional information from an external data source, which is associated BaseEvent
message 0..1 recommended
String
The description of the event/finding, as defined by the source BaseEvent
metadata 1
Metadata
The metadata associated with the event or a finding BaseEvent
observables * recommended
Observable
The observables associated with the event or a finding BaseEvent
raw_data 0..1
String
The raw event/finding data as received from the source BaseEvent
raw_data_hash 0..1
Fingerprint
The hash, which describes the content of the raw_data field BaseEvent
raw_data_size 0..1
Integer
The size of the raw data which was transformed into an OCSF event, in bytes BaseEvent
severity 0..1
String
The event/finding severity, normalized to the caption of the BaseEvent
severity_id 1
SeverityIdEnum

The normalized identifier of the event/finding severity

BaseEvent
start_time 0..1
TimestampT
The start time of a time period, or the time of the least recent event includ... BaseEvent
status 0..1 recommended
String
The event status, normalized to the caption of the status_id value BaseEvent
status_code 0..1 recommended
String
The event status code, as reported by the event source BaseEvent
status_id 0..1 recommended
StatusIdEnum
The normalized identifier of the event status BaseEvent
time 1
TimestampT
The normalized event occurrence time or the finding creation time BaseEvent
timezone_offset 0..1 recommended
Integer
The number of minutes that the reported event time is ahead or BaseEvent
type_name 0..1
String
The event/finding type name, as defined by the type_uid BaseEvent
type_uid 1
Integer
The event/finding type ID BaseEvent
unmapped 0..1
Object
The attributes that are not mapped to the event schema BaseEvent
api 0..1
Api
Describes details about a typical API (Application Programming Interface) cal... CloudProfile
cloud 1
Cloud
Describes details about the Cloud environment where the event or finding was CloudProfile
device 0..1 recommended
Device
An addressable device, computer system or host HostProfile
osint 1..*
Osint
The OSINT (Open Source Intelligence) object contains details related to an OsintProfile
action 0..1
String
The normalized caption of action_id SecurityControlProfile
action_id 0..1 recommended
ActionIdEnum
The action taken by a control or other policy-based system leading to an SecurityControlProfile
attacks *
Attack
An array of MITRE ATT&CK® objects describing identified tactics, techniques & SecurityControlProfile
authorizations *
Authorization
Provides details about an authorization, such as authorization outcome, and a... SecurityControlProfile
confidence 0..1
String
The confidence, normalized to the caption of the confidence_id value SecurityControlProfile
confidence_id 0..1 recommended
ConfidenceIdEnum
The normalized confidence refers to the accuracy of the rule that created the SecurityControlProfile
confidence_score 0..1
Integer
The confidence score as reported by the event source SecurityControlProfile
disposition 0..1
String
The disposition name, normalized to the caption of the disposition_id value SecurityControlProfile
disposition_id 0..1 recommended
DispositionIdEnum
Describes the outcome or action taken by a security control, such as access SecurityControlProfile
firewall_rule 0..1
FirewallRule
The firewall rule that pertains to the control that triggered the event, if SecurityControlProfile
is_alert 0..1 recommended
Boolean
Indicates that the event is considered to be an alertable signal SecurityControlProfile
malware *
Malware
A list of Malware objects, describing details about the identified malware SecurityControlProfile
malware_scan_info 0..1
MalwareScanInfo
Describes details about the scan job that identified malware on the target SecurityControlProfile
policy 0..1
Policy
The policy that pertains to the control that triggered the event, if SecurityControlProfile
risk_details 0..1
String
Describes the risk associated with the finding SecurityControlProfile
risk_level 0..1
String
The risk level, normalized to the caption of the risk_level_id value SecurityControlProfile
risk_level_id 0..1
RiskLevelIdEnum
The normalized risk level id SecurityControlProfile
risk_score 0..1
Integer
The risk score as reported by the event source SecurityControlProfile

Rules

Rule Applied Preconditions Postconditions Elseconditions
any_of [{'slot_conditions': {'service': {'required': True}}}, {'slot_conditions': {'dst_endpoint': {'required': True}}}]

In Subsets

Aliases

  • Authentication

See Also

Notes

Identifier and Mapping Information

Annotations

property value
ocsf_constraints {"at_least_one": ["service", "dst_endpoint"]}
ocsf_event_uid 2
associations {"actor.user": ["src_endpoint"], "dst_endpoint": ["user"], "src_endpoint":
["actor.user"], "user": ["dst_endpoint"]}

Schema Source

Mappings

Mapping Type Mapped Value
self ocsf:Authentication
native ocsf:Authentication

LinkML Source

Direct

name: Authentication
annotations:
  ocsf_constraints:
    tag: ocsf_constraints
    value: '{"at_least_one": ["service", "dst_endpoint"]}'
  ocsf_event_uid:
    tag: ocsf_event_uid
    value: 2
  associations:
    tag: associations
    value: '{"actor.user": ["src_endpoint"], "dst_endpoint": ["user"], "src_endpoint":

      ["actor.user"], "user": ["dst_endpoint"]}'
description: 'Authentication events report authentication session activities, including
  user

  attempts to log on or log off, regardless of success, as well as other key

  stages within the authentication process. These events are typically generated

  by authentication services, such as Kerberos, OIDC, or SAML, and may include

  information about the user, the authentication method used, and the status of

  the authentication attempt.'
notes:
- 'D3FEND™ Ontology d3f:AuthenticationEvent 

  https://d3fend.mitre.org/event/d3f:AuthenticationEvent'
in_subset:
- iam_subset
from_schema: https://w3id.org/lmodel/ocsf
see_also:
- https://d3fend.mitre.org/event/d3f:AuthenticationEvent
aliases:
- Authentication
is_a: IamEvent
slots:
- account_switch_type
- account_switch_type_id
- activity_id
- auth_factors
- auth_protocol
- auth_protocol_id
- authentication_token
- certificate
- dst_endpoint
- is_cleartext
- is_mfa
- is_new_logon
- is_remote
- logon_process
- logon_type
- logon_type_id
- service
- session
- status_detail
- user
slot_usage:
  account_switch_type:
    name: account_switch_type
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  account_switch_type_id:
    name: account_switch_type_id
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  activity_id:
    name: activity_id
    range: AuthenticationActivityIdEnum
  auth_factors:
    name: auth_factors
    annotations:
      group:
        tag: group
        value: context
    description: 'Describes a category of methods used for identity verification in
      an

      authentication attempt.'
  auth_protocol:
    name: auth_protocol
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  auth_protocol_id:
    name: auth_protocol_id
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  authentication_token:
    name: authentication_token
    annotations:
      group:
        tag: group
        value: context
    description: 'The authentication token, ticket, or assertion, e.g. <code>Kerberos</code>,

      <code>OIDC</code>, <code>SAML</code>.'
  certificate:
    name: certificate
    annotations:
      group:
        tag: group
        value: primary
    description: 'The certificate associated with the authentication or pre-authentication

      (Kerberos).'
    recommended: true
  dst_endpoint:
    name: dst_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: The endpoint to which the authentication was targeted.
    recommended: true
  is_cleartext:
    name: is_cleartext
    annotations:
      group:
        tag: group
        value: context
  is_mfa:
    name: is_mfa
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  is_new_logon:
    name: is_new_logon
    annotations:
      group:
        tag: group
        value: context
  is_remote:
    name: is_remote
    annotations:
      group:
        tag: group
        value: primary
    description: The attempted authentication is over a remote connection.
    recommended: true
  logon_process:
    name: logon_process
    annotations:
      group:
        tag: group
        value: context
  logon_type:
    name: logon_type
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  logon_type_id:
    name: logon_type_id
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  service:
    name: service
    annotations:
      group:
        tag: group
        value: primary
    description: The service or gateway to which the user or process is being authenticated
    recommended: true
  session:
    name: session
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  status_detail:
    name: status_detail
    description: 'The details about the authentication request. For example, possible
      details for

      Windows logon or logoff events

      are:<ul><li>Success</li><ul><li>LOGOFF_USER_INITIATED</li><li>LOGOFF_OTHER</li></ul><li>Failure</li><ul><li>USER_DOES_NOT_EXIST</li><li>INVALID_CREDENTIALS</li><li>ACCOUNT_DISABLED</li><li>ACCOUNT_LOCKED_OUT</li><li>PASSWORD_EXPIRED</li></ul></ul>'
  user:
    name: user
    annotations:
      group:
        tag: group
        value: primary
    description: The subject (user/role or account) to authenticate.
    required: true
rules:
- postconditions:
    any_of:
    - slot_conditions:
        service:
          name: service
          required: true
    - slot_conditions:
        dst_endpoint:
          name: dst_endpoint
          required: true
  description: 'OCSF at_least_one: at least one of [''service'', ''dst_endpoint'']
    must be set.'

Induced

name: Authentication
annotations:
  ocsf_constraints:
    tag: ocsf_constraints
    value: '{"at_least_one": ["service", "dst_endpoint"]}'
  ocsf_event_uid:
    tag: ocsf_event_uid
    value: 2
  associations:
    tag: associations
    value: '{"actor.user": ["src_endpoint"], "dst_endpoint": ["user"], "src_endpoint":

      ["actor.user"], "user": ["dst_endpoint"]}'
description: 'Authentication events report authentication session activities, including
  user

  attempts to log on or log off, regardless of success, as well as other key

  stages within the authentication process. These events are typically generated

  by authentication services, such as Kerberos, OIDC, or SAML, and may include

  information about the user, the authentication method used, and the status of

  the authentication attempt.'
notes:
- 'D3FEND™ Ontology d3f:AuthenticationEvent 

  https://d3fend.mitre.org/event/d3f:AuthenticationEvent'
in_subset:
- iam_subset
from_schema: https://w3id.org/lmodel/ocsf
see_also:
- https://d3fend.mitre.org/event/d3f:AuthenticationEvent
aliases:
- Authentication
is_a: IamEvent
slot_usage:
  account_switch_type:
    name: account_switch_type
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  account_switch_type_id:
    name: account_switch_type_id
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  activity_id:
    name: activity_id
    range: AuthenticationActivityIdEnum
  auth_factors:
    name: auth_factors
    annotations:
      group:
        tag: group
        value: context
    description: 'Describes a category of methods used for identity verification in
      an

      authentication attempt.'
  auth_protocol:
    name: auth_protocol
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  auth_protocol_id:
    name: auth_protocol_id
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  authentication_token:
    name: authentication_token
    annotations:
      group:
        tag: group
        value: context
    description: 'The authentication token, ticket, or assertion, e.g. <code>Kerberos</code>,

      <code>OIDC</code>, <code>SAML</code>.'
  certificate:
    name: certificate
    annotations:
      group:
        tag: group
        value: primary
    description: 'The certificate associated with the authentication or pre-authentication

      (Kerberos).'
    recommended: true
  dst_endpoint:
    name: dst_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: The endpoint to which the authentication was targeted.
    recommended: true
  is_cleartext:
    name: is_cleartext
    annotations:
      group:
        tag: group
        value: context
  is_mfa:
    name: is_mfa
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  is_new_logon:
    name: is_new_logon
    annotations:
      group:
        tag: group
        value: context
  is_remote:
    name: is_remote
    annotations:
      group:
        tag: group
        value: primary
    description: The attempted authentication is over a remote connection.
    recommended: true
  logon_process:
    name: logon_process
    annotations:
      group:
        tag: group
        value: context
  logon_type:
    name: logon_type
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  logon_type_id:
    name: logon_type_id
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  service:
    name: service
    annotations:
      group:
        tag: group
        value: primary
    description: The service or gateway to which the user or process is being authenticated
    recommended: true
  session:
    name: session
    annotations:
      group:
        tag: group
        value: primary
    recommended: true
  status_detail:
    name: status_detail
    description: 'The details about the authentication request. For example, possible
      details for

      Windows logon or logoff events

      are:<ul><li>Success</li><ul><li>LOGOFF_USER_INITIATED</li><li>LOGOFF_OTHER</li></ul><li>Failure</li><ul><li>USER_DOES_NOT_EXIST</li><li>INVALID_CREDENTIALS</li><li>ACCOUNT_DISABLED</li><li>ACCOUNT_LOCKED_OUT</li><li>PASSWORD_EXPIRED</li></ul></ul>'
  user:
    name: user
    annotations:
      group:
        tag: group
        value: primary
    description: The subject (user/role or account) to authenticate.
    required: true
attributes:
  account_switch_type:
    name: account_switch_type
    annotations:
      group:
        tag: group
        value: primary
    description: 'The account switch method, normalized to the caption of the

      account_switch_type_id value. In the case of ''Other'', it is defined by the

      event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Account Switch Type
    rank: 1000
    alias: account_switch_type
    owner: Authentication
    domain_of:
    - Authentication
    range: string
    recommended: true
  account_switch_type_id:
    name: account_switch_type_id
    annotations:
      group:
        tag: group
        value: primary
    description: The normalized identifier of the account switch method.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Account Switch Type ID
    rank: 1000
    alias: account_switch_type_id
    owner: Authentication
    domain_of:
    - Authentication
    range: AccountSwitchTypeIdEnum
    recommended: true
  activity_id:
    name: activity_id
    annotations:
      group:
        tag: group
        value: classification
    description: The normalized identifier of the activity that triggered the event.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Activity ID
    rank: 1000
    alias: activity_id
    owner: Authentication
    domain_of:
    - BaseEvent
    - ApiActivity
    - ApplicationError
    - ApplicationLifecycle
    - DatastoreActivity
    - FileHosting
    - ScanActivity
    - WebResourceAccessActivity
    - WebResourcesActivity
    - DiscoveryEvent
    - DiscoveryResult
    - DataSecurityFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    - AccountChange
    - Authentication
    - AuthorizeSession
    - EntityManagement
    - GroupManagement
    - UserAccess
    - DhcpActivity
    - DnsActivity
    - EmailActivity
    - EmailFileActivity
    - EmailUrlActivity
    - FtpActivity
    - HttpActivity
    - NetworkActivity
    - NetworkFileActivity
    - NtpActivity
    - RdpActivity
    - SmbActivity
    - SshActivity
    - TunnelActivity
    - RemediationActivity
    - EventLogActvity
    - FileActivity
    - KernelActivity
    - KernelExtensionActivity
    - MemoryActivity
    - ModuleActivity
    - PeripheralActivity
    - ProcessActivity
    - ScheduledJobActivity
    - ScriptActivity
    - AirborneBroadcastActivity
    - DroneFlightsActivity
    - RegistryKeyActivity
    - RegistryValueActivity
    - WindowsResourceActivity
    - WindowsServiceActivity
    range: AuthenticationActivityIdEnum
    required: true
  auth_factors:
    name: auth_factors
    annotations:
      group:
        tag: group
        value: context
    description: 'Describes a category of methods used for identity verification in
      an

      authentication attempt.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Authentication Factors
    rank: 1000
    alias: auth_factors
    owner: Authentication
    domain_of:
    - Idp
    - AccountChange
    - Authentication
    range: AuthFactor
    multivalued: true
  auth_protocol:
    name: auth_protocol
    annotations:
      group:
        tag: group
        value: primary
    description: 'The authentication protocol as defined by the caption of

      <code>auth_protocol_id</code>. In the case of <code>Other</code>, it is defined

      by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Auth Protocol
    rank: 1000
    alias: auth_protocol
    owner: Authentication
    domain_of:
    - Scim
    - Sso
    - Authentication
    - DroneFlightsActivity
    range: string
    recommended: true
  auth_protocol_id:
    name: auth_protocol_id
    annotations:
      group:
        tag: group
        value: primary
    description: 'The normalized identifier of the authentication protocol used to
      create the

      user session.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Auth Protocol ID
    rank: 1000
    alias: auth_protocol_id
    owner: Authentication
    domain_of:
    - Scim
    - Sso
    - Authentication
    - DroneFlightsActivity
    range: AuthProtocolIdEnum
    recommended: true
  authentication_token:
    name: authentication_token
    annotations:
      group:
        tag: group
        value: context
    description: 'The authentication token, ticket, or assertion, e.g. <code>Kerberos</code>,

      <code>OIDC</code>, <code>SAML</code>.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Authentication Token
    rank: 1000
    alias: authentication_token
    owner: Authentication
    domain_of:
    - Authentication
    range: AuthenticationToken
  certificate:
    name: certificate
    annotations:
      group:
        tag: group
        value: primary
    description: 'The certificate associated with the authentication or pre-authentication

      (Kerberos).'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Certificate
    rank: 1000
    alias: certificate
    owner: Authentication
    domain_of:
    - Sso
    - Tls
    - DigitalSignature
    - Authentication
    range: Certificate
    recommended: true
  dst_endpoint:
    name: dst_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: The endpoint to which the authentication was targeted.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Destination Endpoint
    rank: 1000
    alias: dst_endpoint
    owner: Authentication
    domain_of:
    - Evidences
    - LoadBalancer
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourcesActivity
    - DataSecurityFinding
    - Authentication
    - AuthorizeSession
    - NetworkEvent
    - DhcpActivity
    - DnsActivity
    - EmailActivity
    - NetworkActivity
    - NetworkFileActivity
    - TunnelActivity
    - EventLogActvity
    - UnmannedSystemsEvent
    - AirborneBroadcastActivity
    range: NetworkEndpoint
    recommended: true
  is_cleartext:
    name: is_cleartext
    annotations:
      group:
        tag: group
        value: context
    description: 'Indicates whether the credentials were passed in clear text.<p><b>Note:</b>

      True if the credentials were passed in a clear text protocol such as FTP or

      TELNET, or if Windows detected that a user''s logon password was passed to the

      authentication package in clear text.</p>'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Cleartext Credentials
    rank: 1000
    alias: is_cleartext
    owner: Authentication
    domain_of:
    - Authentication
    range: boolean
  is_mfa:
    name: is_mfa
    annotations:
      group:
        tag: group
        value: primary
    description: Indicates whether Multi Factor Authentication was used during authentication.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Multi Factor Authentication
    rank: 1000
    alias: is_mfa
    owner: Authentication
    domain_of:
    - Session
    - Authentication
    range: boolean
    recommended: true
  is_new_logon:
    name: is_new_logon
    annotations:
      group:
        tag: group
        value: context
    description: Indicates logon is from a device not seen before or a first time
      account logon.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - New Logon
    rank: 1000
    alias: is_new_logon
    owner: Authentication
    domain_of:
    - Authentication
    range: boolean
  is_remote:
    name: is_remote
    annotations:
      group:
        tag: group
        value: primary
    description: The attempted authentication is over a remote connection.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Remote
    rank: 1000
    alias: is_remote
    owner: Authentication
    domain_of:
    - Session
    - Authentication
    range: boolean
    recommended: true
  logon_process:
    name: logon_process
    annotations:
      group:
        tag: group
        value: context
    description: The trusted process that validated the authentication credentials.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Logon Process
    rank: 1000
    alias: logon_process
    owner: Authentication
    domain_of:
    - Authentication
    range: Process
  logon_type:
    name: logon_type
    annotations:
      group:
        tag: group
        value: primary
    description: 'The logon type, normalized to the caption of the logon_type_id value.
      In the

      case of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Logon Type
    rank: 1000
    alias: logon_type
    owner: Authentication
    domain_of:
    - Authentication
    range: string
    recommended: true
  logon_type_id:
    name: logon_type_id
    annotations:
      group:
        tag: group
        value: primary
    description: The normalized logon type identifier.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Logon Type ID
    rank: 1000
    alias: logon_type_id
    owner: Authentication
    domain_of:
    - Authentication
    range: LogonTypeIdEnum
    recommended: true
  service:
    name: service
    annotations:
      group:
        tag: group
        value: primary
    description: The service or gateway to which the user or process is being authenticated
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Service
    rank: 1000
    alias: service
    owner: Authentication
    domain_of:
    - QueryEvidence
    - Span
    - Trace
    - Api
    - MessageContext
    - ServiceQuery
    - Authentication
    range: Service
    recommended: true
  session:
    name: session
    annotations:
      group:
        tag: group
        value: primary
    description: The authenticated user or service session.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Session
    rank: 1000
    alias: session
    owner: Authentication
    domain_of:
    - QueryEvidence
    - Actor
    - NetworkConnectionInfo
    - Process
    - SessionQuery
    - Authentication
    - AuthorizeSession
    - TunnelActivity
    range: Session
    recommended: true
  status_detail:
    name: status_detail
    annotations:
      group:
        tag: group
        value: primary
    description: 'The details about the authentication request. For example, possible
      details for

      Windows logon or logoff events

      are:<ul><li>Success</li><ul><li>LOGOFF_USER_INITIATED</li><li>LOGOFF_OTHER</li></ul><li>Failure</li><ul><li>USER_DOES_NOT_EXIST</li><li>INVALID_CREDENTIALS</li><li>ACCOUNT_DISABLED</li><li>ACCOUNT_LOCKED_OUT</li><li>PASSWORD_EXPIRED</li></ul></ul>'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status Detail
    rank: 1000
    alias: status_detail
    owner: Authentication
    domain_of:
    - Compliance
    - LoadBalancer
    - BaseEvent
    - Authentication
    - EventLogActvity
    range: string
    recommended: true
  user:
    name: user
    annotations:
      group:
        tag: group
        value: primary
    description: The subject (user/role or account) to authenticate.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - User
    rank: 1000
    alias: user
    owner: Authentication
    domain_of:
    - QueryEvidence
    - Actor
    - Evidences
    - Job
    - ManagedEntity
    - Process
    - UserInventory
    - UserQuery
    - IamAnalysisFinding
    - AccountChange
    - Authentication
    - AuthorizeSession
    - GroupManagement
    - UserAccess
    - RdpActivity
    - TunnelActivity
    range: User
    required: true
  actor:
    name: actor
    annotations:
      group:
        tag: group
        value: context
    description: 'The actor object describes details about the user/role/process that
      was the

      source of the activity. Note that this is not the threat actor of a campaign

      but may be part of a campaign.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Actor
    rank: 1000
    alias: actor
    owner: Authentication
    domain_of:
    - Evidences
    - HostProfile
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - ConfigState
    - DeviceConfigStateChange
    - InventoryInfo
    - OsintInventoryInfo
    - SoftwareInfo
    - UserInventory
    - DataSecurityFinding
    - IamEvent
    - NetworkFileActivity
    - SystemEvent
    - EventLogActvity
    - FileActivity
    - KernelExtensionActivity
    - ModuleActivity
    - ProcessActivity
    - ScheduledJobActivity
    - RegistryKeyActivity
    - RegistryValueActivity
    range: Actor
    recommended: true
  http_request:
    name: http_request
    annotations:
      group:
        tag: group
        value: context
    description: Details about the underlying HTTP request.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - HTTP Request
    rank: 1000
    alias: http_request
    owner: Authentication
    domain_of:
    - Evidences
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourceAccessActivity
    - WebResourcesActivity
    - IamEvent
    - HttpActivity
    range: HttpRequest
  http_response:
    name: http_response
    annotations:
      group:
        tag: group
        value: context
    description: Details about the underlying HTTP response.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - HTTP Response
    rank: 1000
    alias: http_response
    owner: Authentication
    domain_of:
    - Evidences
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourceAccessActivity
    - WebResourcesActivity
    - IamEvent
    - HttpActivity
    range: HttpResponse
  src_endpoint:
    name: src_endpoint
    annotations:
      group:
        tag: group
        value: primary
    description: Details about the source of the IAM activity.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Source Endpoint
    rank: 1000
    alias: src_endpoint
    owner: Authentication
    domain_of:
    - Evidences
    - ApiActivity
    - DatastoreActivity
    - FileHosting
    - WebResourceAccessActivity
    - WebResourcesActivity
    - DataSecurityFinding
    - IamEvent
    - NetworkEvent
    - DhcpActivity
    - EmailActivity
    - NetworkActivity
    - NetworkFileActivity
    - TunnelActivity
    - EventLogActvity
    - UnmannedSystemsEvent
    - AirborneBroadcastActivity
    - DroneFlightsActivity
    range: NetworkEndpoint
    recommended: true
  activity_name:
    name: activity_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event activity name, as defined by the activity_id.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Activity
    rank: 1000
    alias: activity_name
    owner: Authentication
    domain_of:
    - BaseEvent
    - DataSecurityFinding
    - Finding
    - IncidentFinding
    range: string
  category_name:
    name: category_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event category name, as defined by category_uid value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Category
    rank: 1000
    alias: category_name
    owner: Authentication
    domain_of:
    - BaseEvent
    range: string
  category_uid:
    name: category_uid
    annotations:
      group:
        tag: group
        value: classification
    description: The category unique identifier of the event.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Category ID
    rank: 1000
    alias: category_uid
    owner: Authentication
    domain_of:
    - BaseEvent
    range: BaseEventCategoryUidEnum
    required: true
  class_name:
    name: class_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event class name, as defined by class_uid value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Class
    rank: 1000
    alias: class_name
    owner: Authentication
    domain_of:
    - BaseEvent
    range: string
  class_uid:
    name: class_uid
    annotations:
      group:
        tag: group
        value: classification
    description: 'The unique identifier of a class. A class describes the attributes
      available in

      an event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Class ID
    rank: 1000
    alias: class_uid
    owner: Authentication
    domain_of:
    - BaseEvent
    range: BaseEventClassUidEnum
    required: true
  count:
    name: count
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The number of times that events in the same logical group occurred
      during the

      event <strong>Start Time</strong> to <strong>End Time</strong> period.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Count
    rank: 1000
    alias: count
    owner: Authentication
    domain_of:
    - Observation
    - RelatedEvent
    - Session
    - DiscoveryDetails
    - UnmannedSystemOperatingArea
    - BaseEvent
    range: integer
  duration:
    name: duration
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The event duration or aggregate time, the amount of time the event
      covers from

      <code>start_time</code> to <code>end_time</code> in milliseconds.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Duration Milliseconds
    rank: 1000
    alias: duration
    owner: Authentication
    domain_of:
    - Span
    - Timespan
    - Trace
    - FirewallRule
    - BaseEvent
    - ScanActivity
    range: integer
  end_time:
    name: end_time
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The end time of a time period, or the time of the most recent event
      included in

      the aggregate event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - End Time
    rank: 1000
    alias: end_time
    owner: Authentication
    domain_of:
    - Span
    - Timespan
    - Trace
    - NetworkTraffic
    - UnmannedSystemOperatingArea
    - MalwareScanInfo
    - BaseEvent
    - ScanActivity
    - Finding
    - IncidentFinding
    range: TimestampT
  enrichments:
    name: enrichments
    annotations:
      group:
        tag: group
        value: context
    description: 'The additional information from an external data source, which is
      associated

      with the event or a finding. For example add location information for the IP

      address in the DNS answers:</p><code>[{"name": "answers.ip", "value":

      "92.24.47.250", "type": "location", "data": {"city": "Socotra", "continent":

      "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc":

      "Yemen"}}]</code>'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Enrichments
    rank: 1000
    alias: enrichments
    owner: Authentication
    domain_of:
    - BaseEvent
    range: Enrichment
    multivalued: true
  message:
    name: message
    annotations:
      group:
        tag: group
        value: primary
    description: The description of the event/finding, as defined by the source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Message
    rank: 1000
    alias: message
    owner: Authentication
    domain_of:
    - Response
    - Span
    - HttpResponse
    - LoadBalancer
    - BaseEvent
    - ApplicationError
    range: string
    recommended: true
  metadata:
    name: metadata
    annotations:
      group:
        tag: group
        value: context
    description: The metadata associated with the event or a finding.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Metadata
    rank: 1000
    alias: metadata
    owner: Authentication
    domain_of:
    - BaseEvent
    range: Metadata
    required: true
  observables:
    name: observables
    annotations:
      group:
        tag: group
        value: primary
    description: The observables associated with the event or a finding.
    notes:
    - 'OCSF Observables FAQ 

      https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md'
    from_schema: https://w3id.org/lmodel/ocsf
    see_also:
    - https://github.com/ocsf/ocsf-docs/blob/main/articles/defining-and-using-observables.md
    aliases:
    - Observables
    rank: 1000
    alias: observables
    owner: Authentication
    domain_of:
    - RelatedEvent
    - BaseEvent
    range: Observable
    recommended: true
    multivalued: true
  raw_data:
    name: raw_data
    annotations:
      group:
        tag: group
        value: context
    description: The raw event/finding data as received from the source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data
    rank: 1000
    alias: raw_data
    owner: Authentication
    domain_of:
    - BaseEvent
    range: string
  raw_data_hash:
    name: raw_data_hash
    annotations:
      group:
        tag: group
        value: context
    description: The hash, which describes the content of the raw_data field.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data Hash
    rank: 1000
    alias: raw_data_hash
    owner: Authentication
    domain_of:
    - BaseEvent
    range: Fingerprint
  raw_data_size:
    name: raw_data_size
    annotations:
      group:
        tag: group
        value: context
    description: The size of the raw data which was transformed into an OCSF event,
      in bytes.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Raw Data Size
    rank: 1000
    alias: raw_data_size
    owner: Authentication
    domain_of:
    - BaseEvent
    range: integer
  severity:
    name: severity
    annotations:
      group:
        tag: group
        value: classification
    description: 'The event/finding severity, normalized to the caption of the

      <code>severity_id</code> value. In the case of ''Other'', it is defined by the

      source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Severity
    rank: 1000
    alias: severity
    owner: Authentication
    domain_of:
    - Osint
    - RelatedEvent
    - VendorAttributes
    - Vulnerability
    - Check
    - Cvss
    - KbArticle
    - Malware
    - BaseEvent
    range: string
  severity_id:
    name: severity_id
    annotations:
      group:
        tag: group
        value: classification
    description: '<p>The normalized identifier of the event/finding severity.</p>The
      normalized

      severity is a measurement the effort and expense required to manage and resolve

      an event or incident. Smaller numerical values represent lower impact events,

      and larger numerical values represent higher impact events.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Severity ID
    rank: 1000
    alias: severity_id
    owner: Authentication
    domain_of:
    - Osint
    - RelatedEvent
    - VendorAttributes
    - Check
    - Malware
    - BaseEvent
    range: SeverityIdEnum
    required: true
  start_time:
    name: start_time
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The start time of a time period, or the time of the least recent
      event included

      in the aggregate event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Start Time
    rank: 1000
    alias: start_time
    owner: Authentication
    domain_of:
    - Span
    - Timespan
    - Trace
    - NetworkTraffic
    - UnmannedSystemOperatingArea
    - MalwareScanInfo
    - BaseEvent
    - ScanActivity
    - Finding
    - IncidentFinding
    range: TimestampT
  status:
    name: status
    annotations:
      group:
        tag: group
        value: primary
    description: 'The event status, normalized to the caption of the status_id value.
      In the case

      of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status
    rank: 1000
    alias: status
    owner: Authentication
    domain_of:
    - RelatedEvent
    - Ticket
    - Whois
    - AdditionalRestriction
    - Check
    - Compliance
    - DataClassification
    - HttpResponse
    - BaseEvent
    - Finding
    - IncidentFinding
    - DroneFlightsActivity
    range: string
    recommended: true
  status_code:
    name: status_code
    annotations:
      group:
        tag: group
        value: primary
    description: 'The event status code, as reported by the event source.<br /><br
      />For example,

      in a Windows Failed Authentication event, this would be the value of ''Failure

      Code'', e.g. 0x18.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status Code
    rank: 1000
    alias: status_code
    owner: Authentication
    domain_of:
    - Span
    - Compliance
    - BaseEvent
    - EventLogActvity
    range: string
    recommended: true
  status_id:
    name: status_id
    annotations:
      group:
        tag: group
        value: primary
    description: The normalized identifier of the event status.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Status ID
    rank: 1000
    alias: status_id
    owner: Authentication
    domain_of:
    - Ticket
    - AdditionalRestriction
    - Check
    - Compliance
    - DataClassification
    - BaseEvent
    - Finding
    - IncidentFinding
    - RemediationActivity
    - DroneFlightsActivity
    range: StatusIdEnum
    recommended: true
  time:
    name: time
    annotations:
      group:
        tag: group
        value: occurrence
    description: The normalized event occurrence time or the finding creation time.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Event Time
    rank: 1000
    alias: time
    owner: Authentication
    domain_of:
    - TransformationInfo
    - BaseEvent
    range: TimestampT
    required: true
  timezone_offset:
    name: timezone_offset
    annotations:
      group:
        tag: group
        value: occurrence
    description: 'The number of minutes that the reported event <code>time</code>
      is ahead or

      behind UTC, in the range -1,080 to +1,080.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Timezone Offset
    rank: 1000
    alias: timezone_offset
    owner: Authentication
    domain_of:
    - BaseEvent
    range: integer
    recommended: true
  type_name:
    name: type_name
    annotations:
      group:
        tag: group
        value: classification
    description: The event/finding type name, as defined by the type_uid.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type Name
    rank: 1000
    alias: type_name
    owner: Authentication
    domain_of:
    - RelatedEvent
    - BaseEvent
    range: string
  type_uid:
    name: type_uid
    annotations:
      group:
        tag: group
        value: classification
    description: 'The event/finding type ID. It identifies the event''s semantics
      and structure.

      The value is calculated by the logging system as: <code>class_uid * 100 +

      activity_id</code>.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Type ID
    rank: 1000
    alias: type_uid
    owner: Authentication
    domain_of:
    - Observable
    - RelatedEvent
    - BaseEvent
    range: integer
    required: true
  unmapped:
    name: unmapped
    annotations:
      group:
        tag: group
        value: context
    description: 'The attributes that are not mapped to the event schema. The names
      and values of

      those attributes are specific to the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Unmapped Data
    rank: 1000
    alias: unmapped
    owner: Authentication
    domain_of:
    - BaseEvent
    range: Object
  api:
    name: api
    annotations:
      group:
        tag: group
        value: context
    description: Describes details about a typical API (Application Programming Interface)
      call.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - API Details
    rank: 1000
    alias: api
    owner: Authentication
    domain_of:
    - Evidences
    - CloudProfile
    - ApiActivity
    range: Api
  cloud:
    name: cloud
    annotations:
      group:
        tag: group
        value: primary
    description: 'Describes details about the Cloud environment where the event or
      finding was

      created.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Cloud
    rank: 1000
    alias: cloud
    owner: Authentication
    domain_of:
    - CloudProfile
    - CloudResourcesInventoryInfo
    range: Cloud
    required: true
  device:
    name: device
    description: An addressable device, computer system or host.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Device
    rank: 1000
    alias: device
    owner: Authentication
    domain_of:
    - AuthFactor
    - Evidences
    - Logger
    - ManagedEntity
    - HostProfile
    - ConfigState
    - DeviceConfigStateChange
    - EvidenceInfo
    - InventoryInfo
    - PatchState
    - SoftwareInfo
    - DataSecurityFinding
    - Finding
    - RdpActivity
    - TunnelActivity
    - SystemEvent
    - EventLogActvity
    range: Device
    recommended: true
  osint:
    name: osint
    annotations:
      group:
        tag: group
        value: primary
    description: 'The OSINT (Open Source Intelligence) object contains details related
      to an

      indicator such as the indicator itself, related indicators, geolocation,

      registrar information, subdomains, analyst commentary, and other contextual

      information. This information can be used to further enrich a detection or

      finding by providing decisioning support to other analysts and engineers.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - OSINT
    rank: 1000
    alias: osint
    owner: Authentication
    domain_of:
    - OsintProfile
    - OsintInventoryInfo
    range: Osint
    required: true
    multivalued: true
  action:
    name: action
    description: The normalized caption of <code>action_id</code>.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Action
    rank: 1000
    alias: action
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    range: string
  action_id:
    name: action_id
    annotations:
      sibling:
        tag: sibling
        value: action
    description: 'The action taken by a control or other policy-based system leading
      to an

      outcome or disposition. An unknown action may still correspond to a known

      disposition. Refer to <code>disposition_id</code> for the outcome of the

      action.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Action ID
    rank: 1000
    alias: action_id
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    range: ActionIdEnum
    recommended: true
  attacks:
    name: attacks
    description: 'An array of MITRE ATT&CK® objects describing identified tactics,
      techniques &

      sub-techniques. The objects are compatible with MITRE ATLAS™ tactics,

      techniques & sub-techniques.'
    notes:
    - MITRE ATT&CK® — https://attack.mitre.org
    - MITRE ATLAS — https://atlas.mitre.org/matrices/ATLAS
    from_schema: https://w3id.org/lmodel/ocsf
    see_also:
    - https://attack.mitre.org
    - https://atlas.mitre.org/matrices/ATLAS
    aliases:
    - MITRE ATT&CK® and ATLAS™ Details
    rank: 1000
    alias: attacks
    owner: Authentication
    domain_of:
    - Osint
    - RelatedEvent
    - FindingInfo
    - SecurityControlProfile
    - IncidentFinding
    - SecurityFinding
    range: Attack
    multivalued: true
  authorizations:
    name: authorizations
    description: 'Provides details about an authorization, such as authorization outcome,
      and any

      associated policies related to the activity/event.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Authorization Information
    rank: 1000
    alias: authorizations
    owner: Authentication
    domain_of:
    - Actor
    - SecurityControlProfile
    range: Authorization
    multivalued: true
  confidence:
    name: confidence
    annotations:
      group:
        tag: group
        value: context
    description: 'The confidence, normalized to the caption of the confidence_id value.
      In the

      case of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence
    rank: 1000
    alias: confidence
    owner: Authentication
    domain_of:
    - Osint
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: string
  confidence_id:
    name: confidence_id
    annotations:
      group:
        tag: group
        value: context
    description: 'The normalized confidence refers to the accuracy of the rule that
      created the

      finding. A rule with a low confidence means that the finding scope is wide and

      may create finding reports that may not be malicious in nature.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence ID
    rank: 1000
    alias: confidence_id
    owner: Authentication
    domain_of:
    - Osint
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: ConfidenceIdEnum
    recommended: true
  confidence_score:
    name: confidence_score
    annotations:
      group:
        tag: group
        value: context
    description: The confidence score as reported by the event source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Confidence Score
    rank: 1000
    alias: confidence_score
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - Finding
    - IncidentFinding
    - SecurityFinding
    range: integer
  disposition:
    name: disposition
    description: 'The disposition name, normalized to the caption of the disposition_id
      value. In

      the case of ''Other'', it is defined by the event source.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Disposition
    rank: 1000
    alias: disposition
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    range: string
  disposition_id:
    name: disposition_id
    annotations:
      sibling:
        tag: sibling
        value: disposition
    description: 'Describes the outcome or action taken by a security control, such
      as access

      control checks, malware detections or various types of policy violations.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Disposition ID
    rank: 1000
    alias: disposition_id
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    range: DispositionIdEnum
    recommended: true
  firewall_rule:
    name: firewall_rule
    description: 'The firewall rule that pertains to the control that triggered the
      event, if

      applicable.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Firewall Rule
    rank: 1000
    alias: firewall_rule
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    range: FirewallRule
  is_alert:
    name: is_alert
    description: 'Indicates that the event is considered to be an alertable signal.
      Should be set

      to <code>true</code> if <code>disposition_id = Alert</code> among other

      dispositions, and/or <code>risk_level_id</code> or <code>severity_id</code>
      of

      the event is elevated. Not all control events will be alertable, for example
      if

      <code>disposition_id = Exonerated</code> or <code>disposition_id =

      Allowed</code>.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Alert
    rank: 1000
    alias: is_alert
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    range: boolean
    recommended: true
  malware:
    name: malware
    description: A list of Malware objects, describing details about the identified
      malware.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Malware
    rank: 1000
    alias: malware
    owner: Authentication
    domain_of:
    - Osint
    - SecurityControlProfile
    - DetectionFinding
    - SecurityFinding
    range: Malware
    multivalued: true
  malware_scan_info:
    name: malware_scan_info
    description: 'Describes details about the scan job that identified malware on
      the target

      system.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Malware Scan Info
    rank: 1000
    alias: malware_scan_info
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    - DetectionFinding
    range: MalwareScanInfo
  policy:
    name: policy
    description: 'The policy that pertains to the control that triggered the event,
      if

      applicable. For example the name of an anti-malware policy or an access control

      policy.'
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Policy
    rank: 1000
    alias: policy
    owner: Authentication
    domain_of:
    - PermissionAnalysisResult
    - AdditionalRestriction
    - Assessment
    - Authorization
    - DataClassification
    - DataSecurity
    - ManagedEntity
    - SecurityControlProfile
    - ScanActivity
    - AccountChange
    range: Policy
  risk_details:
    name: risk_details
    annotations:
      group:
        tag: group
        value: context
    description: Describes the risk associated with the finding.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Details
    rank: 1000
    alias: risk_details
    owner: Authentication
    domain_of:
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    range: string
  risk_level:
    name: risk_level
    annotations:
      group:
        tag: group
        value: context
    description: The risk level, normalized to the caption of the risk_level_id value.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Level
    rank: 1000
    alias: risk_level
    owner: Authentication
    domain_of:
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: string
  risk_level_id:
    name: risk_level_id
    annotations:
      group:
        tag: group
        value: context
    description: The normalized risk level id.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Level ID
    rank: 1000
    alias: risk_level_id
    owner: Authentication
    domain_of:
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: RiskLevelIdEnum
  risk_score:
    name: risk_score
    annotations:
      group:
        tag: group
        value: context
    description: The risk score as reported by the event source.
    from_schema: https://w3id.org/lmodel/ocsf
    aliases:
    - Risk Score
    rank: 1000
    alias: risk_score
    owner: Authentication
    domain_of:
    - Osint
    - ApplicationObject
    - User
    - Device
    - SecurityControlProfile
    - DataSecurityFinding
    - DetectionFinding
    - SecurityFinding
    range: integer
rules:
- postconditions:
    any_of:
    - slot_conditions:
        service:
          name: service
          required: true
    - slot_conditions:
        dst_endpoint:
          name: dst_endpoint
          required: true
  description: 'OCSF at_least_one: at least one of [''service'', ''dst_endpoint'']
    must be set.'